KDE 4.6 RC2

Just upgraded to KDE SC 4.6 RC2 from RC1. KDE Factory repo has just been populated with RC2 (4.5.95). Had no issues ATM and everything is very stable. I am very impressed :slight_smile:

Thanks for the thread.
Before i jump into the sea, i need to know few issues which was there in RC1, and forced me to go back to 4.5. Sound? and system tray behavior?, they are back to normal?

Sound is working fine here. I haven’t noticed anything wrong in system tray behavior. Was there something wrong with system tray behavior? Because I didn’t know about it :slight_smile:

I am updating ATM. Hope to have smooth transition.
Sound was gone as many noticed in RC1, and system tray was unusable because of missing icons, not starting up at startup etc, have to add manually every time KDE starts with missing icons.

I had sound in RC1 I just had to say “Yes” to that dialog box when you first log on to the desktop to remove the duplicate sound device. I don’t know why a duplicate sound device was created. Maybe a bug?

Everything for the most part seems fine to me a tad faster than 4.5

Only issue so far is, after viewing images in gwenview, closing dolphin will pop up the Dolphin KDE crash handler.

Also kdesu systemsettings does not work for me.

Those are the only two issues I have seen so far.

Looks OK so far but I’ll have to leave it running for a while to see how
kwin behaves. I noticed yesterday that the memory it was using was a little
over 1 GiB. This was just before the system froze and I had to reboot via
the power switch.

Graham Davis, Bracknell, Berks. E-mail: change boy to man

closing dolphin will pop up the Dolphin KDE crash handler

Same here every time i close dolphin. It was solved in RC1(may be for me).
Display brightness doesn’t seem to save the values, every time i start plasma it will go back to the default settings.(system tray-> battery icon-> screen brightness)

One thing, which really impressed me is search in dolphin, its quite fast and w/o enabling Nepomuk will work. Search results can list folders too now. That’s great improvement.

Still exploring it…

Moved to M5 yesterday, to KDE4 4.6 RC2 today. Sound issue still exists. I hacked it by downgrading the phonon packages, this brings back the device that gives me music :).

I have one strange issue though: If I start Yast modules from the Control Centre or through ‘kdesu yast2’ the widgets are not the oxygen ones, it looks a bit qt3-ish…; if I start the Control Centre through ‘su -c yast2’ it’s OK. Anyone else seeing this?

For the rest: I decided to start on a clean ~/.kde4 folder and copy over the necessary stuff from my previous ~/.kde4. I’m impressed by the relaxed beauty and simplicity of the defaults.

My sound’s back and it’s fast!
I think I’ll try it on my main 11.3 partition too.

Same thing here with Yast.

Running smoothly here, no k3b, Sound Devices(VLC Backend) solved!

Thanks openSUSE & KDE Teams, I love linux because of you!!

Upgraded 4.5.80 → 4.6 RC2 on 11.3 test machine, with (latest) 2.6.37 released kernel. Very smooth, no situations ATM. Touchpad accelertion needed adjustment (seemed to be quicker and “slipperier” on RC2).

Upgraded on 11.4, also with latest 2.6.37 kernel, only similar touchpad problems, adjusted.

Next: upgrade 11.4 with Factory Xorg (Intel driver → 2.13.903, Mesa – > 7.9.802-54.1).

Note: An earlier post referenced YAST as appearing more “qt-ish”. It seems so, crisper while not unpleasant.

I installed 4.6 RC2 on 11.3. Sound was working but not with flash videos. Anyone know how to get sound to work with flash?

The upgrade of KDE 4.5.80 → 4.6 RC2 on 11.3 test machine, with (latest) 2.6.37 released kernel continues well, with two (2) minor problems:

  1. Screensavers do not work. At the appointed interal (set at 10 minutes), the screen just goes blank. The screen is immediately restored via the keyboard/touchpad. Also, the monitor will go into powersave 20 minutes (as set) after the screensaver.

  2. (This may seem picayune). In the KPatience card game, at least one of the 12 selectable games (Forty & Eight) does not work. That sounds totally earth-shattering, but the manner of failure is curious: cards either disappear, fly out of the window to the right or change in size. (I can wit: no bugzilla for a card game!).

Same behavior observed on 11.4 MS5 standard machine. However, on the 11.4 with Factory Xorg (Intel driver → 2.13.903, Mesa – > 7.9.802-54.1), the attempt to switch system packages to the KDE Factory results in more dependency errors than I have seen (more than 50, last count). Problems with* libxml*, shared-mime and more.

MS6 is around the corner, so I will re-attempt KDE 4.6 RC2 on the fresh install, after the Xorg Factory upgrade.

I’m still on 4.5.5 and yesterday’s update killed sound in flash. Luckily, a reboot restored it. Might work for you.

Doh! The videos I was watching the first time didn’t have any sound. I tried some other videos and sound is working fine.

Has anyone else experienced a segmentation fault on 4.6 RC2 when they go to Configure Desktop -> Locale?

Yep. See: https://bugs.kde.org/show_bug.cgi?id=262488

Well now I see your post, I have KDE 4.5.5. I thing also KDE 4.6 is stable and efficient as 4.4 and 4.5. When I upgrade to OpenSuse 11,4 I upgrade also KDE to 4.6 vesion. Thanks!!!

Always Friendly!!!

Linux rocks Opensuse rules