kde 4.6 Networkmanagement button "Enable wireless" not active

After updating two days ago, I found that I cannot enable wireless.
I went through all the steps in the sticky post at the beggining of this forum. Everything seems to be in place.

root # dmesg | grep WLAN
   10.295168] b43-phy0: Broadcom 4311 WLAN found (core revision 10)

root # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
vboxnet0  no wireless extensions.

pan0      no wireless extensions.
root # iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down

vboxnet0  Interface doesn't support scanning.

pan0      Interface doesn't support scanning.

Any idea? If I have to provide more info, please, tell me.
Thanks a lot.

Some things to try:

If you have “rfkill” installed, then run


/usr/sbin/rfkill list

If it is not installed, try installing it via a wired connection.

If there’s an Fn key combination for your system that turns WiFi on or off, try using that key combination.

Thanks. Now everything works perfectly. I feel very silly, but as I have always the wifi on I didn’t realize that somebody or something had switched it off.
Sorry for making you lose your time.

Anyway, I took advantage to install rfkill which I didn’t know. Thanks.

I’m glad you have it working.