KDE 4.6 Desktop Background Satellite view Globe

No problems, everything works as intended! One small thing bothers me, how can I turn off the ugly red labels for the continents? I cannot find this option anywhere!

That’s what I would like to know too. It doesn’t seem to be possible.

****! but “impossible” is not the linux way! is the satellite image uploaded from google earth? where can I find out more info about this feature?

Hello kstaz,

Your right, it isn’t impossible but not easy.

What I did is change the bluemarble theme, removing all the geographical information.
To do this open the file /usr/share/kde4/apps/marble/data/maps/earth/bluemarble/bluemarble.dmgl.
You need root privileges in order to change this file.

Completely delete this section:

            <layer name="standardplaces" backend="geodata">
                <geodata name="cityplacemarks">
                    <sourcefile format="KML">cityplacemarks.kml</sourcefile>
                    <pick>placemark</pick> <!-- picks certain features from a
                                            file -->
                <geodata name="baseplacemarks">
                    <sourcefile format="KML">baseplacemarks.kml</sourcefile>
                <geodata name="elevplacemarks">
                    <sourcefile format="KML">elevplacemarks.kml</sourcefile>
                <geodata name="observatoryplacemarks">
                    <sourcefile format="KML">observatoryplacemarks.kml</sourcefile>
                <geodata name="otherplacemarks">
                <geodata name="boundaryplacemarks">
                    <sourcefile format="KML">boundaryplacemarks</sourcefile>

The theme needs to be reloaded in order to see the changes.
Either log-out and log-in again or change the theme to a different one and change it back.

Good luck!:wink:


Of course it works only for that map-theme (is that the right word?) and the normal Marble is affected too. But these are things can be circumnavigated, I think if you made a “fork” of a map-theme that just lacks these placemarks.

Well you can temporarily disable the continent labels by choosing “Legend” on the left and un-checking “Terrain” (that will also hide the Mountain labels and volcano labels at the same time).

Edward: that’s a bit brute force :wink: If you want to disable the terrain labels by default then you can also just change the section:

            &lt;property name="terrain"&gt;


            &lt;property name="terrain"&gt;

That should work as well.

Thanks guys! I’ve found the file, opened as root and modified in Kwrite but it will not allow me permission to save as root, even though i opened it through su terminal, I cannot save as such.
I’ve tried looking it up since yesterday and nothing is working.
Btw it looks excellent without the labels!:good:

Try Alt+F and ‘kdesu kwrite’ instead of - how did you call it? - “su terminal”.

Still does not work. What I meant to say, is at the terminal I tried to sudo open the file, and though I did I wasn’t able to write to root as root. I don’t get whats wrong, and why I dont have permission to do so…

On 07/09/2011 06:36 AM, kstaz wrote:
> I don’t get whats wrong, and why I dont have permission to do so…

do this in a terminal:

kdesu kwrite

give your root password when asked, then KWrite will open with root
powers…use it’s menu File > Open and navigate to the file to edit:

edit it as needed, save it, and close KWrite…job done.

or, if you can’t save the edited file as root, then you have FAR worse
problems than you think!


Worked beautifully, thank you!
Looks great, and a very simple fix!
I’m not used to linux yet, only really have had it for 2-3 weeks now and still working out how to use the terminal correctly & efficiently!!
Thanks again everyone, excellent work! The globe looks much better now! :good::good:

On 07/11/2011 01:36 AM, kstaz wrote:

> still working out how to use the terminal correctly& efficiently!!

good for you!

you will soon learn it is really not all that hard, (and nearly as
cool-geeky as the movies make it out to be) and in most cases far
quicker (if you KNOW what you are doing and don’t shoot yourself in the

just so you know: anytime you need to edit a configuration file as root,
you don’t actually have to even touch a terminal…

a non-terminal way to do the same thing you just did is to

-hold down Ctrl and Alt and then press the F2 key
-a small popup blank will appear near the top of your screen, in it
-type & enter kdesu kwrite
-give root password when asked
-soon a root powered KWrite pops up and you know what to do then!

easy peasy.


You certainly mean Alt+F2. Ctrl+Alt+F2 drops you at tty2.

On 07/11/2011 04:06 PM, Lord Emsworth wrote:
> You certainly mean Alt+F2. Ctrl+Alt+F2 drops you at tty2.

YES! thank you! Alt+F2 opens the run dialog…