KDE 4.6 and Network Management

I recently transitioned my 11.3 installs from 4.5 to 4.6 following the thread here:
KDE4.6 to get Release:46 repository

The upgrade on my desktop (wired only) was very smooth with few issues.

The upgrade on my HP-DV7 laptop was a bit flaky in the area of Network Management.

I had recently been having issues with knetworkmanager, where it would sometimes start up (from boot) or restart (from sleep) in a disabled state, Stopping and restarting the network service brought it back to life, but the above thread made it sort of clear that the future was plasmoid-networkmanagement, not knetworkmanager.

I was able to install plasmoid-networkmanagement and remove the knetworkmanager I had installed, but felt a bit like I was hacking at it. Adding to the confusion are similar naming for desktop elements, similar icons and the always questionable: when to log out - log in (to restart kde) and when to just reboot.

I agree with the comments (in thread) that plasmoid-networkmanagement is a superior interface and may solve issues others are having with startup under knetworkmanagement.

Under the assumption that soon to be released 11.4 will load plasmoid-networkmanagement rather than knetworkmanager as a default, I would like to suggest that someone post a new thread on the topic on the correct way to make the transition and best practices for using it. The kde46 repo (above reference) has good info but is now quite long and heads down other paths at times. I forsee many having network startup issues with the new release, getting experience now would smooth the transition.

Posting my hacking would likely confuse too many folks, it did me for a while.
That said, life is very good once 4.6 is up and running.

Well read this Αναβάθμιση Στο Τελευταίο KDE](http://forums.opensuse.org/greek/i-i-i-i/i-i-i-iui-i-i-i-i-i-i-i-i-i-i-i-i-isi-i-i-ioei-i-i-i-i/i-iui-i-i-i-i-i-i-i-documentation/453205-i-i-i-i-i-i-i-i-i-i-i-i-i-i-iui-iui-i-i-i-i-kde-2.html). Translate it, because I am Greek and all thread is in greek. Go to the second page and translate my post, it is the fast way to upgrade.

I am on 11.4-milestone6 + x86-64 and whilst the network plasmoid is better integrated, it doesn’t actually work in making connections!

I can click “manage connections” and see both wifi and vpnc configurations; if I want to view the specific configuration I need to enter my kwallet password.

However, although configurations exist, when I simply click the plasmoid’s system tray icon, none of the wifi configs not the cisco vpnc config are listed.

This worked up till milestone 5, so I don’t know what’s gone wrong. It’s very annoying as it means I have no working wifi, and I have to start vpn at command line having created a file /etc/vpnc/blahblah.conf

Any thoughts/ideas gratefully received.

Try to run this in terminal

kquitapp knetworkmanager qdbus org.kde.kded /kded loadModule networkmanagement
$ kquitapp knetworkmanager qdbus org.kde.kded /kded loadModule networkmanagement
unnamed app(9589): "Application knetworkmanager could not be found using service org.kde.knetworkmanager and path /MainApplication." 

this happens as root or logged-in user.

package installs:

# rpm -qa  |grep -i networkman

if I try and install networkmanger-kde4, I run into dependency hell:

# zypper install NetworkManager-kde4
Loading repository data...
Warning: Repository 'openSUSE-11.4-Update' appears to outdated. Consider using a different mirror or server.
Reading installed packages...
Resolving package dependencies...

Problem: NetworkManager-kde4-0.9.svn1192577-7.2.x86_64 conflicts with plasmoid-networkmanagement provided by plasmoid-networkmanagement-0.9.svn1192577-7.2.x86_64
 Solution 1: Following actions will be done:
  deinstallation of plasmoid-networkmanagement-0.9.svn1192577-7.2.x86_64
  downgrade of kaddressbook-4.5.85-1.1.x86_64 to kaddressbook-4.4.10-3.2.x86_64
  downgrade of kmail-4.5.85-1.1.x86_64 to kmail-4.4.10-3.2.x86_64
  downgrade of kontact-4.5.85-1.1.x86_64 to kontact-4.4.10-3.2.x86_64
  downgrade of korganizer-4.5.85-1.1.x86_64 to korganizer-4.4.10-3.2.x86_64
 Solution 2: do not install NetworkManager-kde4-0.9.svn1192577-7.2.x86_64

Choose from above solutions by number or cancel [1/2/c] (c): ^C

Choose cancel. And tell me the installation process of your NetworkManager.

I did cancel install. I know network manager is running:

# nm-tool

NetworkManager Tool
...snip lots...
- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlagn
  State:             disconnected
  Default:           no
  HW Address:        xx:xx:xx:xx:xx:xx

  Wireless Access Points 
    xxxxxxxxxx:   Infra, xx:xx:xx:xx:xx:xx, Freq 2437 MHz, Rate 54 Mb/s, Strength 98 WPA WPA2

# nmcli con
NAME                      UUID                                   TYPE              SCOPE    TIMESTAMP-REAL                    
Auto eth0                 xxxxxxxxxxxxxxxxxxx   802-3-ethernet    system   Tue Mar  1 12:57:18 2011          
NAME                      UUID                                   TYPE              SCOPE    TIMESTAMP-REAL          

About installation of networkmanager read this Αναβάθμιση Στο Τελευταίο KDE](http://forums.opensuse.org/greek/i-i-i-i/i-i-i-iui-i-i-i-i-i-i-i-i-i-i-i-i-isi-i-i-ioei-i-i-i-i/i-iui-i-i-i-i-i-i-i-documentation/453205-i-i-i-i-i-i-i-i-i-i-i-i-i-i-iui-iui-i-i-i-i-kde-2.html#post2284799)

please can you post a non-greek link? thanks!

p.s. I read the english bits, and those instructions seem to apply to people running 11.3 + other repos, I am on 11.4 milestone6, as up to date as I can be.

I do get offered kde4.6 upgrades from 4.5.85 but if I go for those it seems to cause chaos with a variety of other apps being downgrades to kde4.4??? :confused:

Sure here I translate it
This os the technique maybe repositories’ url has changed so go and find the repositories who you need

It is my technique to upgrade your KDE

Well first of all
open a terminal and write


add repository

# zypper addrepo -f http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.3/ KDE46

add the extra repository

# zypper addrepo -f http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.3/ KDE46-Extra

And upgrade

# zypper dup --from KDE46 --from KDE46-Extra

If you use network manager


# zypper install plasmoid-networkmanagement


kquitapp knetworkmanager qdbus org.kde.kded /kded loadModule networkmanagement

Close terminal and reboot your system.

Warning all repositories possibly change

You will check here SDB:KDE upgrade - openSUSE

I wrote again ok???

Always Friendly!!!;):slight_smile:

And read this http://www.linuxtopia.org/online_books/opensuse_guides/opensuse11.1_reference_guide/sec_basicnet_nm.html

I dist-upgraded to 4.6; I had to accept some downgrading of the kdepim packages from 4.5.x to 4.4.x but fortunately there weren’t very many that were downgraded and I don’t use the PIM features as I’m an android phone user and use google directly.

As a consequence the plasmoid internet to network manager now works fine, the kde network manager stuff seems to have disappeared entirely from my system and isn’t in the repos any more.

thanks very much for your time and efforts. I had hoped that 11.4 release would fix this problems, even though it seemed at times that everything was broken forever, so I am relieved and happy now.


Thank for all of you important discussion for me about Network Management.
have this strange behavior of networkmanager. I do not use password in kwallet for auto connection on wifi, but I setup to autoconnect and write pass for wifi in networkmanager settings, this worked in KDE 4.5.4, but now i must write pass every time when sistem starts and do that two times to connect on wifi…

Is this bug or what?