KDE 4.6.0 desktop folder shortcut problem


I’ve just built a clean install of opensuse 11.4 and have a weird problem with the plasma ‘Desktop Folder’. No shortcuts in it will work. They have little exclamation marks in the corner which pop up a warning asking if I trust the program (e.g. ‘firefox %u’). I then say yes by clicking Continue, and get a Sorry message which says:

Service ‘/home/nelson/Desktop/firefox.desktop’ must be executable to run.

The links are executable, they belong to me and I belong to the group they are assigned to. I have tried creating my own shortcuts, by dragging and from scratch, all with the same error.

I can only think that something has gone wrong at install, as I have another pc recently upgraded to 11.4, and it is fine.

Does anyone have any idea how to fix it?



Which activity type are you using?

Try folder view. Mine works perfectly

Sorry, I’m not aware of what activity type is? My desktop settings are set on the layout ‘Desktop’. I’ve tried switching to folder view, and the links still won’t run, with the same error. url type links work fine- such as the ‘My computer’ (sysinfo) and ‘Online help’ links. Also, as I said in the orginial post, I have another install of suse 11.4, kde 4.6.0, and it is fine.

I have just found an unrelated error in a forum suggesting deleting .kde/share/config/plasma-desktop-appletsrc and then restarting plasma. May give this a go, although I don’t really like the idea…

Bit the bullet and removed plasma-desktop-appletsrc, as well as plasma-appletsrc and plasma-desktoprc from my user account when logged in as root. Then relogged in- but it hasn’t fixed it. I also notice it hasn’t reinstated a copy of plasma-appletsrc- should I copy this back in?

Also, whilst logged in as root, I found that the links work fine on the desktop folder there, and didn’t have the warning exclamation mark in the bottom right corner.

So completely baffled now!

While logged in as root:

cd /home/glyn/Desktop
chown -R glyn .

See if that fixes the problem. In the above, I assume that your login name is “glyn”. Change that to whatever is the real login name for your system.

At least in my tests, I see the same behavior if those files are not owned by me. I’m guessing that you probably have a different uid than in files that were there from a previous install. You might have to fix your home directory in the same way.

Don’t login as root!

Go back to your user account. Right click the desktop and make sure the widgets are unlocked.
Now go to the application launcher and find an application you want to add to the desktop and right click it > add to desktop

Does that work?

to nrickert, I have checked that I own the links and the folder- I do, so that isn’t the problem. Also, I would expect it to give a different error message in that instance.

I have played previously with trying to upgrade Suse installs- it is not worth it- it is far less hassle to make a clean install, which is what I did, and then copy over bookmarks, Kontact data, vbox, music and photo libraries etc. So, I don’t think it is a problem with the uid being different.

To caf4926, I had previously tried dragging copies of links into the Desktop Folder, to no avail. However, copying to desktop ( a different space in plasma) as you suggest, works! Why these work and converting to a folder view desktop doesn’t, I don’t understand.

I then tried making links in the Desktop Folder to items from the application launcher, and they also work, but copying them doesn’t! There is some subtle difference which is confusing me. The links all say they belong to user root and group root, yet they work (and I do not belong to root group), whereas the shortcut desktop configuration files, which belong to me, group users, do not work. I can’t see any other difference.

So, in summary, thanks caf4926, I have a workaround to the problem! Still not sure exactly what is causing the problem though!

Got it sorted. My suspicions grew when I tried running ImageJ, which isn’t a proper install, but just an extracted folder in my home dir with a shell script. This gave a ‘bash- permission denied’ error. A few quick checks that I really did have bash (not sure linux would run without it?) and then a google search pulled up someone with a similar error for running bash scripts. It was my non root partitions fstab entries- they apparently needed specifying as having executable status in their attributes by adding ‘exec’ to the partitions attributes. My home partition now looks like this in fstab:

/dev/sda2 /home ext4 user,acl,user_xattr,exec 1 2

and it all works!

Actual reason it was broken in the first place- the only explanation I can think of is that I made a manual partition setup. As I previously described in an earlier post, I made a fresh install of suse 11.4. I was previously running Suse 11.1 and wasn’t going to risk attempting an upgrade. But, I did want to mount my old partitions, so I installed a new hard drive as sda and moved the other one to the second sata connection and set up the partitions manually when I did the install. Thought I’d been quite clever, but not clever enough!

Happy now, this was really bugging me!

It was probably that “user” that caused the problem. I have neither “user” nor “exec”, and it works fine. I’m guessing that “user” probably implies “noexec”.