kde 4.5 rc2 with 11.3

is it stable enough to make the move to kde 4.5 yet?

I get no/very few crashes, however kwin uses up a lot of my cpu, causing my computer to be slow. Though this may be due to the nvidia driver. Apart from that it’s quite stable.

KDE 4.5 rc2 is pretty good, it gives a more refined and uniform feel than 4.4 that is if you dont mind not having Kinfo and a standard KDE icon on the app launcher. I dont experience the high CPU load mentioned and Konq with webkit seems a little quicker… but I’ve only been running it for a few hours on OS 11.3 beta 2.

thanks very much for the postings - i will give it a try

Just installed openSUSE 11.3. Do you know which repos I need to enable to be able to upgrade to KDE 4.5?

I tried enabling the KDE unstable repositories, but get too many errors in YaST when I want to upgrade.

There are big moves going on, just wait until is settles down, else go to the IRC and see if the devs can answer you

i had the same problem: after running KDE unstable for a few months on 11.2, i tried to upgrade to unstable on 11.3, but it wanted to downgrade half my repos and change the others to 586 architecture. KDE factory, which will be KDE 4.5 until november i think, installs ok, but rebooting i get a weird error: ksmserver not available. .xsession-error lists a bunch of other stuff, somehow relating to some authority-file that has a different owner than KDE apparently expected. i couldn’t manage to log into KDE 4.5 after that, even though i tried all sorts of things, incl. removing the whole .kde4 dir: always the same error.

i googled for almost one night, but got only confused reports in various forums, nothing helpful–until i came across this post here: <oops, can’t find it anymore. it’s in the help forum, not beta, and an admin told the guy to move it. still, at one point somebody suggested running zypper dup. the OP tried that and it worked.

i’m trying that now, running zypper dup with all repos enabled–something i don’t normally do. but since i consider this (2nd) installation of 11.3 messed up, it can’t really hurt.

it’s still zypper-duping, i’ll post again when i know if it works or not. if not, i’ll go back to KDE 4.4, even though i had good experience with KDE 4.5 on 11.2.


yippie–it worked. i don’t really understand how zypper dup decides what to do with different repos enabled; something i’ll have to spend some time with eventually. KDE still shows it’s on 4.4.95, while i got the impression that during zypper dup some packages from 4.4 got pulled in, too. anyway, it’s working now. still can’t say how well, but on first glance everything looks ok.

so here’s what i did to get to this stage:

  1. install KDE factory repos via one-click (default & develop);
  2. everything went down the drain;
  3. zypper dup with everything enabled somehow, mysteriously, fixed my install, so that at least i can log into KDE.

if i do find further major problems, i’ll post again. if not, means everything is fine.


Im using this repositoryfor 11.2 :

Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.2

And im not getting a standard white tray icon panel. Just the usual, amarok blue, pidgin green, etc.

Try switching from kdebase4-runtime opensuse to kdebase4-runtime upstream to get the white tray icons back.