KDE 4.5 Folder view desktop. Icons in place

KDE 4.5.3. Desktop as “Folder View”, which means that you have on the desktop the files in the folder you have selected (~/Desktop in my case).
I can move those icons and place them in another part of the screen, but everytime kde starts up, they are in the upper right corner. And that happens even if the “Lock in place” option is enabled.
Is there any way to have the icons persistently in the place you want them?
Mind: I’m not talking about widgets, but icons of files (Folder View Desktop)

I just had a look and set up the desktop as a Folder View.

It seems to me that you need to set ‘Sorting’ to ‘Unsorted’, and have ‘Lock in Place’ unchecked in ‘Folder View Settings’>‘Display’.

At least it works for me, and icons that I moved to a different spot on the desktop retain their positions even after logging out and back in.

It doesn’t work for me. Don’t know why. I can just play with “Arrangement” to say if I want them top, bottom, right or left. There are worse things. :wink:

Thanks for your concern.

On Sat, 20 Nov 2010 00:06:02 +0530, Lord Emsworth
<Lord_Emsworth@no-mx.forums.opensuse.org> wrote:

> It seems to me that you need to set ‘Sorting’ to ‘Unsorted’, and have
> ‘Lock in Place’ unchecked in ‘Folder View Settings’>‘Display’.
> At least it works for me, and icons that I moved to a different spot on
> the desktop retain their positions even after logging out and back in.

same here; as long as i don’t touch the sorting choice, don’t have the
desktop crash on me, and don’t add or remove icons, it stays as it is. any
of the mentioned activities may reset all icons in whatever is the
default order. this doesn’t happen too frequently, but nevertheless
prevents me from spending much effort in fancy arrangements. for that
different folder views are better; they usually stay the way they are.


phani.

Maybe that’s the reason. I will try not to do the activities you mention. At least to see if what you say works for me too.
Thanks phanisvara

On Sat, 20 Nov 2010 01:06:01 +0530, wrbbt
<wrbbt@no-mx.forums.opensuse.org> wrote:

> It doesn’t work for me. Don’t know why. I can just play with
> “Arrangement” to say if I want them top, bottom, right or left. There
> are worse things.

if you didn’t put too much effort into your plasma setup, i’d try with a
fresh one. no need to rename all of ~/.kde4, just everything
plasma-related. (not all files start with “plasma”; there’s some that
begin with “activity”, and perhaps something else. it’s a while ago that i
last felt the need to make a backup of everything plasma. these days i
keep everything simple, not much effort to set up again.


phani.

Just to make sure that I understand you correctly. Don’t you have the setting where you can change the sorting, or does it just not work? “Sorting” is located right under “Arrangement” and you can set it to sort by name, date etc or unsorted.

Thanks phani. In the end I did what you suggest. Other small issues get resolved (though I didn’t mean it); so it was good to do it. But about the location of files on the desktop everything is the same as before.

Sorting is in “unsorted” as you suggested. Arrangement is “Top to bottom, left to right”. With these settings I can move the icons to any other spot on the desktop, but next time I start kde they are if the upper left corner of the screen.
Anyway, I’m not going to spend more time in this small thing.
Thanks, Lord_Emsworth

I’ve had the same problem since upgrading to kde4.5 and I’ve tried everything. The last thing I tried was deleting ~/.kde4/share/config/plasma-desktop-appletsrc and re-setup the desktop. Things were OK for a week and a half and it started happening again yesterday. Maybe it was just a lucky streak as it does not happen on every boot up. The icons always go to depending on how the Arrangement is set (Top to Bottom, Left to Right. etc), I have Sorting set as Unsorted. I get the feeling the Arrangement needs a None choice, which it doesn’t.

I did what you say (deleting ~/.kde4/share/config/plasma-desktop-appletsrc) but nothing changed.

I get the feeling the Arrangement needs a None choice, which it doesn’t.
I have the same feeling.
Maybe in kde4.6 it works fine. I haven’t checked.