KDE 4.5.4 white screen on login, plus more problems

i have 11.2 64bit version of openSUSE with nVidia graphic card 8600GT. Yesterday I’ve ran update via zypper and it installed kde 4.5.4, as I didn’t logout till late in the night, just now I’ve discovered that when I login into kde everything is white, I get normal notification that yakuake is started but nothing else, today’s updates didn’t solve the problem.
Any hints on how to fix this?

I’ve tried to reinstall KDE and when it “finished” and I have tried to start kde i get the following message
"Call to lnusertemp failed (temporary directories full?). Check your installation.
after this message that comes in a window, I can only choose finish to exit into console mode.

After this, I can’t log in into lxde, icewm, windowmaker or any other GUI interface or desktop environment.

Clear Temp Files at Boot

You can possibly get to that via
Boot to Level 3, then Yast and More…

Thanks for the thread about emptying the tmp. It worked, not at first but after a full shutdown and a clear head :D. Now I can enter my KDE but it will ask of me a lot of work to get all the things back on the desktop becouse everything was gone now I have to put it back together again by hand.

Great news - well done

Thanks to you, without your help it wouldn’t work!

Hello. I tried doing that and I get the same results.
I dropped to console, went root, removed /tmp , recreated it, and now i have the same problems, kde loads, kwin works, dolphin works, but plasma is unusable. It has a white background and where the widgets where it says that it cannot load the components. Krunner starts but acts like a simple input line that does nothing.

Cleaning /tmp is not the same as removing and recreating /tmp. It you really removed that directory, not just its content, the one you recreated doesn’t for sure have the correct access rights. As root, you’ll have to do:

chmod 1777 /tmp