KDE 4.4 logout problem

Hello.

While I was using KDE 4.3.5 and previous all was OK. But after upgrading to KDE 4.4.0 or 4.4.1 I’ve got a problem. When I press any logout button (logout, reboot, shutdown, etc.) nothing happens. I only hear a logout sound. After that I can continue to work as usually, but clicking logout buttons doesn’t cause logout menu. The only way to logout is to press “Ctrl+Alt+Backspace”. :frowning:

This problem appears at both my computers, where I have openSUSE 11.2.

Any ideas what to do?

sergeyopensuse wrote:
> Any ideas what to do?

bug in kernel 2.6.31.12-0.1.1.i586
see http://tinyurl.com/y9eaxp8


palladium

But my kernel version is 2.6.33. And I have this problem only in KDE. But in GNOME all is OK.

Maybe somebody knows how I can find any system messages and understand what is happening.

Post

zypper lr -d

you may have mixed repositories active.

This is the output of “zypper lr -d”:

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

—±-----------------------------------------------±-----------------------------------------------±--------±--------±---------±-------±----------------------------------------------------------------------------------------------±-------
1 | Google | Google | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |
2 | NVIDIA | NVIDIA | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.2 |
3 | download.videolan.org-SuSE | VideoLan Repository | Yes | Yes | 99 | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/ |
4 | ftp.skynet.be-suse | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.2/ |
5 | openSUSE 11.2-0 | openSUSE 11.2 | No | No | 100 | yast2 | cd:/// |
6 | openSUSE-11.2-DVD-ISO | openSUSE-11.2-DVD-ISO | Yes | No | 100 | yast2 | iso:///?iso=openSUSE-11.2-DVD-i586.iso&url=file:///home/sergey/Downloads/ |
7 | openSUSE-11.2-Non-Oss | openSUSE-11.2-Non-Oss | Yes | No | 100 | yast2 | http://mirror.yandex.ru/opensuse/distribution/11.2/repo/non-oss/ |
8 | openSUSE-11.2-Oss | openSUSE-11.2-Oss | Yes | No | 100 | yast2 | http://mirror.yandex.ru/opensuse/distribution/11.2/repo/oss/ |
9 | openSUSE_BuildService_-Education | openSUSE BuildService - Education | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/Education/openSUSE_11.2 |
10 | openSUSE_BuildService
-GNOME:Apps | openSUSE BuildService - GNOME:Apps | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/GNOME:/Apps/openSUSE_11.2/ |
11 | openSUSE_BuildService
-GNOME:STABLE:2.28 | openSUSE BuildService - GNOME:STABLE:2.28 | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/GNOME:/STABLE:/2.28/openSUSE_11.2/ |
12 | openSUSE_BuildService
-KDE4:Factory/Desktop | openSUSE BuildService - KDE4:Factory/Desktop | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.2/ |
13 | openSUSE_BuildService
-KDE4:STABLE/Desktop | openSUSE BuildService - KDE4:STABLE/Desktop | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/ |
14 | openSUSE_BuildService
-KDE:Backports | openSUSE BuildService - KDE:Backports | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/KDE:/Backports/openSUSE_11.2/ |
15 | openSUSE_BuildService
-KDE:KDE3 | openSUSE BuildService - KDE:KDE3 | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/KDE:/KDE3/openSUSE_11.2/ |
16 | openSUSE_BuildService
-KDE:KDE4:Community | openSUSE BuildService - KDE:KDE4:Community | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/KDE:/KDE4:/Community/openSUSE_11.2/ |
17 | openSUSE_BuildService
-KDE:Qt | openSUSE BuildService - KDE:Qt | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/KDE:/Qt/openSUSE_11.2/ |
18 | openSUSE_BuildService
-Mozilla | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/mozilla/openSUSE_11.2/ |
19 | openSUSE_BuildService
-OpenOffice.org | openSUSE BuildService - OpenOffice.org | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/OpenOffice.org:/STABLE/openSUSE_11.2/ |
20 | openSUSE_BuildService
-multimedia/photo | openSUSE BuildService - multimedia/photo | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/multimedia:/photo/openSUSE_11.2/ |
21 | openSUSE_BuildService
-multimedia:xine | openSUSE BuildService - multimedia:xine | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/multimedia:/xine/openSUSE_11.2/ |
22 | openSUSE_BuildService
-science | openSUSE BuildService - science | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/science/openSUSE_11.2/ |
23 | openSUSE_BuildService
-Драйверы_для_веб-камер | openSUSE BuildService - Драйверы для веб-камер | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/drivers:/webcam/openSUSE_11.2/ |
24 | openSUSE_BuildService
-Игры | openSUSE BuildService - Игры | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/games/openSUSE_11.2/ |
25 | repo-debug | openSUSE-11.2-Debug | No | No | 101 | NONE | http://download.opensuse.org/debug/distribution/11.2/repo/oss/ |
26 | repo-source | openSUSE-11.2-Source | No | No | 101 | NONE | http://download.opensuse.org/source/distribution/11.2/repo/oss/ |
27 | repo-update | openSUSE-11.2-Update | Yes | Yes | 100 | rpm-md | http://download.opensuse.org/update/11.2/ |
28 | Основной_репозиторий
(Contrib) | Основной репозиторий (Contrib) | Yes | Yes | 99 | rpm-md | http://mirror.yandex.ru/opensuse/repositories/openSUSE:/11.2:/Contrib/standard/ |

I have installed KDE by switching all packages to KDE4:Factory/Desktop repository.

Gadzuks man. That has got to be the worst list yet. Too too too many active repositories. It is no wonder you have problems. It is a wonder the OS boots at all.

I don’t know where to begin straighting this out.

IMO You trashed the install reinstall from scratch and be careful on what repositories you keep active. For example you have both factory and 4.4 stable active thus mixed. These are two different versions and are at two different levels of stability.

Shakes head sadly… :open_mouth:

Maybe you are right, but I have no problems because of large number of repositories before. And I have installed KDE from one repository. Maybe it needs upgrade of some other package, which isn’t in the dependences?

I am experirncing this too but mine seems to occur randomly. My repo list is a lot cleaner too, only having the recommended 4 repos plus the kde factory for KDE4.4.1 as active.

As far as I can tell my problem seems related in some way to the seeminly random problem I’m having of the sound in KDE to suddenly stop working although it still works in the YAST sound test. When I have the the sound problem and then fix it by resetting my sound card then I am unable to log out or shutdown that session.

suse tpx60s wrote:
> As far as I can tell my problem seems related in some way to the
> seeminly random problem I’m having of the sound in KDE to suddenly stop
> working although it still works in the YAST sound test. When I have the
> the sound problem and then fix it by resetting my sound card then I am
> unable to log out or shutdown that session.

i think you may have stumbled on a real relationship…that is,
perhaps some sound settings are blocking hardware release and therefor
a clean shutdown…

someone with the problem wanna do a poll and then write a bug or three?


palladium

I get the same thing on my server.

I have a very basic KDE 4.4 setup on there which I run only from runlevel3 to do file maintenance/shuffling and external disk de/mounting (quicker for me than cli).

This is on openSUSE 11.1 32bit kernel 2.6.27.42-0.1-default, no multimedia or anything fancy.

To the OP: I don’t see any way to rescue this install, but by inspecting each individual package for repo and version. Reinstall, follow guide for restricted media etc.

But you have the base 11.2 AND the factory. It should be OR the factory not both at the same time. See. You are mixing the base install with the Factory. This spells disaster. If you read the forms you will see that at least 30% of the problems are being caused by this kind of mixing of repositories. Many of the small specialty repo’s are ok because they only supply one or a couple of packages. But the big ones that hold a full distoe worth of packages are poison to each other. The support problem is that it is hard to explain to noobs which are ok an which are not and there is no easy way to just tell. So here is a general rule

  1. If you are keeping the base install keep active only the base 4 repos possible 5th your video driver repo. If you need a package from some other repo activate/add that repo but deactivate after the install.

  2. If you are playing with the betas or other advanced repos, disable the base repo’s and use only stable or factory repos you want to play with.

This is a corollary of the most general rule in computing.

Mom’s rule of programming.
“Put things back the way you found them.”
:wink:

It’s a known bug https://bugs.kde.org/show_bug.cgi?id=228005.
Try to disable system logout sound on system notification.

suse_tpx60s wrote:

<quote> As far as I can tell my problem seems related in some way to the seeminly random problem I’m having of the sound in KDE to suddenly stop working although it still works in the YAST sound test. When I have the the sound problem and then fix it by resetting my sound card then I am unable to log out or shutdown that session. </quote>

I had the same issue with sound, but fixed it by adding user to ‘audio’ group. Don’t know about logging out. I had it before, but not now anymore, don’t know if it’s fixed though.

Same logout problem here.

Sound notifications on: logout does not work

Sound notifications off: logout works