KDE 4.3 upgrade

Have tried to do a KDE 4.3 upgrade on Suse11.1, x64, following this howto: KDE/Upgrade - openSUSE but don’t seem to have achieved much at all… Went throught the process and I think it told me it had about 220+MB to install, but all I have to show is a broken KDE. Looking at the software packages (KDE), it ‘sort of’ looks like it has made available KDE4.3 for most packages that I HAVEN’T got installed, but all of the packages that ARE installed, still seem to be 4.1, with no update options (ie to 4.3) available. If I try and upgrade anything that is available, I get dozens of dependency probs…

The troubleshooting section says to delete these : rm ~/.kde4/share/config/plasma-desktop* files, but they don’t exist…
I’m confused. Anyone??

Please post result of:

zypper lr -d

You might want to read here:
KDE4.3.* Upgrade - HowTo - openSUSE Forums

Thanks for the reply. Have actually done a botch job myself (well, maybe not, as it seems to have ‘mostly’ worked…) by removing the factory repo as suggested in the howto, and adding the kde4.3 repo, (/repositories/KDE:/43/openSUSE_11.1/), as suggested in another article.
Have done another full update, and it seems to have worked (thank goodness!)
So will see how it goes from here.
Thanks, John.

Check your update repo priority is set to 99.
I did ask you to post your repo details.

Yeah, sorry…
john@home:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | kde-desktop | kde-desktop | Yes | Yes | 10 | rpm-md | Index of /repositories/KDE:/43/openSUSE_11.1 |
2 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0,/dev/sr1 |
3 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
4 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
5 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |

As I said, it seems to be mostly ok now with the 4.3 repo…

Thanks, John.

That’s fine you have 43 at higher priority anyway.
Good luck