KDE 4.3: Network Management tray icon says "Unavailable"

After updating from KDE 4.2.98 to KDE 4.3 the Network Management tray icon shows a disconnected icon and the tooltip is: “Unavailable”. However the wifi connection is working ok. ¿Any ideas?


You tried clicking on it, going to ‘manage networks’, then deleting and recreating the connection you’re using? Sometimes works.

Other than that, sorry to say, the network manager is often said to be unreliable, and many have had better luck with wicd.

Tried removing .kde4/share/config/networkmanagementrc with no luck. Tooltip keeps saying “Unavailable” and clicking on tray icon open a menu with just “Manage Connections…” option. There’s no “Enable/Disable wireless” too.
Anyway… at least the wifi connection (the one with automatically connect option checked) has already been established.

It’s strange because Network Manager seemed to work very well on 4.3RC


Found a post in this thread which links to this workaround: https://bugzilla.novell.com/show_bug.cgi?id=528083#c3

Credits go to Beineri

I have the same problem, I haven’t tried this workaround yet (will when I get home though). Seems to work for the original poster

Yep, it works!

Thanks and regards,