KDE 4.3: middle click in panel creates tomboy applet

If I two-finger-tap (middle click) in the tray or launcher collection (say, on device notifier or network applet) a tomboy notes applet appears.

Presumably not intended behaviour… Can anyone confirm this? Are relatively cosmetic things like this worth reporting this early in the cycle? Presumably if I report this it goes to openSUSE bugzilla, and they can pass it upstream to KDE if need be.

Not getting this at my end.

Hmm… I may have deeper problems. Tried to create a new user to test that, and YaST user and group management crashes repeatedly. Might be time for a reinstall…

What repo’s do you use

zypper lr --details

linux-6aq0:~ # zypper lr --details
# | Alias        | Name                  | Enabled | Refresh | Priority | Type   | URI                                                             | Service
--+--------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
1 | Factory_OSS  | Factory OSS           | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/oss/                  |
2 | Factory_non- | Factory non-OSS       | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/non-oss/              |
3 | repo-debug   | openSUSE-11.2-Debug   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.2/repo/oss/  |
4 | repo-non-oss | openSUSE-11.2-Non-Oss | No      | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/    |
5 | repo-oss     | openSUSE-11.2-Oss     | No      | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/        |
6 | repo-source  | openSUSE-11.2-Source  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/ |
7 | repo-update  | openSUSE-11.2-Update  | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/update/11.2/                       |
linux-6aq0:~ #

Anything look amiss?

You may have your reasons but, your post has not made anything clear. Are we to assume you have 11.1 installed, or at least that is what it was originally? And so, have you intentionally added Factory OSS and Non-OSS repo’s? Taking poetic license I assume by the title of the the thread, you think this is all about KDE4.3. But actually it’s far more than that. As it is you have added repo’s to make your whole system Factory.

Perhaps you can explain what you think you are doing here. Because I can tell you the implications are really quite serious.

Eek! Sounds unpleasant!

This is a testing install, which I put on an external drive using the 11.2 Milestone 2 Live USB, and it contains no data (my apologies for not making that clear). My understanding was that the correct way to track 11.2 development was to add those two repos. I couldn’t persuade it to accept my Novell login details to configure it’s “online update” mode, but figured that may well be because it’s prerelease.

So what did I do wrong?

OK. Fine. No worries then.
You could try adding the Factory kde4 repo’s too

Cheers for the tips Caf. Hmm…

My system had gone a bit odd (by way of concatenating my username with my full name on the login screen, for example), so I decided to download milestone 3 and have a go from there. Few more problems installing this time - had to manually install grub - but the thing is I still can’t add users using YaST user and group management. It hangs on ‘write passwords’ forever.

Anyone else seeing this?

No more magically appearing tomboys, at least. Some progress. :slight_smile:

Not much of a tip as I think now I didn’t perceive very well that ‘Tomboy’ is a Gnome app, so you are probably using Gnome? So why would you want the kde repo’s.
Good luck with the testing. Did you try Yast from level 3 to create new user? Might make some difference… you never know.
Possible to do it from cli too, but I’d have to look it up.

Nope - confusion is entirely my fault (what else were you expecting? :)).

I said KDE 4.3 in the thread title, and meant it - but it isn’t tomboy. Presumably Knote.

If I two-finger tap on the network applet, a yellow square with a T in appears to its left. If I click on that, bold, italic, underline, strikethrough, center align (?) and justified icons appear superimposed over the clock and log out / lock screen buttons.

If I right-click on the notes thing, I have options like notes color, formatting, notes settings, and remove this notes. Unfortunately, hard to identify it, because picking help under settings just says…

There is no documentation available for /plasma-desktop/index.html.

And if I pick ‘Popup notes’ (which is knote) from the main menu it behaves differently - though it does seem to share a logo.

Anyway: IT’S BACK!

(will start another thread for the users thing - thanks)