KDE 4.3 Beta issue with YaST

I’m having a problem with Yast and KDE 4.3 Beta. Any one of the software choices is dying with the following error:

YaST got signal 11 at YCP file /usr/share/YaST2/clients/online_update_select.ycp:105
/sbin/yast2: line 437: 26036 Segmentation fault $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS
Now, everything I have read said this is an issue with KDE 4.2.x and QT 4.5. The fix was to roll QT back to 4.4. I have tried a new user account, and KDE 3.5.9, and both got the same results. The CLI yast runs just fine, this only affects the GUI. Anyone have any ideas on what to do now? Can I roll 4.3 beta back to QT 4.4?

I have a sandbox kde4.3 beta with QT45 and it’s fine.
If you move QT back to 44 then you should also use kde 4.2 from the 42 repo

To roll back QT disable the QT45 repo and the kde 4.3 repo’s and just use the kde42 repo and then do a system wide unconditional update

Caf4926, I don’t have the QT repos enabled. The Factory repo has QT 4.5 in it. I’m hopeing that the next update ( I heard there was one this morning) might help. Is there a config file/folder for QT?

I have been trying some different things that I think might be causing it. I like the Bespin style, and have had some issues with it and kcalendar before, so I have changed it. But I haven’t had a chance to do anything yet today.

I just checked the kde4/Factory repo, all of the libqt4 files were updated this morning. Will try those and see what happens.

I know you know this, but you must expect issues considering what you are using.

Yea, I know. I have been beta testing since win95 was beta testing. This is something I can live with. I just was wondering if there is trick that I haven’t thought of to try and fix it, and maybe add to a bug report or something.

Well although QT45 is in Factory, I added the repo too, and it’s good for me.

OK, I’ll try adding the repo and unconditional update and see if that works.

OK. I did a little digging and found a bug report with resolution:

The patch that is talked about (according to webpin) is only found in the devel\upstack repo. (the updated file has not been placed in the other repos yet, but is supposed to be in the queue.

I will try the QT45 repo and then if that doesn’t work try this updated file.

None of these things worked. The patch isn’t in devel:\upstack. In fact that repo is empty!

I have also found a couple of other things. I have found that some of the things that were fixed and running good have been broken again. I think I will go back to 4.2.3 for right now.

Yeah, I hear you. You are not alone in rolling back, I notice @geoffro did too.

I also noticed growbag did that as well. I was just reading that thread. Sounds like quite a hassle to go back. oh, well. Live and learn!

Are people using zypper dup my understanding is this command is made for this purpose.
Zypper/Usage/11.1 - openSUSE

When I ran it recently I noticed it downgrade a few bits exactly what I’m not sure and not being my work horse I can’t really comment. But it made sense though I had never had any other KDE4.2 packages from any where else. And after trying a zypper up it found none.

@caf4926 - I’m still on 11.0. Do you think going to 11.1 would help? I already downloaded it for my family. I just haven’t moved to it because I did think it was necessary.

I have noticed that most people that are saying that 4.3 is working great are on 11.1.


A move to 11.1 - well it’s not necessary in order to enjoy kde4. In fact I was trying 11.0 recently in a sandbox install with 4.2.3 - With a base install of 4.0 and then all updates - then all the way to 4.2.3 - No problem
I would keep 11.0 if all is well for you and don’t be tempted to go for 4.3 yet. I’m not - and I’m sure I can handle whatever mess it throws at me.

I went back to 4.2.3. I have a couple of issues. Still working on them. But overall smooth downgrade. The major functions are all good. Just have to get some of the previous versions of some things.