KDE 4.3.1 using most of my memory

I have just upgraded from KDE 4.2 to 4.3.1. While 4.2 worked fine, 4.3 uses most of the memory that I have (4Gb). I only know this because of a system info widget that I have running. I don’t know what is using all my memory. Also it has disabled the 3d effects on the desktop. I have tried getting them working but the screen starts flashing black and I lose the windows borders.
Have I upgraded wrong? One click

that’s strange. It doesn’t happen here at all. You can see what is eating so much memory either with top or with kde’s system monitor. Also, you may try loging out, renaming /home/username/.kde4 and loging back again. Note that by doing this, you’ll loose your custom settings for kde so you’ll have to reconfigure again some proggie’s

Open a terminal and run: top

post a screen of it

Ok, sorry for the delay
Here is the output from “top”

14115 root      20   0  679m 226m  22m R   89  5.7  84:50.80 Xorg
15521 sarge     20   0  292m  22m  14m R    1  0.6   0:00.62 konsole
14389 sarge     20   0  849m  90m  47m S    1  2.3   1:57.03 plasma-desktop
14328 sarge     20   0  376m 107m  13m S    1  2.7   0:27.70 kded4
14373 sarge     20   0  292m  13m 9352 S    1  0.3   0:22.16 ksmserver
14375 sarge     20   0  290m  31m  23m S    1  0.8   0:19.18 kwin
14377 sarge     20   0  212m  12m 8120 S    1  0.3   0:13.24 kglobalaccel
14391 sarge     20   0  342m  20m  13m S    1  0.5   0:23.72 knotify4
14404 sarge     20   0  211m  12m 8236 S    1  0.3   0:12.62 kaccess
14412 sarge     20   0  340m  14m  10m S    1  0.4   0:16.16 nepomukserver
14414 sarge     20   0  623m  29m  21m S    1  0.7   0:15.84 krunner
14436 sarge     20   0  215m  16m  11m S    1  0.4   0:13.92 kwalletd
14492 sarge     20   0  221m  16m  10m S    1  0.4   0:12.84 kmix
14532 sarge     20   0  191m  17m  13m S    1  0.4   0:16.38 kupdateapplet
14554 sarge     20   0  139m  13m  10m S    1  0.3   0:07.42 kpowersave
14879 sarge     20   0 70468  12m 8936 S    1  0.3   0:25.22 operapluginwrap
14967 sarge     20   0  616m  99m  66m S    0  2.5   0:11.70 soffice.bin
    1 root      20   0  1064  388  324 S    0  0.0   0:01.10 init
    2 root      15  -5     0    0    0 S    0  0.0   0:00.00 kthreadd
    3 root      RT  -5     0    0    0 S    0  0.0   0:00.00 migration/0
    4 root      15  -5     0    0    0 S    0  0.0   0:00.52 ksoftirqd/0
    5 root      RT  -5     0    0    0 S    0  0.0   0:00.00 migration/1
    6 root      15  -5     0    0    0 S    0  0.0   0:00.22 ksoftirqd/1
    7 root      15  -5     0    0    0 S    0  0.0   0:01.42 events/0
    8 root      15  -5     0    0    0 S    0  0.0   0:01.58 events/1
    9 root      15  -5     0    0    0 S    0  0.0   0:00.00 khelper
   10 root      15  -5     0    0    0 S    0  0.0   0:00.00 kintegrityd/0
   11 root      15  -5     0    0    0 S    0  0.0   0:00.00 kintegrityd/1
   12 root      15  -5     0    0    0 S    0  0.0   0:00.02 kblockd/0
   13 root      15  -5     0    0    0 S    0  0.0   0:00.00 kblockd/1
   14 root      15  -5     0    0    0 S    0  0.0   0:00.00 kacpid
   15 root      15  -5     0    0    0 S    0  0.0   0:00.00 kacpi_notify
   16 root      15  -5     0    0    0 S    0  0.0   0:00.00 cqueue
   17 root      15  -5     0    0    0 S    0  0.0   0:00.10 kseriod
   18 root      15  -5     0    0    0 S    0  0.0   0:00.82 kondemand/0
   19 root      15  -5     0    0    0 S    0  0.0   0:00.80 kondemand/1
   20 root      20   0     0    0    0 S    0  0.0   0:00.00 pdflush
   21 root      20   0     0    0    0 S    0  0.0   0:00.54 pdflush
   22 root      15  -5     0    0    0 S    0  0.0   0:00.00 kswapd0
   23 root      15  -5     0    0    0 S    0  0.0   0:00.00 aio/0
   24 root      15  -5     0    0    0 S    0  0.0   0:00.00 aio/1

You have lots of processes running, including kpowersave which is a kde3 application. I deleted it myself.
But you realise that memory often appears all used up in Linux but it’s not.

The top section of your top was missing. I use htop (you can install it from the repos)

I’ll delete kowersave. I have heard about the memory appearing used, but quite often my system will half freeze. The mouse pointer will still be working but things like the clock I have on the desktop will freeze up. If I try to search in the kickoff menu, kickoff will freeze. It is all a bit odd. KDE 4.2 was fine for most of the time thats why I’m wondering if I have mucked up the install.

It’s normal for linux to use up all available memory - it will allocate all memory not being used by application to buffers and cache (mostly to cache). So, what you need to look at is the amount of memory being used by applications - many memory monitors don’t break it down in that way and I don’t know why because that’s really the important factor. The amount of memory used by cache will shrink and grow based on what’s available. Maybe you already knew all that. Open system monitor - click on the

What I notice from Top is that xorg is using 89% of your cpu - that’s not normal and that would certainly slow things down.

Hope that helps,

Thanks James.
I have come across articles about the memory usage in linux. I don’t know if I understand it. I have noticed that xorg was taking up a lot of the cpu. I tried rebooting and there was an xorg update, but none of that made any difference. I have just rebooted this morning and everything appears to be working as it should. I don’t know what is going on. But won’t be complaining.
I hope all is well now as this coming week I am working away from home so I won’t have access to the internet for large downloads.

Do you by any chance have an ATI Graphics Card and its drivers? If yes then that’s your problem. The people above me responded to a completely different question. In your case the “top” command clearly shows that Xorg eats up 89% of your CPU. Which means that your system must be crawling. Am I right?

Yes I do have an ATI graphics card (in my laptop). And yes, it is crawling. The interesting thing is that the widgets are slow, as is the starting of programs etc. But the the mouse is still moving as normal.
I have had a bit of a problem installing the ATI drivers in the past.
My laptop graphics is an “ATI Radeon HD3470”

I have noticed that Xorg is using about 45% of the cpu now in 4.3.1
I am currently in KDE 3.5 and it seems to be working fine.

Any (simple) ideas anyone? :slight_smile:

Ok, I suppose you are using the ATI fglrx driver, that you installed either from yast, or from ATI’s web page. Now the strange thing is that ATI has forgot to update its main web page with the newest drivers and lists the latest driver as one that was released on March.

But the latest driver is this http://www2.ati.com/drivers/linux/ati-driver-installer-9-8-x86.x86_64.run and was released on August.

Unfortunately you will have to compile it and install it yourself because there is no pre-compiled version for suse. Ideally once you do that the problems will disappear.

Note however that the next time yast online update installs a new kernel you will have to re-compile the driver against the new kernel.

Come back with the results. :slight_smile:

I have just installed the driver in the link you gave me, but it looks like nothing has changed. I have checked the xorg.conf file and the driver is set to fglrx.

I’ll have to have another try tomorrow.

I just hope you uninstalled the previous version of fglrx and that you followed step by step the instructions of the ATI documentation on how to install the new one.

Anyway I can’t help you any further because what I did was on a friends laptop. I own an NVIDIA card.

What I can tell you though is that my friend had some more problems with the graphics and he installed Kubuntu. His words were:“It just works my friend”.

I haven’t tried any version of ubuntu so I can’t testify for it myself.

p.s. Your last resort, if all else fails, is to install the opensource radeon driver, which is blazing fast BUT you won’t have 3D effects(compiz or Kwin).

Ahhh yes. I forgot to remove the old driver first.
I have just done that and reinstalled. Xorg is back to using little of the cpu now. Until I move an open window.
I have had this before on my old laptop also with ATI graphics. I can’t remember what I did to fix that. I might need to do a bit more fiddling after work tonight.

The system seems to be running normally, but the screen is jumping when scrolling or moving an open window. Video driver problem I think.

Thanks for your help.

Still no luck. Looking at the system activity. Xorg is using about 1 to 5% cpu when nothing is happening on the screen. But will go up to 40% when open windows get moved.
I think I had a similar problem with my old HP laptop a while back but I can’t remember what I did to fix it.

There could be some old plasmoid(s) or config settings for those causing this. Logout, hit Ctrl-Alt-F1, login on console with username and password and do:
rm ~/.kde4/share/config/plasma*
Back at prompt hit Crtl-Alt-F7 to return to graphic login screen. Login on desktop, it will be standard KDE4 and run top again.

Just tied that. Still the same.
I might just have to wait until 11.2 comes out. I have tried a new install of 11.2 M6 on a spare hard drive and I have the same problem.

Just for fun I installed a new hard drive in my laptop and installed OpenSuse 11.1 Reloaded. I have installed the ati 9.8 driver with the installer. I tried the distro specific install, but it didn’t look like it installed (not able to run aticonfig --initial). That has been normal for me. So I tried installing the generic install. It looked like more was happening this way and I was able to run the aticonfig.
After a reboot I found that I have the same problem as before.
I have had the ati driver working on this laptop with 11.1 before. It was working well with KDE 4.1, would have a few problems (screen flicking) with KDE 4.2 and now slow 2D in KDE 4.3.1
Any clues anyone?

Its a sad day for me when windows looks better than my Linux :frowning:

Look my friend, I understand your frustration but I guess you ll have to deal with the fact that right now OpenSUSE 11.1, ATI and 3d desktop do not blend well. It is not a Linux problem, it’s a suse problem. As I told you before Kubuntu/Ubuntu do not have these problems. So if you are not a die hard suse fan you could try those. If you are… well as a last resort I would go to the ATI wiki and try every previous driver version just in case someone works. But I wouldn’t expect much if I were you.

The other solution is to wait for OpenSUSE 11.2 which will probably not have these probs.

Cheers and good luck

Oh well, if thats the way it is I might just have to live with it unill it gets fixed. OpenSuse generally just works for me most of the time, so I’ll stick with it for a while and hope it improves. I’ll install the KDE version of Mint on another partition for now. That works with my usb tv tuner.
Thanks for the help.:slight_smile: