KDE 4.3.1 audio problems


I have an odd audio problem I am trying to resolve. I hope someone can give me advice on what to do next.

In KDE I have no System Notifications, Kaffiene, Amarok2, Amarok and Xine immediately exit when opened without an error. If I try to open the System Settings/Multimedia or System Settings/Notifications control panels they also exit without an error.

I have audio in other applications, MPlayer, Skype, VLC, Songbird, etc., as well as from the Konsole.

I’ve tested Konsole audio using the published guidelines in the Audio HowTo, ‘speaker-test’ works fine for all users.

In Yast2 I can configure and test the audio card without errors, but I am not able to get USB headphones working.

I have been through the ‘Check your multimedia problem in ten steps’. There are no errors or missing dependencies showing up.

As a double check, I’ve booted from the 11.2 Live CD and everything worked fine including KDE Notifications and application audio.

I’ve tried deleting my .kde4 profile, this didn’t fix the problem, and application and control panel behaviour remained the same with a clean profile.

At this stage I am lost, I’m not sure what to do next. Any advice is welcome and greatly appreciated.



I’ve partly resolved the problem.

A dependency had installed;

libffmpeg-devel (fake)

Removing this and installing the default libffmpeg0 solved the problem as far as audio output goes.

Mics and USB headset are still not working as expected but I should be able to resolve these problems shortly.