KDE 4.2 RC1, widgets still locking desktop

I had development version, now installed 4.2 from factory, but still, when I try to add widget, list locks. Then, KDE offers termination dialog, when I click Terminate, screen goes black and that is it…

Maybe someone had that problem and resolved. If so, please help

Update:
Double clicking widgets still locks, but drag & drop works OK.

Strange haven’t had any problems. May be one of the widgets you have that are unstable.
Which ones do you have?

/Geoff

It happened to me also. If you double click or select the plasmoid and click on Add button it locks and you can just ctrl+alt+bckspc twice to get back in.
Haven’t tried the drag and drop still.

It happens randomly with any widget. Maybe not so randomly, I was thinking it could be related to graphics card memory.

Happens with almost all widget. I do not know what is linked for, but in 4.2 RC1 drag & drop works while it didn’t in 4.2 beta. At least, we are getting somewhere :slight_smile:
I see bug is already posted on KDE so we shall wait few more days for 4.2 to go out.

Yep, drag and drop doesn’t lock plasma.

Anyway, I discovered simple cure for black desktop:
Alt+F2, run input appears, type “plasma” and everything is back again.

Reminded me on XP’s Explorer problem, as it was known to crash. So, I used same tactics and it worked.