kde 4.2 google gadget

I’m on openSUSE 11.1 x86_64 running KDE 4.2 from the Unstable repo (had
same issue under x86 also; but had other performance issues leading to a
x86_64 install). I add the photos widget from Google and get the widget
with a black screen. In my .xsession-errors file I get:

>
> kwin: X Error (error: <unknown>[DAMAGE+0], request:
> XDamageDestroy[DAMAGE+2], resource: 0x181f156)
> Not a regular file: /
> Register default_framework extension.
> Register qtwebkit_browser_element extension, using name “_browser”.
> Register qt_system_framework extension.
> Register qt_edit_element extension.
> Register gst_audio_framework extension.
> Register gst_video_element extension.
> Register linux_system_framework extension.
> Register dbus_script_class extension.
> No permissions to access D-Bus.
> slide_shower.js:355: add new feed ‘nature - Google Image Search’
> (http://images.google.com/images?q=nature&imgsz=xxlarge)
> fetchs.js:364: fetch http feed
> url=http://images.google.com/images?q=nature&imgsz=xxlarge
> fetchs.js:365: No permission to access network.
> fetchs.js:365: ReferenceError: Failed to construct native object of
> class XMLHttpRequest
> main.js:161: TypeError: kSlideShower is undefined
>

However, if I launch ggl-qt and then add the photos widget it works
fine. The same also happens with the rss reader widget (fails when
adding via -Add Widgets- but works fine from ggl-qt. Also, -first-
launching ggl-qt and -then- adding the widget via -Add Widgets- does
not resolve the issue either.

Now, is this by design (I must first launch ggl-qt before any Google
gadget can access the network) OR is there a buried setting I need to
change? If it’s by design, what is the point of having Google gadgets
show up in -Add Widgets-.

Any help much appreciated.


falcon119

falcon119’s Profile: http://forums.opensuse.org/member.php?userid=13368
View this thread: http://forums.opensuse.org/showthread.php?t=406985

Hi,

How do you run your Google Gadgets?
I also have a similar problem with the widgets. I have always to run it
like sudo, otherwise I can’t see all the widgets.


douglascaixeta

douglascaixeta’s Profile: http://forums.opensuse.org/member.php?userid=15362
View this thread: http://forums.opensuse.org/showthread.php?t=406985

I created a symlink to the google gadget app in my KDE4 Autostart
directory (ran this in a terminal [only works if KDE4] ln -s
/usr/bin/ggl-qt ~/.kde4/Autostart/
). Some google gadgets work fine
while others seem to fail miserably (the games I’ve tried so far fail).
And since the gadgets also only run on 1 virtual display, they’re pretty
much useless to me.


falcon119

falcon119’s Profile: http://forums.opensuse.org/member.php?userid=13368
View this thread: http://forums.opensuse.org/showthread.php?t=406985