KDE 4.2: cannot proceed beyond the login screen

I have encountered pretty bad one: right after a correct login, when KDE desktop starts up, it throws me back to the login screen. I can login as root though, and get fresh, new defaul-set desktop for the superuser, so it definitely must be up to certain configurations.

It began shortly after the update from KDE 4.1.3 to 4.2

There’s probably some older plasmoid or plasma config item crashing the X-server, since you can login as root and it all works.

Try this:

  • At the login screen hit Ctrl-Alt-F1
  • login with normal username and password
  • type: rm ~/.kde4/share/config/plasma*
  • hit Ctrl-Alt-F7 to return to login screen
  • login
    You should see a fresh desktop. You’ll have to reimplement your personal adjustments, but all settings for programs renain.

I got this same problem after updating from 4.2.1 to 4.2.2. I tried the proposed rm and no joy. The interesting part about this little update is that I didn’t even have the graphical login prompt installed on 4.2.1. It was an automatic login. After the update, I now have the graphical login that is never ending. :’( This is third time I installed SUSE11.1, after looonnnngggg hours of updating. At the same time I have been doing the setup to another computer I have. It is also interesting that no matter how hard I tried to keep the two the same, they are different, especially now. I have one that has never ending login but has been able to install some development tools on it, while the other computer doesn’t have the graphical login but I can not get the same development tools installed on it. rotfl!