KDE 4.2 Beta 1 Caterpillar

Hi,

Is there a way to have a full install of KDE 4.2 Beta 1 (codenamed Caterpillar) in openSUSE 11.1 RC1?

Over at the KDE website I downloaded this one-click install for openSUSE Factory:-

http://download.opensuse.org/repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_Factory/KDE4-BASIS.ymp

Once it proceeds to install KDE Caterpillar it then complains of a series of package dependencies:-

YaST2 conflicts list - generated 2008-12-11 10:17:20

powerdevil-1.4.1-3.5.i586 requires libplasma.so.2, but this requirement cannot be provided
deleted providers: kdebase4-workspace-4.1.3-9.10.i586@System]
uninstallable providers: kdebase4-workspace-4.1.3-9.4.i586[repo-oss]
] Following actions will be done:
do not install kdebase4-workspace-4.1.82-3.3.i586
do not install kde4-konqueror-4.1.82-1.5.i586
do not install kde4-konsole-4.1.82-1.5.i586
do not install kde4-kwin-4.1.82-3.3.i586
do not install kde4-kwrite-4.1.82-1.5.i586
do not install kdebase4-4.1.82-1.5.i586
] deinstallation of powerdevil-1.4.1-3.5.i586

 ] Ignore some dependencies of powerdevil

skanlite-0.2-3.7.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided

 ] Following actions will be done:

do not install kde4-kdialog-4.1.82-1.5.i586
do not install kde4-konqueror-4.1.82-1.5.i586
do not install kde4-konsole-4.1.82-1.5.i586
do not install kde4-kwin-4.1.82-3.3.i586
do not install kde4-kwrite-4.1.82-1.5.i586
do not install kdebase4-4.1.82-1.5.i586
] deinstallation of skanlite-0.2-3.7.i586

 ] Ignore some dependencies of skanlite

kde4-plasmoid-quicklauncher-0.4-4.13.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided

 ] Following actions will be done:

do not install kde4-kfind-4.1.82-1.5.i586
do not install kde4-konqueror-4.1.82-1.5.i586
do not install kde4-konsole-4.1.82-1.5.i586
do not install kde4-kwin-4.1.82-3.3.i586
do not install kde4-kwrite-4.1.82-1.5.i586
do not install kdebase4-4.1.82-1.5.i586
] deinstallation of kde4-plasmoid-quicklauncher-0.4-4.13.i586

 ] Ignore some dependencies of kde4-plasmoid-quicklauncher

kde4-plasmoid-quickaccess-0.7.1-4.12.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided

 ] Following actions will be done:

do not install kde4-dolphin-4.1.82-1.5.i586
do not install kde4-konqueror-4.1.82-1.5.i586
do not install kde4-konsole-4.1.82-1.5.i586
do not install kde4-kwin-4.1.82-3.3.i586
do not install kde4-kwrite-4.1.82-1.5.i586
do not install kdebase4-4.1.82-1.5.i586
] deinstallation of kde4-plasmoid-quickaccess-0.7.1-4.12.i586

 ] Ignore some dependencies of kde4-plasmoid-quickaccess

kde4-konqueror-plugins-4.1.3-2.1.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided

 ] downgrade of kde4-konqueror-plugins-4.1.3-2.1.i586 to kde4-konqueror-plugins-4.1.3-1.13.i586

 ] Following actions will be done:

do not install kde4-kdepasswd-4.1.82-1.5.i586
do not install kde4-konqueror-4.1.82-1.5.i586
do not install kde4-konsole-4.1.82-1.5.i586
do not install kde4-kwin-4.1.82-3.3.i586
do not install kde4-kwrite-4.1.82-1.5.i586
do not install kdebase4-4.1.82-1.5.i586
] Ignore some dependencies of kde4-konqueror-plugins

kde4-knewsticker-4.1.3-4.5.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided

 ] deinstallation of kde4-knewsticker-4.1.3-4.5.i586

 ] Following actions will be done:

do not install kde4-kmix-4.1.82-1.5.i586
do not install kde4-konqueror-4.1.82-1.5.i586
do not install kde4-konsole-4.1.82-1.5.i586
do not install kde4-kwin-4.1.82-3.3.i586
do not install kde4-kwrite-4.1.82-1.5.i586
do not install kdebase4-4.1.82-1.5.i586
] Ignore some dependencies of kde4-knewsticker

kde4-kgreeter-plugins-4.1.3-9.4.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided

 ] Following actions will be done:

do not install kde4-keditbookmarks-4.1.82-1.5.i586
do not install kde4-konqueror-4.1.82-1.5.i586
do not install kde4-konsole-4.1.82-1.5.i586
do not install kde4-kwin-4.1.82-3.3.i586
do not install kde4-kwrite-4.1.82-1.5.i586
do not install kdebase4-4.1.82-1.5.i586
] deinstallation of kde4-kgreeter-plugins-4.1.3-9.4.i586

 ] Ignore some dependencies of kde4-kgreeter-plugins

compiz-kde4-0.7.8-6.3.i586 requires libplasma.so.2, but this requirement cannot be provided
deleted providers: kdebase4-workspace-4.1.3-9.10.i586@System]
uninstallable providers: kdebase4-workspace-4.1.3-9.4.i586[repo-oss]
] Following actions will be done:
do not install kdebase4-session-4.1.82-1.32.i586
do not install kde4-kwin-4.1.82-3.3.i586
do not install kde4-konqueror-4.1.82-1.5.i586
do not install kde4-konsole-4.1.82-1.5.i586
do not install kde4-kwrite-4.1.82-1.5.i586
do not install kdebase4-4.1.82-1.5.i586
] deinstallation of compiz-kde4-0.7.8-6.3.i586

 ] Ignore some dependencies of compiz-kde4

YaST2 conflicts list END

Now. there is a similar thread over at KDE 4.2 - openSUSE Forums and the suggestion was to remove some of the installable packages. Is that the only way to go about it? Is there really no way of installing KDE Caterpillar properly into openSUSE 11.1 RC1?

Many thanks for any help given.

I do believe that in preparation for 11.1, the Devs are going about moving/realigning all the repos around to facilitate the release. The KDE repo is one that is being realigned. It should all clear up within the week.

I think I have read that Index of /repositories/KDE:/KDE4:/UNSTABLE: will be the home for the KDE4 latest and greatest.

Because it is labeled “Unstable”, expect it to have dependency issues as it will change more than daily. Think of it as a workspace for the KDE4 Developers.

For those rpms that show as having dependency issues, just select “do not install”. That may show other dependency issues too, just work your way through them. They will eventually resolve as the Devs work out the bugs.

If you can’t live with the dependency issues, then switch to the “Stable” repos;)

  • When upstream has branched KDE 4.2 prior release (early January) and Trunk
    is open for 4.3 development then we will start to use KDE:KDE4:UNSTABLE
    again with regular KDE trunk snapshots updates.

Knew I read that somewhere:)

(You just have to look at them and see which version numbers are in which repo)

Many thanks! That info is all I needed :slight_smile: