KDE 4.2.1 becomes unreponsive.

After about 1-3 hours of use, the launcher of KDE just quites working. If I log out/in it starts okay, but its annoying.

Does anyone have any ideas?

System: openSUSE 11.1 (i586)
KDE: 4.2.1 (KDE 4.2.1) "release 104

The launcher? You mean the Run Command dialog, or the Kickoff Application Launcher, or something else?

Kickoff Applicatioon Launcher.

Is it just the kickoff? If you have other launch buttons in the panel or a separate panel, do they work?
Have you tried to check what is running in the background?


Well, actually I removed Opera & that has solved the issue it seems. I will update if the problem occurs again.

Okay, I say that and it happens right after.

It’s extremely unlikely that opera would be the problem anyway. More likely an issue with Plasma and your configuration settings. I’m not saying you have something wrong necessarily - just that it can get that way.

Try renaming the .kde4 folder to .kde4_old
When you login next it will be a totally new kde4 setup (don’t worry we can go back to your old folder later)
This will let you run as if it’s the first time you used kde4 and will not have all the possible conflicts from your old settings. See how it behaves. If it solves the issue - then we at least know it’s something in the user settings. If it remains - we need to think again.

to do it from cli (Ctrl-Alt-F1)

mv /home/username*/.kde4 .kde4_old

Found the problem. It was picasa. I unstalled it, kde was fine. so i re-installed it, and kde went crazy, un installed again, now its fine. If it goes crazy again, I will try caf4926’s advice. but picassa seems to be culprit.

Just wait and see. If Picasa is the culprit just leave it out. I never use it myself. You may not need to use my earlier advice.