KDE 4.2.1 and nvidia 180.44?

[move this to hardware if that’s more appropiate. To me it sounds more like a DE issue but I may be wrong]

Just wondering…

I recently tried the 180.44 stable version of the nvidia-driver. I usually use whatever is available in the nvidia-repo (currently 180.29), but I was too curious…

So, I uninstalled the driver available through the repo and installed the 180.44 version manually. It runs, and composite and everything works.

The only problem is that when the 180.44 driver is used, kwin tends to use A LOT of cpu. Somewhere between 30 - 40 % of a 3.5 Ghz P4. With the repo-version, it fluctuates between 5-10 % approximately.

Has someone else noticed the same problem, and knows of a work-around (save reverting to 180.29, which is what I’ve done temporarily. 180.44 worked better otherwise though so I would prefer to use that one)?

Sorry… no assist from me other than to say that I am not experiencing the issue on my computer.

Are you talking about some specific activity? The reason I ask is because on all of my computers, kwin never even uses a half a percent during idle monitoring (usually reported at 0.1%).

I have all the desktop effects/etc enabled. My primary PC is a laptop with a 2.66GHz Core2Duo (P9600) and 1GB Nvidia 9800M GTS.

The 180-series is known to leave remains, when installing another version. You need to remove all remains of the 180.29 driver. Search the fora, there should be a dozen posts by me explaining how to do that. Uninstall the 180.44 driver, after that check for and remove remains.
After the cleaning you reinstall the driver. Should be OK now. If not, it’s the driver, try the 185.13 one, works like a charm for me. Here’s the FTP address: ftp://download.nvidia.com/XFree86/

Sorry it took me a while to respond. I’ve been busy, and has been trying to solve this as well…


No, it’s not a specific activity. As you say, when the computer is completely idle kwin (and x.org) rarely goes above 1 %. The fluctuation part I mentioned only shows up when kwin has something to do. And even then, it only spikes at that percentage (and rarely at even 10 %, usually around 5 % or so) which is not a problem since it almost immediately goes down to well below 1 % again.

The problem with the .44 version is that it stays at around 30 - 40 % even when the computer is, or should be, completely idle.


Much as I have tried, I haven’t been able to find a post that explains how to completely remove the old one.

I thought

zypper remove x11-video-nvidiaG02

and a reboot followed by a manual installation would be sufficient?

Never mind. It works as it should if I skipped the latest stable and opted for the 185.13 one instead.