KDE 4.14.2 Isn't Stable

Under openSUSE 13.2 x64, KDE 4.14.2 hasn’t been very stable for me. I had a bunch of rsync windows minimized in a group, and each time I clicked on the group, plasma-desktop would crash. Since I could reproduce the bug repeatedly, sometimes plasma-desktop would restart itself and other times I would have to start it using the command line. Another time, I was able to get plasma-desktop to crash just by selecting two files on the desktop, and that happened twice thus far. Within the last day, there are a bunch bug reports at bugs.kde.org similar to the one I submitted, all pertaining to openSUSE 13.2. Can anyone shed light on this? I’m hoping these bug reports don’t just sit there and collect dust for years, going unanswered.

not seeing any instablity on 2pc’s and 2laptops

suggest the install be carefully checked

Desktop: KDE 4.14.2 Distro: openSUSE 20141105 (Harlequin)

are the symptons the same when booting into a new user profile?

I haven’t tried that yet, but can easily just reinstall or create a new profile if needed. However, I’m not sure if reinstalling or creating a new profile would fix the issue considering the bug reports below – and a few of them came in just hours apart. Most users in the below reports listed 13.2 as their distro:

https://bugs.kde.org/show_bug.cgi?id=340791
https://bugs.kde.org/show_bug.cgi?id=340790
https://bugs.kde.org/show_bug.cgi?id=340786
https://bugs.kde.org/show_bug.cgi?id=340780
https://bugs.kde.org/show_bug.cgi?id=340735
https://bugs.kde.org/show_bug.cgi?id=340669
https://bugs.kde.org/show_bug.cgi?id=340654
https://bugs.kde.org/show_bug.cgi?id=340651
https://bugs.kde.org/show_bug.cgi?id=340634

I’m using btrfs instead of ext4, and wonder if that may have something to do with it. Other than that, my KDE desktop is pretty much vanilla as there’s nothing custom or crazy going on.

I have had it crash once, and that was when setting up for the first time.

Hmm, make that twice - it also happened when running nouveau graphics driver on initial setup. In that case, I had to edit “.kde4/share/config/kwinrc” and turn off desktop effects before I could get it to behave. (I did that by adding a line “Enabled=false” to the “[Compositing]” section).

Apart from initial setup issues, it has been quite stable.

maybe that’s it, ext4 is the disk format on all installs

The file system (if it is working) should not be an issue and BTRFS does work.Video may be an issue depending on which drivers.

I don’t think it’s the btrfs filesystem. I did notice that this problem happened when the system was under 100% load on all 4 cores (BOINC) and I had three instances of rsync running, copying over three separate directories to an external USB hard drive. So, I was pushing the system to its max which could have exacerbated a bug which exists in the new xorg and/or with KDE 4.14.2. I think the crashes may have something to do with animations, as the crash would happen when I clicked on minimized grouped Konsole windows. Now, on a different day, I’m not able to reproduce the crash. I’m using the open source “radeon” driver, as I have an ATI card and don’t really like proprietary software.

I just got plasma-desktop to crash again. I had about 4 Dolphin windows minimized and one maximized. When I clicked the grouped items on the panel, plasma-desktop crashed and I got a black screen. If I hover up to the top left hot corner, all my applications are still running and accessible. Is there a way to get plasma-desktop running again from another tty, or some shortcut to bring Konsole up on tty7? Shouldn’t KSysGuard (ctrl+esc) be capable of launching something that isn’t already running?

My plasma-desktop crashes also. On different computers. I had several crashes, some examples:

  • Desktop crashes after hoovering on a group and screen examples are shown
  • Desktop crashes after accessing “hided pictograms” on the systemtray (excuse me if I use the wrong terms, my desktop is not in English)

I’m not sure if the desktop really crashes. Background freezes and panels and application menu is not usable anymore. Default I have opened a Konsole screen. The only way that I know to resume working is by issuing a reboot in the konsole.

my desktop becomes unstable when I deselect the bookmark toolbar in konqueror and restart the application again it just takes forever

It may be a desktop problem but is more likely a video driver problem. So if you are having KDE crashes/freezes please tell us your video card and driver.

Hi, it's a laptop with Intel integrated graphics that are upgraded from 13.1
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
    Subsystem: Acer Incorporated [ALI] Device [1025:029b]
    Flags: bus master, fast devsel, latency 0, IRQ 27
    Memory at d0000000 (64-bit, non-prefetchable) [size=4]
    Memory at c0000000 (64-bit, prefetchable) [size=256]
    I/O ports at 30d0 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 3
    Kernel driver in use: i915
    Kernel modules: i915

00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)


[/size][/size][/size]

Yesterday was a good day on KDE, as I had no crashes. Today was different. Today, the desktop keeps flashing black as plasma-desktop crashes and restarts itself. At least it doesn’t completely crash and not come back like it did a few days ago, although I expect it to do that again. What’s unfortunate is that it seems like we’re going backwards, to the days of when KDE 4 was not stable. KDE on openSUSE 13.1 x64 was stable for me, and 13.2 x64 is not stable. Sure, there are people who are always going to say, “Oh, well I’m not having that problem so it doesn’t really matter”, but I am having this problem and so are other people so it does matter. And nobody has answered my bug report, and it will probably sit there for 10 years without even being read. What’s the point of submitting KDE bug reports when KDE barely has enough people working on it, let alone enough volunteers to read bug reports and fix things as they’re already working on version 5? I really can’t wait to see how stable that will be.

I don’t see how I could recommend openSUSE to a friend or client when after setting their computer up and leaving, the thing crashes. If Linux advocates want the uptake of Linux to increase, then please make the software stable. I am able to google stuff and tinker with things to get things working as well as ask questions here, but the aforementioned people don’t have those skills and even if they did, they aren’t going to spend their time finding workarounds for bugs as their work is sitting there stagnating.

I’m still having a major problem with plasma-desktop crashing over and over again. It’s not a hardware problem because my hardware isn’t that old, and this doesn’t happen on 13.1. plasma-desktop sometimes will restart itself after a crash, and other times I have to press Alt-F2 to bring up Krunner and type: “plasma-desktop”. Other times Alt+F2 doesn’t work and I have to restart the PC. I asked for a method to restart KDE on tty7 earlier but nobody answered my question. Just like nobody is answering my bug report, and nobody is acknowledging that this problem with plasma-desktop even exists. So far openSUSE 13.2 has been a really disappointing experience for me.

Tip: install yakuake as terminal application. When the plasma-desktop crashes, hit F12, you’ll see yakuake still works. Run

plasma-desktop

and your windows etc should be accessible again.

BTW KDE 4.14.2 here, no crashes, apart from an initial one where (older) conflicting plasmoids seemed to be the culprit. Cleaning out the plasma* files in ~/.kde4/share/config made the account accessible again.

Excellent, thanks for that info. I installed yakuake and will report back on whether or not cleaning out the ~/.kde4/share/config did anything, but I already erased the entire ~/.kde4 folder when I upgraded. What’s really funny is that 13.2 RC1 was rock solid stable for me.

Everything was running smoothly today on KDE 4.14.2, when out of the blue and after hours of desktop usage, plasma-desktop crashed. I pressed F12 and brought up yakuake, and typed in “plasma-desktop”. All that did was bring up the KDE crash handler dialogue box. I tried a few times, and each time plasma-desktop crashed and the crash handler dialogue box opened. Is there some other way to restart plasma-desktop from tty1, without losing what I’m working on? I also erased the entire ~/.kde4 folder earlier so that can’t be the culprit.

I found a new bug report at bugs.kde.org which is exactly the same issue i’m having, so I’ll post it here:

" Bug 340930 - Plasma-desktop crashes repeatedly in different situations"

Application: plasma-desktop (4.11.12)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.6-2-desktop x86_64

Distribution: “openSUSE 13.2 (Harlequin) (x86_64)”

– Information about the crash:

  • What I was doing when the application crashed:

I’ve had plasma-desktop crash while selecting different applications from the taskbar applet but when I relaunch from the cli it continues to crash. There doesn’t seem to be a single trigger, it can crash without any user interaction as well.

The crash can be reproduced sometimes.

So, looks like the problem may be related to btrfs after all:

https://bugs.kde.org/show_bug.cgi?id=340657