KDE 4.11 Final Regressions

I had previously been running Kde 4.10.x from the 4.11 Factory repo.

I have since switched over to the stable 4.11 repo.

Two regressions I’ve found so far after going from Factory to stable.

  1. On my main desktop running the 325.15 NVIDIA driver upon reboot there is massive tearing and it seems that vsync isn’t working at all at this point. The only way I have found to fix this is to toggle the OpenGL level (in my my case I flip it from 3.1 to 2.0 and then back). This behavior wasn’t present with the Factory packages. For KDE vsync I use full screen repaints as that is the only setting that eliminates tearing. Switching this setting has no effect. Only changing OpenGL levels seems to engage vsync.

  2. On my Asus Zenbook, the keyboard backlight controls that were working with the 4.11 Factory repo no longer work. There isn’t even a keyboard brightness slider in the taskbar power settings like there was in the Factory repo packages.

Both of these seem like fairly serious regressions, given how smoothly they had been working until the final stable upgrade. I’m going to continue to play around and see what else I find.


It seems that on the Asus Zenbook if you login then immediately logout and login again, the keyboard brightness controls work just as they had previously. This holds true for my user account and the test user account I made to see if there was an old config file that might be messing with the settings. I’m not sure why it doesn’t load the first time, but it’s very annoying.

Upgraded KDE 4.11 with tumbleweed (12.3, i586) cant set default program for file type, though it seems to be changing the desired one, but after apply=>ok there is not change at all :slight_smile:


anybody tried that?

Just tried it, I don’t seem to have that problem, using the packages from the KR411 repo.

Like the OP I also have some backlight issues with KDE, but in my case I don’t think its a regression because I think I remember 4.10 doing the same thing (at least with the fn keys, the screen dim bug might be a regression). Its quite annoying:

Both my fn keys and kde’s brightness control work to change my brightness. But when I use my fn brightness keys, the brightness changes but KDE does not realize it changed and continues to show the old brightness. I also have an issue with the “screen dim” feature in the power settings. If I leave my laptop unplugged long enough for the screen dim to go into effect after 2 minutes, when I plug it back in it doesn’t return to 100% brightness like it is supposed to, but instead returns to ~50% brightness. KDE is the only DE I have these issues on, the fn keys work flawlessly in gnome or XFCE. KDE’s brightness handling seems quite buggy.

I have not had the issue where there is no brightness slider in the battery applet though, its always there on first login for me.

Do you get a never finishing dialog saying “Updating system configuration” where you only can press “Cancel” to continue?
I have that problem as well, even had it years ago with KDE3 already.

The configuration does get saved, it just isn’t applied though.
Run “kbuildsycoca4” (as user, in Konsole or by typing Alt+F2) for the changes to take effect.

Does the file type dialog then show the correct default program for you?

No, updating system configuration finished with showing desired app on top, but when I clicked on file its open with old one (default), tried kbuildsycoca4 but no change

Hm, other than having to run “kbuildsycoca4” manually (which is not new, as mentioned) it works fine here with KDE 4.11 from [noparse]KDE:Distro:Factory[/noparse]…

Does the change get written to ~/.local/share/applications/mimeapps.list ?
Maybe try to rename that file to see if it works then?

I just found this bug report which exactly sounds like your problem:

A fix is already available, so I would hope this will be fixed in 4.11.1 being released on September 3rd.