KDE 4.10.1 Upgrade: Missing Suspend menu item and broken hibernation


I have upgraded two machines: 64bit desktop and a 32bit netbook, both running openSUSE 12.2, to KDE 4.10.1. Now I am experiencing power management issues.

For the desktop, the Suspend and Hibernate items in kmenu->Leave are missing. They are not available in the Power Management settings as actions for “Suspend Session”. If I run the pm-suspend from the command line, it works fine. Suspending from within KDE 4.10 was available before the upgrade.

For the netbook, I upgraded it from 4.9 to 4.10.1. Suspend and Hibernate are missing in kmenu/Power Management as well. pm-suspend works from the command line, but pm-hibernate now results in a black screen and the netbook doesn’t turn off. I have to force it off by holding the power button. Hibernation worked fine in KDE 4.9.

Running pm-is-supported on both machines indicate that suspend and hibernation are both supported.

Anyone experience this? Is there a workaround?


Yes same here

I reported in the ML too

Same here. We have a bug.

I’m just awaiting some patched files to load to OBS
Once it does, I can test it for Raymond and we’ll see where we are…

Thanks for looking into this. I have no problem waiting. I hope this patches also fix the hibernation issue (black screen - non response - not turning off). If not, I can tackle that as a separate issue. Again, thanks!



We are looking for someone that could test the packages before they would go to general KR410 public, so volunteers wanted :wink:

Discussion here:
[opensuse-kde] kde4.10.1](http://lists.opensuse.org/opensuse-kde/2013-03/msg00010.html)
Packages info in the last mail (installing kdebase-workspace package would be enough)

I installed http://download.opensuse.org/repositories/home:/sumski:/branches:/KDE:/Release:/410/openSUSE_12.2/x86_64/kdebase4-workspace-4.10.1-897.1.x86_64.rpm
and the sleep/hibernate actions are back!

Great Martin, good to hear :slight_smile:
We are then looking to push the patch in KR410 repo, and should be available (hopefully) sometime tommorow.
Will get back here too.

Bug is now also reported upstream:

Thanks a lot for testing :wink:

I too confirm that the Index of /repositories/home:/sumski:/branches:/KDE:/Release:/410/openSUSE_12.2 repo fixes the missing menu item entries. I upgraded to the available RPMs in that repo and now the Suspend and Hibernate options are there. Suspend works on both machines, but Hibernate still results in just a back screen and the netbook does not turn off.

This may be off-topic, if it is I will move it to a new thread, but my sound on the desktop KDE no longer works?!? This is unrelated to that above repo as it stopped working when I updated to the latest KDE:Release:410 repo (before using the above repo). I checked with YaST->Hardware->Sound and Other->Play Test Sound works. Just seems like KDE (Phonon maybe?) doesn’t anymore? My sound card is listed in Phonon->Device Preference. When I select it and press “Test”, I get “Failed to set the selected audio output device”. The Backend is set to gstreamer. I tried the vlc backend but that didn’t work either.

Could this be related to KDE 4.10.1 or is this something new? The packages that were upgraded (prior to upgraded to the above repo) as listed by:
rpm -qa --last | less

Note that kdebase4-workspace-* is not listed. Those were upgraded at the same time but now are replaced from the versions found in the above repo.

libphysfs1-2.0.2-171.1                        Wed 06 Mar 2013 16:45:49
liblapack3-3.4.2-47.1                         Wed 06 Mar 2013 16:45:49
strace-4.7-32.1                               Wed 06 Mar 2013 16:45:48
libblas3-3.4.2-47.1                           Wed 06 Mar 2013 16:45:48
digikam-lang-3.0.0-161.1                      Wed 06 Mar 2013 16:45:46
kipi-plugins-lang-3.0.0-161.1                 Wed 06 Mar 2013 16:45:42
digikam-3.0.0-161.1                           Wed 06 Mar 2013 16:45:42
kipi-plugins-geolocation-3.0.0-161.1          Wed 06 Mar 2013 16:45:40
kipi-plugins-acquireimage-3.0.0-161.1         Wed 06 Mar 2013 16:45:40
kipi-plugins-3.0.0-161.1                      Wed 06 Mar 2013 16:45:38
libkgeomap-lang-3.0.0-161.1                   Wed 06 Mar 2013 16:45:37
knotes-4.10.1-386.1                           Wed 06 Mar 2013 16:45:37
ksplashx-branding-openSUSE-12.2-11.18.11      Wed 06 Mar 2013 16:45:36
ksplash-qml-branding-openSUSE-12.2-11.18.11   Wed 06 Mar 2013 16:45:36
kdm-branding-openSUSE-12.2-11.18.11           Wed 06 Mar 2013 16:45:36
gtk3-theme-oxygen-1.1.2-25.1                  Wed 06 Mar 2013 16:45:36
python-kde4-4.10.1-88.2                       Wed 06 Mar 2013 16:45:35
libmediawiki1-3.0.0-161.1                     Wed 06 Mar 2013 16:45:34
libkgeomap1-3.0.0-161.1                       Wed 06 Mar 2013 16:45:34
libkface1-3.0.0-161.1                         Wed 06 Mar 2013 16:45:34
libkdepim4-4.10.1-386.1                       Wed 06 Mar 2013 16:45:33
kwebkitpart-1.3.2-45.1                        Wed 06 Mar 2013 16:45:33
kdevelop4-plugins-php-1.4.1-46.10             Wed 06 Mar 2013 16:45:33
yast2-qt-branding-openSUSE-12.2-11.18.11      Wed 06 Mar 2013 16:45:32
gtk3-engine-oxygen-1.1.2-25.1                 Wed 06 Mar 2013 16:45:32
wallpaper-branding-openSUSE-12.2-11.18.11     Wed 06 Mar 2013 16:45:31
susegreeter-branding-openSUSE-12.2-11.18.11   Wed 06 Mar 2013 16:45:31
python-distribute-0.6.35-64.1                 Wed 06 Mar 2013 16:45:31
plymouth-branding-openSUSE-12.2-11.18.11      Wed 06 Mar 2013 16:45:13
kdelibs4-branding-openSUSE-12.2-11.18.11      Wed 06 Mar 2013 16:45:13
grub2-branding-openSUSE-12.2-11.18.11         Wed 06 Mar 2013 16:45:11
gimp-branding-openSUSE-12.2-11.18.11          Wed 06 Mar 2013 16:45:10
gfxboot-branding-openSUSE-12.2-11.18.11       Wed 06 Mar 2013 16:45:09
digikam-doc-3.0.0-161.1                       Wed 06 Mar 2013 16:45:09
branding-openSUSE-12.2-11.18.11               Wed 06 Mar 2013 16:45:06
sane-backends-32bit-1.0.23-93.1               Wed 06 Mar 2013 16:45:05

Concerning the Hibernation issue (black screen, not turning off): When I do

echo disk > /sys/power/state

The netbook hibernates correctly. It turns off. Then on reboot it starts up correctly.

I am thinking this is leaning more towards a KDE issue as it first started when I upgraded from 4.9 to 4.10 and it persists now in 4.10.1.

@ sumski

installed kdebase4-workspace-4.10.1-897.1.x86_64.rpm

and now have Sleep and Hibernate icons

both are executable

All packages tested from your repo
It’s all good


I’ve seen this issue too. Will apply the patched package ASAP to check it out on my netbook. :slight_smile:

After installing the workspace package, then logging out/in, I’ve now got my sleep/hibernate options back! :good::good:

Based on the feedback, patch has also been added to KR410 repo. Should be built/published sometime today :wink:

Thanks to everyone for testing!

OK, fix is now built and published in KR410 repo, so anyone that tested the previous packages can switch back to the main repo.

Thank you very much sumski for fixing this so quickly. Do you have any idea what could have happened to hibernation? As a work around I wrote a script that simply calls:

echo disk > /sys/power/state

I added to the permissions for the user to run the script as root in /etc/sudoers and added a .desktop file for easy launching. For some reason, clicking on Leave->Hibernate in KDE results in a back screen and the netbook doesn’t turn off.

Np, i only added Raymonds patch, so quick fix and welcome is from/for him :wink:

I wish i could help you on that one, but i don’t have a swap, so can’t hibernate to test. I’ll try to create a swap file to see what happens here. (Though i am using Factory, so conditions won’t be exactly the same)
Are you using any proprietary driver that could interfere?

Cheers for the quick fixing and delivering of the new packages.