KDE 4.10.1 failed to set audio device

My sound in KDE 4.10.1 no longer works. I checked with YaST->Hardware->Sound and Other->Play Test Sound works. Just seems like KDE (Phonon maybe?) doesn’t anymore? My sound card is listed in Phonon->Device Preference. When I select it and press “Test”, I get “Failed to set the selected audio output device”. The Backend is set to gstreamer. I tried the vlc backend but that didn’t work either.

AFACT, this happened after an update that mainly just updated branding packages. Any ideas as to what I could have broke?

No problems found here.

pc without pulseaudio: vlc plays music, kaffeine plays DVD’s

laptop with pulseaudio: vlc plays music, kaffeine plays DVD’s

can only suggest

  • toggling pulseaudio off and on
  • check your volume pre-sets
  • a forced re-install of alsa/pulseaudio packages

If you have more than one audio device
Are you sure your preferred device matches with the setting in kmix?

I’ve tried reinstalling all packages related to phonon and alsa and still no sound. I logged into KDE using root and there was sound! Seems like both my user accounts don’t have sound. Something really strange has happened with the device selection. I tried deleting all config files in .kde4 and .config that related to audio and phonon in hopes that I could force KDE to redetect.

I know the audio works because (1) Yast->Sound->Other-Play Test Sound works and (2) sound plays when logged in as root. Could this be a permission issue? It’s strange because nothing changed except I did an update that seemed to only update branding packages.

Any ideas how I can force KDE to re-detect the audio? What files I need to delete?

The solution was to add the user accounts to the audio group!?! Why that matters now I have no idea! I haven’t messed with the user account group membership since installing 12.2 a long time ago.

Hmmm, after reading this thread and the “solution” , add user to audio group , a problem I just recently noticed cleared up as well.

I very infrequently use a USB headset/microphone.
So infrequently that this could be the first since my upgrade to 12.2 from 12.1 where I know they were working.
My audio thru external speakers (audio out jack for motherboard) has worked fine.
But plugging in USB head set, it did not work and did not show in Kmix or in Personal Settings-Multimedia.
I opened YAST-Sound and the headset was visible and tested Fine.

I started to debug, happened upon this thread, tried adding user to audio group, log out, log in, all is good.

Sorry, can’t narrow down possible causes much, just something to lkeep in mind when update soon to 12.3.

I think now this is a new (security) requirement. I checked a 12.1 box that I have and my user account isn’t a member of the audio group. Sound works just fine. I suspect this was introduced with KDE 4.10 or 4.10.1.

Sorry. Can’t help much here (ie. no idea what caused this) but I had similar issue after upgrading KDE - (kernel?) message “no audio” - system sounds still worked but no sound from audio apps. Installed pavucontrol and switched on Internal Analog Audio Sterio. All OK, but YMMW!

I have the same problem after I have disabled Pulseaudio. I have added my user to audio group but sound does not work in KDE & KDE applications such as Amarok, Kopete. Also Flash videos are without sound. openSUSE 13.2.

I use kde
I don’t have pulseaudio disabled
My backend is VLC