KDE 4.1 one click installer ruined my openSUSE

Today I tried the 4.1 KDE one click install on my opensuse 11 64bit installation (4.0 preinstalled). First I ran into tons of dependencies errors I ignored. After installing it from the factory repo I restarted the xserver and I was thrown back to the terminal command prompt. No chance to get it back to start.

Now I have to reinstall from the scratch :frowning:

Is there any way to upgrade to 4.1 without that horrible dependencies errors? Did anybody test the packages before it where released and announced to be easily installed by a so called one click installer?

Sorry, I’m a bit angry about it cause it costs me a lot of time to get my desktop back to the same state I had before.

cu
Gargi

http://i283.photobucket.com/albums/kk282/Chrysantine/facepalm.jpg

You never… EVER ignore dependency errors. On that note, wait a few days until all the repositories have sync’ed KDE changes and everything has been tested to work 100%.

Is there a way to resolve the missing dependencies? :confused:

Edit: just haven’t seen your second sentence under that big picture :slight_smile:
I hope that the packages are moved into the update repo cause I think remaining in the factory repo we’ll never get all dependencies cleared.

Yes, I am sure they tested the packages. And while I didn’t use the one-click installer, I have upgraded with absolutely no issues. What I did:

  1. Install both KDE3 and KDE4, while making KDE4 the default, at install of 11.0.

zypper ref

followed by

zypper up -t package

Everything worked like a charm. This was, of course, after I set up the 3 KDE4 repos.

I think that maybe you should think a little about the statement “First I ran into tons of dependencies errors I ignored.”

I mean, seriously, that’s just not a very good decision.

Yes, normally it isn’t. But I just had cases you could ignore it. In that case it was a real mistake. But what I don’t understand is why there is a one click installer provided leading into those kind of confusions.

Edit: Next time I better test it on a virtualbox installation before I touch my working installation :wink:

cu
Gargi

This was, of course, after I set up the 3 KDE4 repos.

Which are ??

i installed via the one click and was surprised to find no Dragon Player, i thought that was a default part of 4.1?

Upgrading to 4.1 from 4.0.99 went well. I always use YaST, paterns, this time I left the 3.5 for what it is and did KDE as mentioned & Gnome. The only issue was with DidiKam / showfoto it seems I got 0.9.4 from the UNSTABLE repo and should have had 0.10.x from the Factory.

The problem the OP mentions I think has to do with him upgrading from the wrong repo. If you use the one-click install a few times, most likely you will have Factory & UNSTABLE repo’s added. Which may be fine for a single app but not for a whole sys upgrade from STABLE.

It’s got nothing to do with ‘one-click installer’. All the one-click installer
is gonna do is define one or more repositories, and then invoke a template
install (which knows a series of package names to install).

But, what you’re not understanding is that ‘the devil is in the details’.
In reality, what’s been going on for the last 2 or 3 weeks is that they
check in new editions of about 50 packages almost EVERY DAY.
So, if you happen upon the scene during the middle of them inserting
the newest versions of all their freshly rebuilt code into the repos, you’ll get a bunch
of ‘version mismatches’ that to you become ‘dependency conflicts’.

So, like they said, you decided to ignore the dependency conflicts, and
messed up your system. The rest of us just saw the conflicts, bailed out,
came back a half-hour later, refreshed, found no dependency conflicts, and installed
the next version. *

“Once burned, twice learned.”

Hope that clarifies it.*

To get the 4.1 betas, you needed to have been updating from Factory. The three repos are Community, Desktop, and Extra-Apps, all of which you can find here: KDE/Repositories - openSUSE

Boy I was mad when I had just updated KDE 4.0 last night and then found out 4.1 (which I’ve heard from many places is more stable) is available via one-click.

So I just (like 5-10 minutes ago) updated it and am using it right now. So far so good, but I do have KDE 3.5 just in case.

Oh, and for the record its the 32 bit version.

I just upgraded to 4.1. All went smoothly via 1 click.
But im rather disappointed with Kde 4.1. I really thought it would be revolutionary. But I havn’t noticed anything special about this release. :frowning:
Still can’t even highlight your icons on your desktop, and why the heck is the option to arrange icons on your desktop by vertical/horizontal removed in 4.1? arghhhh
maybe 4.2 will be better.

Why? So you’re stuck at a CLI. Big deal. This is where YaST scores.

You can run YaST from the console with the same functionality you’d have from the GUI, which will enable you to easily modify your repos and update your packages. Believe me, I had to do this a couple of times during the 4.1 testing cycle.

No need to re-install. I hate to sound like a clichee, but this isn’t Windows.

Cheers,
KV

The views of KDE and openSUSE what should be part of the default install differ, just “zypper in dragonplayer”.

cheers,

1234567890

Obviously, you haven’t yet been assimilated.:smiley:

If you ask the KDE4 developers, they tell you that any sane person
would NOT WANT ‘icons on the desktop’, so they haven’t implemented that yet.
You are supposed to use the folderview widget instead.
[And, icon placement options in folderview aren’t scheduled until 4.2, I think.]

Meanwhile, us mere mortals mostly still want our ‘icons on the desktop’, so
we keep using 3.5.x until 4.2 hits the streets.

the bug originally starting this thread will be fixed in YaST soon. - see here: https://bugzilla.novell.com/show_bug.cgi?id=413150

Assalamoalaikum

It seems to me like there is some problem with the one-click install for kde4.1 after going through the posts in this thread. Am i right? Should i go for one-click install just like that.

Do i need to remove my current kde3.5 in OpenSuSE 10.3 too?