kde 4.1 Factory Update - Plasma desktop issues

Today’s update 25th Sept

Upon re-login. Desktop reverts to a default suse green swirl background and cannot be changed.

Anyone else with this issue, or a work around?

Same problem here! :frowning:

In kde3 I could just delete ~/.kde/share/config/kdesktoprc but there’s no such file in kde4 :frowning:

  • caf4926,

update QT. I activated this repository:


I also deleted both plasma-appletsrc and plasmarc in ~/.kde4/share/config and restarted kde but no luck :frowning:

Uwe, I already have that repo and no updates available. :\

I’ll try that. Iused to have that repo then switched to plain QT

I’ll report back

No change.
Guess it’s wait and see.

Same problem. I’m reported it on http://bugs.kde.org.

On 09/25/2008 ram88 wrote:
> Same problem. I’m reported it on ‘http://bugs.kde.org
> (https://bugs.kde.org/show_bug.cgi?id=171643).

Well duh, after I did today’s update, I see what you mean! It is also not possible to change the desktop color to anything but the default grey.
They marked it as a duplicate of https://bugs.kde.org/show_bug.cgi?id=170441, but I am not sure that is correct. The symptoms seem totally different.

BTW, is that the best method to submit a bug? Since the files come from an Opensuse repo, it might be faster to submit a bug in bugzilla.novell.com. Not sure though.


Hmmm… I don’t know the best method, but if it is really a bug then they will find the solution (I hope :)). Yeah, symptoms are different and this can’t be the duplicate of that one, because it is happened today with us, but the another bug is from 2008-09-05…
BTW, I’m deleted some plasmoids from my plasma-appletsrc (folderview and plasma-weather), and now I’m posting from 4.1.1 :slight_smile:
ps.:Correct, you can’t change anything on the desktop except the plasma theme, and plasmoids.

I have been in touch directly with the guys on suse build service kde4, it seemed to news to them. And no feedback yet to report, they just clarified my bug report.
Which incidentally - Is not a grey desktop, but the green suse swirl - but anyway - whatever we are all getting we are stuck with it.

I tried a totally new .kde4 user too - but it’s just the same.

Have the same problem here. Default green desktop that can’t be changed

I had the same problem after I updated my system this afternoon. I also added the QT44 repo but it had no effect.

A fix is promised next week

— Comment #2 from Stephan Binner <stbinner@novell.com> 2008-09-25 13:40:57 MDT —
The fix will be in the KDE 4.1.2 packages next week.

I also have the same problem after updating kde, it is now kde 4.1.2 “release 52.2”.
i hope it will be fixed soon…

Yep, me too.

For any who have the Community repo in their list:

You will have dependency issues if you try and update at the moment (27th Sept), we will have to wait for the promised updates next week in the factory dektop.

I have the same problem here. Default green desktop can’t be changed

You can also configure a wallpaper in ~/.kde4/share/config/plasma-appletsrc manually: look for the containment number with the line “plugin=desktop” and eg assuming it’s “0” add a section


Sorry Beineri,
I just tried that for me it achieved nothing.