KDE 4.1 Compiz install problems

Hi all,

I’m having trouble installing Compiz via the one-click-install.

I have tried the one-click for KDE and for KDE4, but I continually get these errors:

nothing provides libplasma.so.1()(64bit) needed by compiz-kde4-0.7.8-9.1.x86_64

nothing provides python < 2.6 needed by compizconfig-settings-manager-0.7.8-2.4.x86_64

I am running a fresh install of OpenSuse 11.1 64 bit version on an ASUS F8VA.

Be gentle - I’m not used to either KDE or rpm files… or Compiz for that matter. :smiley:

You don’t actually need to use any OneClick install - Compiz is installed natively in kde4.

Config Desktop - Desktop - Desktop Effects

All effects section to adjust settings
use kwin as window manager (in session manager)

Hey caf, thanks the reply mate!

That was actually the first thing I tried, but i get this error message pop up when I tick the “Enable desktop effects box” and then press apply:

Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type.

So I did what the message says and it all seemed peachy to me, then I tried to update it with the one-click…

Did I do more damage?..

Alright - It turns out that the seocnd monitor I have plugged in was causing the effects not to turn on. It’s disabled now and the effects say that they’re on, but nothing fancy happens… ever.

I turned on the explosion effect when windows close… nothing.

Is there somewhere else I need to turn 3D acceleration on…?

Also - Kwin is my window manager, but I didn’t have to change it (i even tried setting it to compiz, but still nothing).

Your not the only one. I am having the same problem. I choose compiz as my default window manager and it isnt doing anything.

did you check Compiz Fusion ?

Yes I have, quite thoroughly.

It seems like all 3D acceleration is disabled, despite it being set to enabled. When i scroll through web pages in any of the browsers, it’s very slow and choppy, as is shrinking windows.

Also worth mentioning is that fgl_glxgears and fglrxinfo return the following:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  14
  Current serial number in output stream:  14


Sorry to be irritating - bump!

It could be that your graphics is just not going to manage this: What exactly do you have in that regard?

FYI to others:
The settings in the opening page of desktop effects

Make sure you have effects for desktop switching set to cube