KDE 4.1.1 Is in the repo's

I just ran updates to 4.1 and all is fine for me, and those unresolved dependency issues sorted themselves out too.

how does one most safely go about getting it from a clean 11.0 KDE4 install? :slight_smile:

I updated every KDE related package to version 4.1.1 but I’m getting problems with compositing effects (native kwin effects). They all stoped working!!!

Desktop runs smoothly but no matter how many times I enable/disable desktop effects and 3D acceleration KDE seems to ignore my settings and gives me no “wobbly windows” or “desktop zoom” whatsoever.

Has anybody else got this problem?? Help please!!

This one click install worked for me when I first updated from 4.0.4 to 4.1.0. However, you might run into problems with dependencies. This is because there are packages which don’t get updated, and still need the old 4.0.4 libraries, whereas the v4.1.x ones need the newest, and both versions can’t be installed at once.

I was abble to solve this by removing the old apps and, once everything was updated, getting them back. VERY IMPORTANT: I did this without ever leaving YaST2, using its dependency solving utility. It might be boring going through all the options but it is worth the while.

Hi,

I’m having problems with desktop effects too, after updating to 4.1.1.

Kwin says this:

kwin: X Error (error: BadAlloc [11], request: X_GLXCreatePixmap[GLX+22], resource: 0x1801d84)
kwin: X Error (error: GLXBadDrawable[GLX+2], request: X_GLXGetDrawableAttributes[GLX+29], resource: 0x1801d84)
kwin: X Error (error: BadDrawable [9], request <unknown> [145:4], resource: 0x1801d84)
kwin(18434): Compositing self-check failed, disabling compositing.

Agreed, it’s not working. Sure to be a fix though. I hadn’t noticed as I don’t use it really.

cheers, all working.

people on dot.kde are having problems with compositing effecrts too.

Same here, but only when using OpenGL. Xrender works, but that’s too slow to be useful. If, for some reason, kwin decides that composite isn’t available shouldn’t the settings program reflect that (i.e. greyed out)?

Not sure if it’s driver related, but I’m using nvidia and their latest beta. Everything else that depends on OpenGL works as it should though.

same here - desktop effects are broken with 4.1.1 (using stable NVidia driver). XRender works but
a) very slow
b) wrong in many aspects of the rendering effect.

Worse is the problem that when you tried to activate the desktop effects, something happens with the OpenGL acceleration.
The framerates for OpenGL applications drops dramatically. The X2 Benchmark shows a decrease from 26-27fps to 12-13fps (I benchmark nearly every day to track changes in KDE and NVidia software)
Deactivating the desktop effects (which actually never appeared) doesn’t help as long as the computer stays in runlevel 5. Only rebooting (or maybe go into runlevel 3 and switch back to 5) helps to regain the OpenGL acceleration.

I’m having the same issues with effects not working in kde 4.1.1. I was using the latest nvidia stable drivers, so I switched to the beta drivers. No change, although video performance appears to have increased.

Yeah, I have the same problem on my OpenSuse 11 (Geforce 7600GS). No desktop effects, only XRender works but very slowly. I hope there will be solution as soon as possible. :slight_smile: Anyway it happens only in OpenSuse or even in others distro?

# rpm -q --changelog -p "http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0/x86_64/kde4-kwin-4.1.1-57.1.x86_64.rpm" | head -n 13
* Thu Sep 04 2008 llunak@suse.cz
- temporarily disable kwin self-check until the problem is found
  (bnc#422532)

* Wed Sep 03 2008 dmueller@suse.de
- add libsensors4 support

* Tue Sep 02 2008 llunak@suse.cz
- switch to the kwin branch for 11.1 (e.g. bnc#418772)

* Thu Aug 28 2008 dmueller@suse.de
- update to 4.1.1
  * see http://kde.org/announcements/changelogs/changelog4_1to4_1_1.php

No, it just happens in every Distro, because it is a bug of KDE 4.1.1.
So the composite dosn’t work: :’(
Bug 170085 – selfcheck fails

Andy.Reddy

Problem is well known:
Bug 170346 - Compositing disabled after update to 4.1.1 and Bug 170085 - selfcheck fails

And I think there exists a patch:
Revision 854546

But how to use it?

Issues with desktop effects now seem solved.

Still not solved for me with kde4-kwin-4.1.1-57.1. I get the dialog telling me desktop effects cannot be enabled, but desktop effects work fine while that dialog is showing. As soon as I close it, desktop effects are disabled.

So to use desktop effects I can either leave the dialog open and hide it in a virtual desktop, or of course use Compiz, which works fine.

kde4-kwin-4.1.1-57.1 works for me fine now.:slight_smile: