KAudioCreator gets error messages (still)

Very pi**ed off here. I have new box with new 11.1 installation and I am simply trying to rip a cd to my upnp server with KAudioCreator. As soon as I start the ripping I get an error message:-

Unknown error. If you have a cd in the drive try running cdparanoia -vsQ as yourself (not root). Do you see a track list? If not, make sure you have permission to access the CD device. If you are using SCSI emulation (possible if you have an IDE CD writer) then make sure you check that you have read and write permissions on the generic SCSI device, which is probably /dev/sg0, /dev/sg1, etc… If it still does not work, try typing audiocd:/?device=/dev/sg0 (or similar) to tell kio_audiocd which device your CD-ROM is.

If I run cdparanoia -vsQ I get a list of tracks and these also show in the jobs list in Ripper.

The device shown as selected in KAudioCreator is /dev/cdrom and all the permissions are set. I am a member of the users group and have even tried adding cdrom to my permissions (which is not correct but has been suggested as a quick fix).

Strange thing is if I select only one track it will on occasions work.

I have reported a bug but no fix as yet but does anybody else have this problem with KAudioCreator and is there a work around?

The permissions issue with cd’s in 11.1 has been bugfixed via updates so no need to alter settings.
I always use k3b for ripping and it works just fine and have also used Jripper. Just make sure you have all the necessary codecs:

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Flash, k3b, Amarok - Install Guide - openSUSE Forums

Hi and many thanks for the reply. I know about the permissions fix but my problem has similar symptom. I am sure there is a bug in KAudioCreator and do not believe it is getting any attention from the “owner”

I have just ripped and encoded two tracks separately using KaudioCreator with Lame encoder and both ran to completion. On the second run however the cd eject would no longer work.

If I select all tracks I get the above error message and all goes pear shaped.

Using Grip + Lame all works by the book. Only one problem with grip. No help or man pages. How do I get these installed please?

Regards and thanks again.

Grip User’s Guide

Brilliant, I have the info I need so that keeps me moving forward so thanks again. OTOH why do the help buttons in grip not work? Can I get the above document installed and integrated with grip so that they do?

I have never used Grip. Sorry.
And in such circumstances I tend to move on from applications that are not working for me and find something that does.

Hi and thanks. Yes, that is what I am doing and Grip works fine on KDE but I needed the manual. I guess it would already be there if I had installed a Gnome desktop but I chose KDE when I first moved over to Linux from OS/2 a few years ago and I guess the habit has stuck.

However the KAudiocreator bug is an old problem and somebody should have fixed it by now. I guess it has no priority whatsoever.

Thanks again.