kate starts and kde4.1 login :(

I dont know want i did but today every time i login to kde4.1 , kate is loaded with a empty ducoment ?? how can i fix this ?
there is nothing in ~/.kde4/autostart .
where is the configuratuion that tells the kde4 to run programs at login ??
and the funny part is it grows in number of kate instances . i mean the second time there was 2 kate :),and the third time 3 kate .

check in ~/.config/autostart

there are just these files

eagled-autostart.desktop dayplanner_auto.desktop opensuseupdater-autostart.desktop

Not sure how you can stop it opening at login unless you are not closing it before logging out.

You can get rid of the empty document by going to Configure Kate > Sessions. If you have selected Start new session, this may explain why it shows you an open document.

Something might be screwed up in the place where KDE stores your sessions, so it can continue them when you log back in (alluded to by john_hudson).

If none of the other ideas succeed, you could always try to start KDE with an empty session, and then stay there or go back to saving your sessions after you have successfully logged into an empty session. To start an empty session, go to configure desktop->advanced->session manager, and under “on login”, choose an empty session.

i think i found the problem , though its a guess
i deleted my ~/.kde4/ folder and tried again anew.
and after i repeated my last steps in the former /.kde4/ i found out ( i think) that the problem was from one of downloaded plasmoid (from “download from internet” option ,in “add widgets”) ,its called “prayer times plasmoid”. i think its the source of problem because installing it doesn’t add a widget to desktop like its supposed to do add after logoff and login , kate starts :slight_smile:

it happend again without installing that plasmoid
dear god what I am doing wrong???

in windows there was a place you could see all startup autoruns.where is it in opensuse :frowning:

i can confirm it.
alin@green:~> kate --version
Qt: 4.4.0
KDE: 4.1.1 (KDE 4.1.0 (4.1 >= 20080722)) “release 19.3”
Kate: 3.1.1


have you tried this? It worked for me.


you mean you had the same problem , … thank god I thought i did something that caused this.

i try you way and report back :))

by the way I have temprebobly solved it by addinf kate to the list of excluded program from sessions. :slight_smile:

starting empty sessions solves this problem (obviously)

but going back to loading saved sessions still loads an instance of kate :frowning:

so i checked loading option but added kate to banned from loading in login list

The problem is, that kate does not quit if you hit the close button in the windeco. You can check this if you run kate from a terminal. So of you start kate from the menu and close it the process is still running on logout and if you login again kde will restore kate. This does not happe if you close kate with ctrl+Q (file->quit). This is a kde bug which is also in konqueror and som other apps.

thanks for your time

but can’t they (kde developer) fix this obvious bug???
that shouldn’t be so hard , right?

I guess it’s already fixed but not yet in the suse packages:

Bug 167826 - Konqueror processes never terminate