kalarm: only the first audio alarm works normally

Since the last kde update I have observed that when an audio alarm is triggered everything is normal: you see the window with the message and hear the sound.
But from that moment on the alarms show the window, but no sound is heard.
If I quit the application and start it again, the same happens: first alarm works normally, the others are mute.
I removed the config files and started again, but this resolved nothing.
Any idea?

Go to start menu–>system settings–>multimedia–>phonon
http://img683.imageshack.us/img683/1620/64614789.png

Go to notification and check sound there. Send me results.

Thanks for your answer.

There are four devices listed there. In this order:

HDA Intell (STAC92xx Analog)
default
hw:0,0
hw:0,1

Clicking on “Test” for each one of them, everything is normal (test sound perfectly audible) for the first three. Nothing happens for the four one (hw:0,1).

Anyway, sound works normally (other notifications, amarok, etc.). The problem is just in kalarm, except for the first alarm trigger after the launch of the application.

Try to up-grade your sound card there and check again. Could you send me picture of your phonon?

I think I have resolved it.
In system settings–>multimedia–>phonon I went to the Backend tab and gave preference to Xine (before gstreamer had it) and everything seems to work normally now.
I’m not sure that this makes sense. At least it works for now.
Thanks for your suggestions.

Now you have sound. Right? Make reboot.

You mean that
http://img695.imageshack.us/img695/1972/36908801.png

Firstly I wanted to make sure that your sound card is “up-grade” and then to set it with xine,vlc or gstreamer.

Anyway now the problem has fixed.

Yes, now everything seems to work normally.
Before I had the backends preference as in your image. I put Xine on top of the list. That was what resolved the problem.
Thanks again.

You’re welcome!;):slight_smile:

I was having problems with analog sound until I moved Xine to the preferred backend also.

11.4 RC4

Could you tell me your features of computer?

opensuse 11.3 kde 4.6
sound card: 82801H (ICH8 Family) HD Audio Controller

Is this what you wanted to know?

I should ask you these features before give advice ok??

Anyway the problem was solved.

[QUOTE=stamostolias;2298599Anyway the problem was solved.[/QUOTE]

Yes. Thanks again for your help.