KAlarm is silent and other sound probs

I have OS 11.2 and default kde 4.3.5.
I also dual boot to Mepis with the same KDE and OS 11.2 is also on a different computer.

On all the above platforms I’m really dissappointed with KDE4 for too many reasons - so I use Gnome for my desktop, but I need some KDE apps -if they still function.
Of course I’m peeved at the proprietarism that hamstrings open source projects.

On the whole I have system sounds - startup, alerts, messages etc - kde, gnome, open suse and mepis both machines.

VLC and Amarok work like the champions they are.
XMMS and sox handle everything too and appaently mplayer.
Even flash works and html5 audio code works in chrome
(?mp3?)

Kaffiene and Totem crash on mp3’s after a few moments. (never had much use for those anyway).
Moonlight just can’t do whatever it thinks it’s supposed to do whenever it comes up.
So far I don’t care about the disfunctional working programs - I have functionality.

KAlarm can’t even play a KDE ogg file.
It might preview a short .ogg file or garble a long file in the browse for file mode, but, it will be silent in test mode or when it’s supposed to wake me up.
(I make it execute scripts running sox in xterm)

One other concern, Java and perhaps Python etc may also be silent -. java.Applet.newAudioClip() didn’t make a peep.
I need more testing (I might be outside the ‘sandbox’).

I would really like to see (hear) KAlarm work properly.

~steve~

You might benefit from following this carefully.
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Notice the need to remove the VidoLan or libdvdcss repo if you have them. The package libdvdcss needs to remain though.

The way I would recommend Kaffeine problems be investigated is to first see if it is the engine selected that has the problem.

If using KDE3 Kaffeine, one can select the engine in use in Kaffeine itself. If using KDE4 Kaffeine, one needs to select the engine in use via the KDE4 desktop backend, which is done via KDE > Configure Desktop > Multimedia.

I have no idea how that is selected in Gnome but I assume some of the Gnome fans should know.

If there is an option to select the xine backend (instead of the gstreamer) then IMHO one should install the packman packaged libxine1 and xine-ui, and use the xine-ui to explore any possible problems with the xine backend.