kaffeine / xine crashes when playing avi files


I have just installed openSuse 11.2 (64bit), and I installed the avi codecs as described in Restricted Formats/11.2 - openSUSE-Community with the 1-click installation for KDE. But kaffeine and xine are crashing when I try to play avi files.

One thing I found out is that all packages are 64 bit packages only the w32codec-all version is 20071007-0.pm.1.1-i586 and I don’t get offered a _64 package. Is this OK? What else could be the problem?


Follow this carefully
Multi-media and Restricted Format Installation Guide - openSUSE Forums

I have the same problem.

libxine from Packman (64 bits)

I think is libxine the problem because the same crash happends if instead of running kaffeine I run xine-ui, but also if I switch to Gstreamer as the multimedia motor then kaffeine run just fine with avi files.

But I do not want to use gstreamer as the motor for multimedia.

Do this

thanks worked for me as well, I used to change per package but this is much easier
now I’ll try VLC :wink: as well