Kaffeine unable to play any DVD

Hello , I installed Suse 11, but I’m not able to play any DVD

I want to use kaffeine as front end player

Kaffeine error: (translated from german) The used version of [FONT=“Arial”]Xine has only a limited set of supported codecs. DVDs cannot be played.

I removed all xine stuff via YAST and installed libxine1 from packman repository

(I have only 4 repos activated (OSS, Non-OSS, Update and Packman))

Thereafter the YASTI search result for Xine doesn’t show any installed XINE files.

Yast search result for libxine1:
installed:

libxine1
libxine1-aa
libxine1-arts
libxine1-codecs
libxine1-directfb
libxine1-esd
libxine1-gnome-vfs
libxine1-jack
libxine1-pulse
libxine1-sdl

repository: 1.1.15-44.pm.0-i686 from Index of /pub/packman/suse/11.0

do I have to install xineui again?

The kaffeine xine parameter settings of the decoder are:

/usr/lib/RealPlayer10/codecs (external.real_codecs_path)???

/usr/lib/win32/ (externa.win32_codecs_path)

Can somebody help me to make Kaffeine play DVDs?

Next time you provide a list of rpms, please include the version numbers. For example on my openSUSE-11.1 beta2 I have:

libxine1-1.1.15-44.pm.1
amarok-xine-1.4.10-1.35
xine-ui-0.99.5-221.16
libxine1-arts-1.1.15-44.pm.1
libxine1-esd-1.1.15-44.pm.1
libxine1-pulse-1.1.15-44.pm.1
libxine1-aa-1.1.15-44.pm.1
libxine1-codecs-1.1.15-44.pm.1 

I do not know the exact cause of this error, but things you could do are:

A quick way to get such an xine version # list , is to type in a gnome-terminal or a konsole:
rpm -qa | grep xine

Thank you for the help!

Here is the required information:
OS Suse 11.0-2.6.25.16-0.1
Kaffeine 0.8.6-54.1 (0.8.7-0.pm1)
libxine1 (1.1.15-44.pm.0)
libxine1-aa (1.1.15-44.pm.0)
libxine1-arts (1.1.15-44.pm.0)
libxine1-codecs (1.1.15-44.pm.0)
libxine1-directfb (1.1.15-44.pm.0)
libxine1-esd (1.1.15-44.pm.0)
libxine1-gnome-vfs (1.1.15-44.pm.0)
libxine1-jack (1.1.15-44.pm.0)
libxine1-pulse (1.1.15-44.pm.0)
libxine1-sdl (1.1.15-44.pm.0)
xine-ui 0.99.5cvs-20080426.pm.0
amarok-xine 1.4.10-100pm.1
amarok 1.4.9.1-27.1 (1.4.10-100.pm.1

when I try to install libdvdnav I get:

YaST2 conflicts list - generated 2008-10-19 20:28:47

liboil-0_3-0-0.3.15-0.pm.2.i586 makes liboil <= 0.3.14 obsolete by offering
liboil-0.3.14-18.1.i586

following Actions will be done:
liboil-0_3-0-0.3.15-0.pm.2.i586 not install
libavcodec52-0.4.9.15594svn-20081010.pm.2143.i686 not install
Replace liboil-0.3.14-18.1.i586 by liboil-0_3-0-0.3.15-0.pm.2.i586

YaST2 conflicts list END

when I try to replace it and say (check again) the radio button gets unchecked again

I Get the same error for libdvdread3 and libffmpeg

when I try to install libdvdcss2 from repository Index of /suse/11.0

nothing is found.

So, does anybody have an idea, what I van try further?

This should be easy to sort.

Simply open YaST > Software > Software management and mark liboil-0.3.14-18.1.i586 for removal and mark liboil-0_3-0-0.3.15-0.pm.2.i586 for installation. Mark no other apps. And then apply that operation. Then once that is complete, proceed as before with the other applications.