Kaffeine not working on OpenSUSE 13.1 (64bit)


I recently did a fresh install of OpenSUSE 13.1 (64bit) and, for some reason, Kaffeine is not working. When I attempt to play any video then I simply get a black screen and no video. I have tried a number of formats including .avi, .flv, .mov, .mpg, .mp4 and .ac3 but nothing works. I have installed the multimedia codecs from the 1-click install at http://opensuse-community.org/ which is referred by the “Multimedia In One Click” sticky thread (first thread in this forum) and I have verified that the following programs were successfully installed:


In fact, I have reinstalled all of these in addition to Kaffeine itself several times but no joy.

All the while, the following programs work just fine:

Dragon Player
VLC Media Player

I would blame the problem on the KDE codecs except Dragon Player and Kplayer use the same KDE codecs as Kaffeine.

At the same time, I have another OpenSUSE 13.1 (64bit) installation where Kaffeine is working fine. In any event, I am stumped. So, if anyone has any ideas, then please let me know.



Hi Gordon,

I was having problems with recent installations of KDE and XFCE in OpenSUSE. All fresh installation and “One-Click Install” don’t worked for me.

So… a guy help me in this Thread: https://forums.opensuse.org/showthread.php/496272-Can-t-play-MP4-DVD-in-Totem-on-XFCE

Off course, Kaffeine use Xine codecs, but I think that will resolve.

1 - First I added the repositories in Yast -> Software Manager -> Configuration -> Repositories -> Add -> Community Repositories and checked Packman and libdvdcss (if you want to play DVDs)
2 - Install plugins
3 - Full repository Vendor change update to Packman -> http://en.opensuse.org/SDB:Vendor_change_update#Full_repository_Vendor_changeBut here, I cannot do it in Yast, because the displayed options doesn’t exist for me. The zypper repos will print the repositories, I get the second column for the next command.

sudo zypper repos
sudo zypper dup --from ftp.gwdg.de-suse

4 - Remove .cache folder on my Home directory:

rm -rf .cache/

You must have read that VLC and Packman repositories will mess all multimedia codecs. So, don’t enable these two.

Another think, VLC and Mplayer, for what I remember use they own codecs, this is why most of time they work.

Try that!

See if the problem exists for a test user.
Start kaffeine from a terminal window. It will throw output in the terminal. Try to play a video and check the output in the terminal.
Meanwhile, post output from

zypper lr -d

between CODE tags, the # in the editor

This does not sound like a codec problem to me, more like a video output problem.

What video card do you have? What driver do you use?

What output do you get when you run kaffeine in a terminal window?

Make sure you have libxine2 from Packman. That one uses vdpau by default, which should be the best choice for nvidia cards. The openSUSE package doesn’t include vdpau support and uses VA-API which doesn’t work with nvidia cards, unless you install vdpau-video.

Try to set a different video.driver in ~/.kde4/share/apps/kaffeine/xine-config. Does it work with “xshm” for example? That one should work in any case, but doesn’t use any hardware acceleration whatsoever.