kaffeine needs legal clearance

Using opensuse 11.4, have installed every possible download and add-on for kaffeine, but still get same excuse that can’t play due to need for a legal clearance [supposedly found on suse site, but it not there].
Where can I download this additional add-on so can overcome legal blockage to use of kaffeine?

The support for openSUSE 11.4 has ended on November 5th 2012 after over 19 months of lifetime. Project Evergreen will continue support for openSUSE 11.4.

You may be better asking this question in the Evergreen forum.

Hi
On the move, temporarily closed.

Hi
Moved and reopened for consumption…

On Mon, 22 Jun 2015 23:06:01 +0000, malcolmlewis wrote:

> wiliamvw;2716419 Wrote:
>> Using opensuse 11.4, have installed every possible download and add-on
>> for kaffeine, but still get same excuse that can’t play due to need for
>> a legal clearance [supposedly found on suse site, but it not there].
>> Where can I download this additional add-on so can overcome legal
>> blockage to use of kaffeine?
> Hi Moved and reopened for consumption…

To the OP - we need specifics of the message you receive. First I’ve
ever heard of this type of issue.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 2015-06-23 02:32, Jim Henderson wrote:
> On Mon, 22 Jun 2015 23:06:01 +0000, malcolmlewis wrote:
>
>> wiliamvw;2716419 Wrote:
>>> Using opensuse 11.4, have installed every possible download and add-on
>>> for kaffeine, but still get same excuse that can’t play due to need for
>>> a legal clearance [supposedly found on suse site, but it not there].
>>> Where can I download this additional add-on so can overcome legal
>>> blockage to use of kaffeine?
>> Hi Moved and reopened for consumption…
>
> To the OP - we need specifics of the message you receive. First I’ve
> ever heard of this type of issue.

Guessing, it could be about the multimedia codecs. It is a legal issue,
after all.

wiliamvw: you need to follow the instructions in the multimedia sticky.
But I doubt that the links to the one-click for 11.4 still work.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On Tue, 23 Jun 2015 01:38:05 +0000, Carlos E. R. wrote:

> On 2015-06-23 02:32, Jim Henderson wrote:
>> On Mon, 22 Jun 2015 23:06:01 +0000, malcolmlewis wrote:
>>
>>> wiliamvw;2716419 Wrote:
>>>> Using opensuse 11.4, have installed every possible download and
>>>> add-on for kaffeine, but still get same excuse that can’t play due to
>>>> need for a legal clearance [supposedly found on suse site, but it not
>>>> there]. Where can I download this additional add-on so can overcome
>>>> legal blockage to use of kaffeine?
>>> Hi Moved and reopened for consumption…
>>
>> To the OP - we need specifics of the message you receive. First I’ve
>> ever heard of this type of issue.
>
> Guessing, it could be about the multimedia codecs. It is a legal issue,
> after all.
>
> wiliamvw: you need to follow the instructions in the multimedia sticky.
> But I doubt that the links to the one-click for 11.4 still work.

I’m not aware of any “warning” that’s displayed that takes you to the
SUSE website. Hence the need for the specific message received.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 2015-06-23 04:10, Jim Henderson wrote:
> On Tue, 23 Jun 2015 01:38:05 +0000, Carlos E. R. wrote:

> I’m not aware of any “warning” that’s displayed that takes you to the
> SUSE website.

Me neither :slight_smile:

But I guess around that way. I have the vague recollection of seeing
legal related warnings years ago with that software. I think there were
attempts to design something that would try to automatically install
needed codecs or whatever, perhaps fluendo, and perhaps links to more
information.

I have an 11.4 without packman installed, but kaffeine is not installed
there and I don’t intend to do, to verify the message…

> Hence the need for the specific message received.

Yes, I agree.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Kaffeine displays a dialog offering to search for the necessary codecs (libxine2-codecs) if they are not installed. If it cannot find them in the configured repos, it displays a link to some openSUSE site (which doesn’t exist any more unfortunately) explaining further details.

Add the Packman repo and this should work. If not, install libxine2-codecs manually (from Packman), and the dialog should disappear.
If you don’t want to install the codecs for whatever reasons, just choose “Don’t show this again” in the dialog to get rid of it. But then you’ll only be able to play open formats like OGG/Theora.

PS: Unfortunately, Kaffeine in 11.4 still uses libxine1, which is not available any more on Packman. You’re out of luck there I’m afraid.
Better upgrade to a later openSUSE version if you want to play multimedia files, or use a different player like Xine itself (package xine-ui), VLC or MPlayer.

Have a similar result when searching for missing codecs on my alternative Evergreen 11.4/Gnome2 system, but not with [now obsoleted] installed libxine1 package(s). The search rarely worked out anyway, even with Packman repo enabled. At least with old Gnome2, the informational response still doesn’t send one to a defunct web page and its other links work, including “legal”.

PS. VLC may not be a smooth ride on Evergreen 11.4, although I rarely use it. I’ve just noticed a problem with the GUI not opening, and throwing errors on opening from command line. Will look at that later.

Yes, as I said, this dialog only appears if the codecs are not installed.

And libxine1-codecs is not available any more (not even for 11.4), so the search cannot find/install it.

The search rarely worked out anyway, even with Packman repo enabled.

ksuseinstall (which is used for this) was broken in 13.1/13.2/Factory/Tumbleweed, because of changes in zypper. I fixed that in December.

The Kaffeine package in 13.1/13.2 still searches for libxine1-codecs though, although it would need libxine2-codecs.
I fixed this too in KDE:Extra (and Factory/Tumbleweed therefore), but that’s still a “problem” in regular openSUSE releases (since 12.2). If you install libxine2 from Packman, you get libxine2-codecs automatically anyway though, as it is recommended by libxine2.

The startup check for codecs doesn’t look for a particular package installed, but asks libxine directly whether it supports MP3 files.
So this is rather a minor issue anyway IMHO.

At least with old Gnome2, the informational response still doesn’t send one to a defunct web page and its other links work, including “legal”.

The actual page it sends you to doesn’t exist, so you get redirected to a general page.

I’ll continue this here in case the OP goes for alternative media player on 11.4, where for example on my system MPlayer is working. Totem, and even Banshee can play videos including all my .mp4 files.

BTW after vlc update software manager had notified about vlc-codects and projectM packages, so manually installed those.

The latest VLC recently installed: vlc-2.2.1-285.2.x86_64, only runs from command line here with opening errors:

VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[00000000006d56f8] core demux error: corrupt module: /usr/lib64/vlc/plugins/access/libdvdnav_plugin.so
[0000000000607678] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.

I checked libdvdnav4 and its dependency on libdvdread4. Both had updates waiting for 4.1.3 –> 5.0.3
libdvdnav4 updated ok, but libdvdread4 fails with a conflict against a file required by libdvdnav4 which it should be providing anyway. This looks like an error with the libdvdread4 package (package info being given as x86-32, very strange).

Still getting the same opening error, but some .mp4’s work and some don’t wrt no audio and more error messages in terminal.

PS. Just tried updating libdvdread4 to get copy the actual conflict message, and it now works so a Packman correction must have just reached the repo mirror. :wink:
I need to logoff or reboot to get do further clean testing, will come back with result.

Confirming the updates to libdvdnav4 and libdvdread4 have fixed the opening error “core demux error: corrupt module: /usr/lib64/vlc/plugins/access/libdvdnav_plugin.so”. The other message seems normal.

Now I’m getting a corrupt module error for liblibass…, the libass packages are installed. Still having some .mp4 issues and vlc only runs from command line. Just a guess, but maybe missing a package from the gstreamer haystack.

Yes, but that error would only break DVD menus.

Now I’m getting a corrupt module error for liblibass…, the libass packages are installed.

Hm. Never seen that one, but have you installed libass from Packman?
This should only affect subtitles though.

Still having some .mp4 issues and vlc only runs from command line.

Hm. Maybe somethings wrong in the .desktop file?

Just a guess, but maybe missing a package from the gstreamer haystack.

VLC does not use gstreamer at all.

Still, I would suggest to do a full repository switch to Packman, this should sort out most problems of incompatible packages.
Also try to delete the VLC config, ~/.config/vlc/ and ~/.local/share/vlc/. Although that shouldn’t cause an audio problem with certain mp4 files…
Are you sure the files themselves are ok?

All good suggestions…

Yes, and clearing the easy ones at least feels like progress is being made now. :slight_smile:

Hm. Never seen that one, but have you installed libass from Packman?
This should only affect subtitles though.

Yes, libass5 already installed from Packman, and have just removed libass4 (11.4 oss) as nothing needed it - no difference so far.

Hm. Maybe somethings wrong in the .desktop file?

Yes, with the gnome2 menu editor I changed a /usr/bin/… command (with some parameters) to plain “vlc” minus quotes. That fixed opening from menu.

VLC does not use gstreamer at all.

OK, that’s a relief, having been through the haystack before to fix .mp4 playback for the other players - adding gstreamer-0_10-plugins-ffmpeg. I haven’t used VLC on 11.4 for a very long time and video playback isn’t the reason I keep an Evergreen system. :slight_smile:

Still, I would suggest to do a full repository switch to Packman, this should sort out most problems of incompatible packages.

Right, I began switching a few packages late yesterday, and also found a good few obsolete ones which I removed. Just finished off the last two or three, checking with YaST’s repo switch, but there is stuff I don’t want to switch anyway, e.g. jack packages. None looked obviously hopeful, and no change to the errors at this point.

Also try to delete the VLC config, ~/.config/vlc/ and ~/.local/share/vlc/. Although that shouldn’t cause an audio problem with certain mp4 files…
Are you sure the files themselves are ok?

Sure in as far as VLC runs them perfectly on 13.1/KDE4 [and Tumbleweed], yesterday when started from command line to look for similar errors.

Haven’t done those config files separately yet, but I decided to uninstall all VLC related packages, reboot and re-install the six-pack. I’m pretty sure that finally removed the libass plugin error message - that’s progress. However the following original error, constantly repeating, remains on three .mp4’s coupled with staccato bleeps instead of proper sound.

[00000000006ea948] alsa audio output error: cannot estimate delay: Input/output error

Just now I reproduced the same errors and sound effects by interrupting the transport, by clicking on the progress bar, on a good .mp4 that plays ok on this system.

Strike that, it must have been a fluke transient effect, as I can no longer reproduce it that way on a newly opened VLC player.

See here:
http://lists.links2linux.de/pipermail/packman/2015-March/013476.html

In short, try to select jack as output in VLC’s audio settings (although that doesn’t seem to be possible here on my 13.2 system…).

Or if you are using PulseAudio (likely if you have GNOME), try switching to this instead.

Interesting link but contains unconvincing instructions wrt to just installing libjack0, it’s a library not the server… here goes anyway:

Removed jack and switched libjack0 to Packman, to recreate the link’s instruction. Selected “Jack audio output” in VLC’s Audio preferences. BTW there is no Pulse output module listed in the drop-down. Played .mp4, video played smoothly with absolutely no sound and no old errors. To quote the link, “things should improve”, yes but there’s no audio, not a beep, and predictably a new error:

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
[00000000006ea948] jack audio output error: failed to connect to JACK server
[00000000006ea948] core audio output error: module not functional
[00007fd8d7e85868] core decoder error: failed to create audio output

If Packman’s version of jack is going to work, and its a big if given past results, I know how to set it up but it’s not an appropriate solution. :slight_smile:

Well, you do need to start the jack server first I suppose.
And you probably wouldn’t necessarily have to install libjack0 from Packman. Although the one from the standard 11.4 repos would probably be too old I’d guess.

If Packman’s version of jack is going to work, and its a big if given past results, I know how to set it up but it’s not an appropriate solution. :slight_smile:

But at least it would show that the problem is not in VLC’s codecs. Probably an alsa audio driver problem then, and maybe very specific to the actual hardware in use…

Well, yes. By default VLC –> [ALSA plug-in]PulseAudio. As you probably know running VLC –> JACK means killing PA. That’s yet another fact the guy in the packman link failed to mention.

Before moving to a proper jack setup, I wanted to check VLC’s normal audio output path through the eyes of pavucontrol. VLC’s audio was totally dead after the libpulse0 fiasco, even after twice resetting its Audio output prefs to ALSA. However, PA was fine - all other players still worked. Tried logging out/in but no VLC audio, even nothing after a reboot! So VLC must use persistent config data, and its Audio ouput prefence setting was not resetting (?). I’ve seen that before with VLC, albeit a long time ago.

Then I remembered those “VLC config, ~/.config/vlc/ and ~/.local/share/vlc/” folders you posted. Voila, removing them restored VLC’s audio [settings]. Could see the application output levels with pavucontrol and the best of the .mp4’s.

I won’t need to investigate this at least

But at least it would show that the problem is not in VLC’s codecs. Probably an alsa audio driver problem then, and maybe very specific to the actual hardware in use…

since VLC now plays all my .mp4 files, without any audio errors - not one! :smiley: I might revisit the libpulse0 thing, but not right now.

Thanks for the help, one of your suggestions hit the jackpot. :wink: