Kaffeine crashes

I’ve already spent several hours trying to find any info on this. Looked on KDE forums, read the FAQ’s and looked in bug lists.

I have the following:
Linux 3.1.10-1.16-desktop x86_64
openSUSE 12.1 (x86_64)
KDE 4.7.2 “release 5”

I don’t like the functionality of the latest Kaffeine so I have stuck with Kaffeine/KDE3. # kaffeine --version gives:

Qt: 3.3.8c
KDE: 3.5.10 "release 193" 
Kaffeine Player: 0.8.8

The application opens OK, but as soon as I try to open a file or CD/DVD it crashes. I’ve searched the /var/log but can find nothing of any use. It had been working perfectly until Sunday when I did my weekly scan for updates.

I’ve looked through the history of that update and tried rolling back some of the gstreamer updates but to no effect. I even tried installing the latest version of Kaffeine but that crashes too. I really don’t want to have to do a clean install, as I have this one working just they way I want.

Has any one had a similar problem?

When a GUI application fails without tellling much, it is allways usefull to start it from a terminal. Then you will at least see if it outputs some error messages.

Let me say that I was the biggest fan of Kaffeine for KDE 3 and used it as long as I could, but by openSUSE 11.4, the road started getting pretty rough in getting it to work. Its biggest issue I think was the move away from the xine sound server, but being a KDE3 app, the smallest issues seems to upset its operation. Today, in openSUSE 12.2, I installed it and it works, but audio function is intermittent to mostly no sound. My suggestion is to switch to VLC as that is what I did for movie watching, its supports Dolby Digital 5.1, alsa and pass through mode, among other things. And I use Totem for my online viewing and the two together cover all of my needs. I suggest you need to let go of KDE 3 and its once bright star Kaffeine of old. When its over, its really over. You can always confirm your multimedia setup using mmcheck: https://forums.opensuse.org/blogs/jdmcdaniel3/mmcheck-version-2-35-check-your-multimedia-16-steps-bash-script-file-36/

Thank You,

Tried that and got nothing. However I also foudn that VLC was doing the same thing and get_iPlayer would download files, but not convert to MP4. When I went back into YaST and looked at the Multimedia group I noticed that ffmpeg and some of the gstreamer plugins needed updating. Ran those updates and all is now well.


I know what you mean however there is now a helper to use gstreamer plugins with the kde3 version and they work really well, including being able to play YouTube. However I now use VLC for playing DVD and streaming stuff of my NAS, but have stuck with Kaffeine for pretty much everything else. I prefer the way it does playlists, and as someone who has been using computers since the 70’s I am used to using the keyboard short cuts so I prefer Kaffeine.

One of the things I find hardest with a number of KDE4 apps is that the shortcut support has got worse. I’ve even stopped using Dolphin because of that, and gone over to Krusader. A bit retro but it is not only a really good file manager, but works across my network and allows me to run backups to a NAS.

Thanks to you both for the prompt replies.:slight_smile: