Kaffeine: Can't play AVI, WMV, etc.

Help! Whenever I try to open an AVI or WMV with kaffeine, I get a xine error stating there’s “No plugin found to handle this resource”

I am using a fresh install of 11.1 with KDE 4.1 and I have followed the 10 step multimedia troubleshooting guide and everything seems OK to me (obviously I am missing something).

Here’s the output from the 10 steps:

1: Check if there are missing dependencies
LC_ALL=C zypper ve
Loading repository data…
Reading installed packages…
Dependencies of all installed packages are satisfied.

2: Check which packages are from VideoLAN repository
rpm -qa --queryformat '%{NAME} → %{VENDOR}
’ | grep -i VideoLAN
libdvdcss → VideoLAN Project (VideoLAN - Free and Open Source software and video streaming solutions for every OS!)

3: Check Basic MultiMedia packages
rpm --verify --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’

4: Verify xine is installed from Packman
rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ libxine1 libxine1-codecs
libxine1-1.1.15-44.pm.2-i686 → packman.links2linux.de
libxine1-codecs-1.1.15-44.pm.2-i686 → packman.links2linux.de

5: Check xine packages
rpm --verify --query --all ‘xine

6: Verify gstreamer plugins (codecs) installed and from Packman
rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly
gstreamer-0_10-ffmpeg-0.10.6-42.pm.1-i586 → packman.links2linux.de
gstreamer-0_10-fluendo-mp3-0.10.7-42.pm.2-i586 → packman.links2linux.de
gstreamer-0_10-fluendo-mpegdemux-0.10.15-42.pm.1-i586 → packman.links2linux.de
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1-i586 → packman.links2linux.de
gstreamer-0_10-plugins-bad-0.10.8-42.pm.2-i586 → packman.links2linux.de
gstreamer-0_10-plugins-base-0.10.21-42.pm.1-i586 → packman.links2linux.de
gstreamer-0_10-plugins-good-0.10.10-42.pm.3-i586 → packman.links2linux.de
gstreamer-0_10-plugins-good-extra-0.10.10-42.pm.3-i586 → packman.links2linux.de
gstreamer-0_10-plugins-ugly-0.10.10-42.pm.2-i586 → packman.links2linux.de

7: Check gstreamer packages
rpm --verify --query --all ‘gst

8: Check Mplayer package
rpm --verify MPlayer

9: Check VLC package
rpm --verify --query --all ‘vlc

10: Check w32codec package
rpm --verify w32codec-all

Extra info:
rpm --query --all --queryformat '%{NAME} → %{VENDOR}
’ ‘libav*’ ‘libpostproc*’ ‘libswscale*’ ‘xine’ ‘gst’ ‘layer’ ‘vlc’ ‘kaffeine’ | grep -v avahi| sort
MPlayer → packman.links2linux.de
amarok-xine → packman.links2linux.de
flash-player → openSUSE
gstreamer-0_10 → packman.links2linux.de
gstreamer-0_10-ffmpeg → packman.links2linux.de
gstreamer-0_10-fluendo-mp3 → packman.links2linux.de
gstreamer-0_10-fluendo-mpegdemux → packman.links2linux.de
gstreamer-0_10-fluendo-mpegmux → packman.links2linux.de
gstreamer-0_10-plugins-bad → packman.links2linux.de
gstreamer-0_10-plugins-bad-lang → packman.links2linux.de
gstreamer-0_10-plugins-base → packman.links2linux.de
gstreamer-0_10-plugins-good → packman.links2linux.de
gstreamer-0_10-plugins-good-extra → packman.links2linux.de
gstreamer-0_10-plugins-ugly → packman.links2linux.de
gstreamer-0_10-plugins-ugly-lang → packman.links2linux.de
gstreamer-0_10-schroedinger → packman.links2linux.de
gstreamer-0_10-utils → packman.links2linux.de
gstreamer-utils → packman.links2linux.de
kaffeine → packman.links2linux.de
libavc1394-0 → openSUSE
libavcodec52 → packman.links2linux.de
libavdevice52 → packman.links2linux.de
libavformat52 → packman.links2linux.de
libavutil49 → packman.links2linux.de
libgstapp-0_10-0 → packman.links2linux.de
libgstinterfaces-0_10-0 → packman.links2linux.de
libgstreamer-0_10-0 → packman.links2linux.de
libpostproc51 → packman.links2linux.de
libswscale0 → packman.links2linux.de
libxine1 → packman.links2linux.de
libxine1-codecs → packman.links2linux.de
libxine1-gnome-vfs → packman.links2linux.de
libxine1-pulse → packman.links2linux.de
libxvidcore4 → packman.links2linux.de
phonon-backend-gstreamer-0_10 → openSUSE
phonon-backend-xine → openSUSE
pullin-flash-player → openSUSE
smplayer → packman.links2linux.de
xinetd → openSUSE
xvidcore → packman.links2linux.de

Thanks in advance.

PS: Oddly, I can play DVDs in kaffeine just fine.

look for

And check this
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Great messy it seems around there :slight_smile:

you only need xine packages from Packman repo or see last post from caf4926.

OK, I went through that post (which was also my starting point in coming to this issue) and ensured libffmpeg0 was is installed from Packman. I am not sure why it was missing but still no luck with kaffeine.

I should have mentioned that while I can’t play video files through kaffeine, I can play them just fine directly through xine which doesn’t make sense to me,

Hy there

Damend, many thanks for your clear instructions! I use OpenSUSE 11.1 on a dualbootsystem with Windows XP, and the last three days I had serious problems with my video and DVD-collection: Kaffeine gave a scrambled image.
I tried everything: deinstall packages, install packages, install different codecs, … you name it, I did it. Now I found your explanations on the forum, and I just finished the 10-step-control. EVERYTHING WORKS AGAIN, thank you man, you made my day!!:slight_smile:
To everybody: if you are using OpenSUSE 11.1, and use Kaffeine to play videos and DVD’s, then this is the way to check all settings and packages when you have playback problems like I did.
Again, Damend, thanks for your work, and I hope I will be able to contribute to the forum some time in the future - I am new to OpenSUSE…

Make certain you have the version of kaffeine packaged by packman, and not the version packaged by Novell/SuSE-GmbH. Also ensure you have selected the xine engine in kaffeine, and not the gstreamer engine.

Thanks but I can’t take this credit. It belongs to caf4926.

Yast shows kaffeine is 0.8.7-2.pm.2-i686 from Packman and I verified that it is configured to use kaffeine-xine (I don’t have kaffeine-gstreamer installed).

Since I don’t have a lot invested in this installation, I am considering re-installing openSUSE 11.1 and then triying the one-click option from Multimedia - openSUSE-Community. Would it be a fair expectation that this would resolve my issue with Kaffeine?

Not really. Didn’t you already say you were able to play in xine?!

What happens with VLC? smplayer? (the packman versions of course)

Oops, wrong person…
caf4926, thanks for the good job. :slight_smile: Actually, I still had a little problem after walking the ten steps: In root I could watch videos, but in normal user login I could not. I resolved this through user management, and giving me - the normal user - some extra rights: audio, video, users. After that, all is back to normal. I don’t know if this is related to my problem - as I said, I am new to OpenSUSE - but it did the trick.
Again, many thanks.

xine, smplayer, & vlc all seem to work fine. Only kaffeine is at issue.

In my case simply adding users to group ‘disk’ and group ‘cdrom’ fixed the issue I think you had.

Try switching the output video mode of kaffeine player from “auto” or from “xv” (xvideo) to “x11”

How about giving us the output of the following to check your rpm versions:

rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' '*layer*' '*kaffeine*' '*ffmpeg*' '*vlc*' | grep -v avahi | sort

If your rpms are the correct versions, then rather re-installing Linux, IMHO a superior approach is to remove kaffeine. Then rename the directory:




and then re-install kaffeine from packman. (where “your-user-name” is your regular user name). [the above is for kde3].

For kde4 if there is no kd3 directory, then check here for a similar kaffeine directory:


I have not run kaffeine under kde4, so I do not know where kde4 stores the kaffeine directory.

Deleting /home/your-user-name/.kde/share/apps/kaffeine, un-installing kaffeine, and then re-installing it resolved this issue.