k9copy not correctly copying DVDs

This is my first time using k9copy, and I’m sure it is due to something I did or didn’t do, but k9copy is not correctly copying the DVDs. Every time I tell it to copy a DVD I notice at the bottom of the window it has settings for Mpeg-4, why list options for MPEG_4 when just copying a video from DVD to a DVD? When it finishes burning the copy it plays fine in a computer but when I try to play it in a DVD player I get an error about how it is not in the correct format. I have tried with two different versions
Version: 1.2.3-0.pm.1
Version: 2.0.2-0.pm.1

Both did the same thing.

At least on mine as well, the MPEG-4 encoding options is always there, whether I am ripping to xvid or copying to DVD.

The first thing I can think of is that you are clicking on the MPG4 button instead of the DVD one.

Are you selecting the whole disc to copy, or just the audio and video title for the movie? ie, you are not copying any of the extra features or menus? If so, I had some problems doing that until I selected “use dvdAuthor for copy without menus” in the configuration for DVD. You can select this by clicking on the configure k9copy button and then the DVD button. There will be a checkbox for this option. I don’t think it is set by default, but I remember having problems until I checked it, or unchecked it. Actually, now that I think about it, I can’t remember which way I had to change it, I only do the full disc since I think the quality difference is negligible and it seems to work so much better.

Anyways, make sure you are selecting the DVD copy button, not the MPG4 button, try checking/unchecking the dvdAuthor option, or try copying the entire disc rather than just the movie.

Well I guess its good to know the MPEG-4 encode options are always there. Yes I’m sure that I was clicking copy DVD instead of encode to MPEG-4/Extract MPEG2 button. I was trying to rip the whole DVD, but I was ripping it with all the menus and things. I can try and rip one with out the menus once I get to my machine that has k9copy installed.

Have you tried it in different DVD players? I know that I have at least one in my house that says it will not work with any burned discs (of any sort), but I have noticed it will work with DVD-R’s, but not DVD+R’s. Some DVD players are not able to work with all disc media. Have you used these discs before with a different program?

Another thing to try, although it is a bit slower, is to copy the DVD to an ISO image first, then burn it using k3b. Maybe even on a slower speed. Just choose “Output Device” to be an ISO image, and then after it is done, use k3b to burn it. Try it on a slower speed as well, as it may be having errors burning it, but computers are sometimes better at doing the error correction at runtime than a standalone DVD player.

I have multiple DVD players in my house and all of them are able to read movies burned onto DVD-R disks, which is what I am using I can never find DVD+R anywhere here in town.

I have also already tried saving to DVD to an ISO and burning it with K3B same result, the DVD is playable in a computer but not in a DVD player. I have unchecked the option to have DVDauthor keep the original menus and I am trying it again.

I figured, but thought we should check the obvious first.

So, are you saying that it only happens with k9copy, but other programs using the same discs are fine?

What size were the iso images? Were they the full 4.3 GB of a single layer DVD?

What options do you have on the configuration page for DVD? I have the following unchecked
Burn with k3b
Auto burn

and the following checked
use dvdauthor for copy without menus
and clear output directory on exit

Other than that, I sort of lost on what else to do. You could try removing the configuration files for k9copy from ~/.kde/share/config/k9copyrc and ~/.kde/share/config/K9Copy. Yours may be in .kde4 instead of .kde. Which brings me to another idea, I think the 2.0.2 version is a kde4 version, so I assume you are using kde4, you can try switching to a kde3 or even gnome session and see if anything is different there.

Hopefully we can work this out, because in my opinion k9copy works way easier than any of the other ones I tried. Although I have never tried any of the Windows ones like DVD Shrink. By the way, I have read that DVD Shrink will work under wine, but I have never tried it.

Yea I use to use xDVDShrink with openSUSE 10.2, and 10.3 and with DVD-R’s it successfully ripped the dvd. The iso’s were 4.3 GB which is correct for a single layer DVD.

I have the following options unchecked:
Burn with K3B
Auto Burn
use dvdAuther to burn without menus (this was checked before)

I have the following options checked:
Quick Scan
one file/chapter (MPEG extraction)
Clear output directory on exit

K9copy 2.0.2 is a KDE4 version, but I also have the KDE3 version installed and it does the same thing. I’m not sure if switching to a kde3 session will make a difference but if the above settings doesn’t work I will try anything.

I know that on my laptop I have problems with either version running under kde4 with ripping to xvid. It will just sort of randomly skip a bunch and then never actually complete it. I haven’t had a chance to figure out exactly why yet, but I know that running the kde3 version actually under kde3, I do not have that problem.

So, it might be worthwhile to try it under kde3 and see if that works. If it doesn’t, then I am sort of out of ideas.

As far as my problem, I was just going to sort of let it go until kde4.1 comes out of beta and I upgrade to it (I’m still using 4.0.4), and if I still have trouble with it, then I will file a bug report. I think it might be a problem with the new media settings in kde4, but like I said, I haven’t confirmed the cause yet.

I have had issues with k9copy in the past, from not copying dvds at all and leaving with coasters, unplayable discs and crashes. I have three ways that solve these problems 1.) Totally remove k9copy and try a later version. 2.) If you have dual boot set up, try using windows and using dvddecrypter and Dvdshrink. 3.) try a different brand of media. I used memorex dvd-r’s for a longtime and then bought some new ones when I ran out. Even though the brand and format were exactly the same, the discs didn’t work. In my expereince k9copy is kind of finnicky. You just have play with it to make it work.

  1. I have k9copy 2.0.2 installed which is the latest version installed, I also tried with version 1.2.3 same problem.
  2. I do not have windows installed, and I tried DVDshrink and could not get it to work correctly under wine
  3. I am using Memorex DVD-Rs, they always seem to give me less trouble and they are cheap.

After testing a ripped DVD and using a different DVD player, this one is newer, I think I found an important missing peace of this puzzle. The reason why the ripped DVDs will work in computers but not in normal DVD players is because they seem to but burnt, or the ISO is made, as a data DVD. Computers can read the data DVD and see that there is a movie on it and play the movie from the DVD just fine, but this is not what home DVD players are expecting which makes them give the error of “Unsupported Disk” or just “Error”. What made me come to this conclusion is that they newer DVD player I tried is designed to work with Divx movies and MP3 disks, and it has a file browser in it. When I put that ripped DVD in it, it gave me a “Unsupported Disk” error and then the file browser came up, I was able to see that it had the correct directories on it, VIDEO_TS and AUDIO_TS but the VIDEO_TS directory seemed empty.

This makes me wonder if K9copy is making a bad ISO, or if K3B is just burning it as a data DVD. As a temporary work around I am reripping a DVD, this time dumping everything streight to a directory instead of making an ISO and I am going to tell K3B to burn it as a video DVD by hand. I shall post my results here once I know if this will work or not.

After testing my idea, not using an ISO just dump the files to the AUDIO_TS and VIDEO_TS directories and telling K3B to burn it as a video DVD, as well as unchecking the option to have K9copy remove the original menus results in a mostly playable DVD. There is some glitches during playback mostly random green boxes, and video pause with audio loss for a second, this may be due to the compression I am testing this with a different movie.

vendion wrote:

> After testing my idea, not using an ISO just dump the files to the
> AUDIO_TS and VIDEO_TS directories and telling K3B to burn it as a video
> DVD, as well as unchecking the option to have K9copy remove the original
> menus results in a mostly playable DVD. There is some glitches during
> playback mostly random green boxes, and video pause with audio loss for
> a second, this may be due to the compression I am testing this with a
> different movie.

I used k9copy and k3b to copy to iso and then burn a dvd yesterday. Worked
well, both in handheld player and my dvd player attached to tv.

A thought struck me though… do you have the libdvdcss library installed? I
checked my system, it’s installed here. I didn’t use any custom settings on
k9copy or k3b, both are stock installs, nothing changed from default.


L R Nix

Yes I do have libdvdcss installed on both my systems, and I can live with not making an ISO. What really matters is that it is working now, I don’t care if I have added more steps to do it. Thanks to everyone for the help.