k8t800 chipset, marvell 88e8001 network adapter problem on 64-bit opensuse 13.1 KDE

Ok, guys… I have been using opensuse 13.1 on my laptop for several months and the only comment I have for it is that I enjoy every second of it. Majestic piece of software. Anyways, I have also an older PC, so recently, I figured that I could install it also there, but I have encountered some difficulties along the road. Namely, the Ethernet via-velocity driver does not work at all, and without network connection… :).

The PC is an old AMD 939 single core 64 bit, with one gigs of RAM and a K8T800 VIA chipset and a marvell 88E8001 network adapter… So my question is, is there another driver or some kind of solution, or am I stuck in the mud with my oldtimer…

Regards

p.s Maybe I should install 32 bit opensuse?

I use an ASUS A8V deluxe board here with apparently the same chipset. (VIA K8T800Pro chipset, Marvell 88E8001 ethernet controller)
Ethernet is working fine here with 13.1 and always has with earlier versions.
lspci tells me I’m using the “skge” driver.

Could you please post the output of:

/sbin/lspci -nnk|grep Marvell -A2

p.s Maybe I should install 32 bit opensuse?

Shouldn’t have any influence regarding your network adapter problem.
1 GiB RAM might be a bit on the low side for a 64bit system (64bit applications usually need a bit more RAM than their 32bit equivalents), although until 12.1 I only had 1 GiB as well and it ran fine.

It would be best to expand the RAM a bit in any case though, I’d say… :wink:

On 06/09/2014 12:46 PM, elots wrote:
>
> Ok, guys… I have been using opensuse 13.1 on my laptop for several
> months and the only comment I have for it is that I enjoy every second
> of it. Majestic piece of software. Anyways, I have also an older PC, so
> recently, I figured that I could install it also there, but I have
> encountered some difficulties along the road. Namely, the Ethernet
> via-velocity driver does not work at all, and without network
> connection… :).
>
> The PC is an old AMD 939 single core 64 bit, with one gigs of RAM and a
> K8T800 VIA chipset and a marvell 88E8001 network adapter… So my
> question is, is there another driver or some kind of solution, or am I
> stuck in the mud with my oldtimer…
>
> Regards
>
> p.s Maybe I should install 32 bit opensuse?

The trade-offs are that 64-bit code, particularly kernels, get a lot more
testing than does the 32-bit varieties, but 32-bit applications are somewhat
smaller, which may be important with your 1 GB RAM. That is especially true if
your disk is small. If you had more than 4 GB RAM, then 64-bit would be better.

A Google search reveals a number of inquiries regarding Linux drivers for the
88E8001, but those all come from 2004. A search of the kernel code shows that
this device is handled by driver skge. To confirm, please supply the appropriate
line for this device from the output of ‘/sbin/lspci -nn’.

What devices are shown in the output of ‘/sbin/ifconfig’?

A Google search reveals a number of inquiries regarding Linux drivers for the
88E8001, but those all come from 2004.A search of the kernel code shows that
this device is handled by driver skge. To confirm, please supply the appropriate
line for this device from the output of ‘/sbin/lspci -nn’.

Line Output of "/sbin/lspci -nn"

00:07.0 Ethernet controller [0200]: VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet Adapter [1106:3119] (rev 11)

What devices are shown in the output of ‘/sbin/ifconfig’?

**Output of ‘/sbin/ifconfig’: **

enp0s7 Link encap:Ethernet HWaddr 00:69:00:0B:05:7F
[INDENT=2]inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::269:ff:fe0b:57f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:53 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4404 (4.3 Kb) TX bytes:10940 (10.6 Kb)
Interrupt:17

[/INDENT]
lo Link encap:Local Loopback
[INDENT=2] inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:86 errors:0 dropped:0 overruns:0 frame:0
TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4780 (4.6 Kb) TX bytes:4780 (4.6 Kb)
[/INDENT]

You are correct, and I already mentioned it… It’s an “oldtimer”, from 2005, but still useful for multimedia and browsing the net… And of course, I did my share of research on the but found nothing useful, hence the reason I post to you guys. Thank you both for the fast reply :slight_smile:

I forgot this one, the last and most important:) The driver is via_velocity**
Line Output of “/sbin/lspci -nnk**”
00:07.0 Ethernet controller [0200]: VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet Adapter [1106:3119] (rev 11)
Subsystem: VIA Technologies, Inc. Device [1106:0110]
Kernel driver in use: via-velocity
Kernel modules: via_velocity

But that’s no Marvell 88e8001 adapter, or is it? :wink:
See mine for comparison:

wolfi@amiga:~> /sbin/lspci -nnk|grep Marvell -A2
00:0a.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller [11ab:4320] (rev 13)
        Subsystem: ASUSTeK Computer Inc. Marvell 88E8001 Gigabit Ethernet Controller (Asus) [1043:811a]
        Kernel driver in use: skge
        Kernel modules: skge

Apparently the driver is working, you even have an IP address assigned.

Could you try to explain your problem in more details please?
What makes you think the driver is not working?

First, can you reach a server by IP address?
Try:

ping 8.8.8.8

A side-note: for computer output please use

 tags. (the '#' button in the forum editor's toolbar)

On 06/09/2014 04:46 PM, elots wrote:
>
> I forgot this one, the last and most important:) The driver is
> via_velocity*
> Line Output of “-/sbin/lspci -nnk-*”
> 00:07.0 Ethernet controller [0200]: VIA Technologies, Inc.
> VT6120/VT6121/VT6122 Gigabit Ethernet Adapter [1106:3119] (rev 11)
>
> Subsystem: VIA Technologies, Inc. Device [1106:0110]
>
> Kernel driver in use: via-velocity
>
> Kernel modules: via_velocity

This interface has absolutely nothing to do with a Marvell 88E8001. Are you
trying to mislead us?

According to ifconfig, you have an IP and should have connectivity.

LOls :smiley: Ooops… I think I may have made a LITTLE mistake, but hey I am new to this and light years from being expert… :smiley: Ok, It’s not Marvel, but trust me the problem is real… So here is the case: I have dual boot win Xp and opensuse… Under xp it works and has been working just fine for the past nine years. Under opensuse I do get the addresses allocation, but I cannot access the net… Further more when I try to make any net operation the system goes into panic, it freezes… So I figured it is a driver problem… It freezes even when trying to change the net configuration through the network manager control module… That’s why I asked if it is 32bit vs 64 bit related problem?

Basic example:
https://pp.vk.me/c618223/v618223789/9e62/p69bhG-1SAk.jpg

The ping result:
https://pp.vk.me/c618223/v618223789/9e6b/r_SaUAK5fmA.jpg

Well, this sounds a bit like:
https://bugzilla.redhat.com/show_bug.cgi?id=1022733

Apparently this got fixed in November, so the fix should not be part of the kernel shipped in openSUSE 13.1 yet.
There is an updated kernel in the update repo though, which you could try, or if that doesn’t work you could try with the latest kernel version.

But first, the kernel panic in your screenshot says “drm_kms_helper”, which is related to the graphics driver. So maybe your system hangs/freezes because of problems with this and not at all related to the network? Although I would find it strange that this happens when running ping in a terminal…
What graphics card/chipset do you have?

Please try booting to “Recovery Mode” (you find that in “Advanced Options” in the boot menu) and report back.
If it doesn’t help, I’ll tell you how you could install a newer kernel.

Well, this sounds like:
https://bugzilla.redhat.com/show_bug.cgi?id=1022733

Apparently this got fixed in November, so the fix should not be part of the kernel shipped in openSUSE 13.1 yet.
There is an updated kernel in the update repo though, which you could try, or if that doesn’t work you could try with the latest kernel version.

But first, your screenshot says “drm_kms_helper”, which is related to the graphics driver. So maybe your system hangs/freezes because of problems with this and not at all related to the network? What graphics card/chipset do you have?
Try booting to “Recovery Mode” (you find that in “Advanced Options” in the boot menu).

Please try that and report back. If it doesn’t help, I’ll tell you how you could install a newer kernel.

Not quite like that…The system does not freeze on login. But you are right, in reality I did have a graphics problem after the install (it’s a fresh install from two days ago), but somehow it got it self fixed (i don’t know how or why) after I entered the advanced mode on the boot screen… The graphic card is NVIDIA 7300 GT…

Ok, it is late here (00:45) but I will write you tomorrow in the late afternoon, after work.

Stay well people! Thank you and good night…

Right, but the exact point where it freezes might vary from system to system I suppose.
And you’re using the same kernel, and the backtrace from your screenshot does contain references to the network driver.

OTOH, I would expect the hang/crash occur earlier during boot if it’s caused by the network driver, as the network is accessed there already. But in your case the system is even able to fetch a network address from the router (I don’t think you set up a static address, did you?).

But you are right, in reality I did have a graphics problem after the install (it’s a fresh install from two days ago), but somehow it got it self fixed (i don’t know how or why) after I entered the advanced mode on the boot screen… The graphic card is NVIDIA 7300 GT…

Well, IIRC I have read of people having problems with that particular card and the shipped nouveau driver.
You might want to install the proprietary nvidia driver instead, but let’s first get your network working.

Ok, it is late here (00:45) but I will write you tomorrow in the late afternoon, after work.

Ok. You are in the same time zone as I am… :wink:

@**wolfi323 **

But first, your screenshot says “drm_kms_helper”, which is related to the graphics driver. So maybe your system hangs/freezes because of problems with this and not at all related to the network? What graphics card/chipset do you have?
Try booting to “Recovery Mode” (you find that in “Advanced Options” in the boot menu).

Ok, I tried the advanced mode again, and from the resolution (640x480) I presume that the graphics driver is off, but nothing changes for the better… Although the system again assigns address from the router, I can’t access the Internet, and it again crashes on my first attempt to do something regarding the NET (ex: ping)…

I assume now we can try something you mentioned yesterday… :slight_smile:

Ok, so let’s try first the updated kernel from the 13.1 updates repo:
http://download.opensuse.org/update/13.1/x86_64/kernel-desktop-3.11.10-11.1.x86_64.rpm

Download this kernel on your other system and copy it to an USB stick or similar, then install it on this system by just opening it in a file manager.
After a reboot, please check that “uname -a” shows you are using kernel-desktop 3.11.10 (not 3.11.6).
Then check if the ping works or still crashes.

If it still crashes, try this kernel as well: (3.14.4)
http://download.opensuse.org/repositories/Kernel:/stable/standard/x86_64/kernel-desktop-3.14.4-2.1.g0de0f93.x86_64.rpm

If you still have questions regarding the installation, just ask.

If it still crashes, try this kernel as well: (3.14.4)

The first one freezes, but this one works :slight_smile: I have a ping response to 8.8.8.8, but I can’t still access the net via Browser and regular http domain…

Well, at least some progress then… :wink:

Now this sounds rather like a configuration issue, with DNS in particular.
I suppose “ping google.com” won’t work either then, right?

Please enter YaST->Network Devices->Network Settings, select your network card (should be selected already anyway), click on “Edit” and verify that “Dynamic Address” is selected and it is set to “DHCP” and “DHCP version 4 only” (or “DHCP both versions 4 and 6”).

And also run “nslookup google.com” and post the output.

Now this sounds rather like a configuration issue, with DNS in particular.
I suppose “ping google.com” won’t work either then, right?

Indeed it doesn’t :)… And hopefully it is just netconfig problem.

Please enter YaST->Network Devices->Network Settings, select your network card (should be selected already anyway), click on “Edit” and verify that “Dynamic Address” is selected and it is set to “DHCP” and “DHCP version 4 only” (or “DHCP both versions 4 and 6”).

It was set to network manager… I changed it to traditional with ifup… Dynamic Address set to “DHCP” and “DHCP version 4 only”

“ping google.com” still returns negative and “nslookup google.com” - connection timeout…

Note: I possess a wireless network USB adapter… I have put it on my laptop just to check if it works (which it did) and then downloaded the same wireless driver and installed it on the troubled PC… And strangely, although I can connect with it on my HOME network, the simptoms stay the same… No access to the internet just like with the Ethernet adapter…

Well, if the ping via IP address works this seems to be the case.

It was set to network manager… I changed it to traditional with ifup… Dynamic Address set to “DHCP” and “DHCP version 4 only”

Actually both should work.

“ping google.com” still returns negative and “nslookup google.com” - connection timeout…

Didn’t you get more output? It should at least tell which DNS server it is trying to reach I think.

I’d suggest you try to remove the file /etc/resolv.conf and reboot. This file contains the DNS-server, it should get dynamically re-created correctly, but this might not work under certain circumstances if it already exists and is corrupted.

sudo rm /etc/resolv.conf

If that doesn’t help either, try to set 8.8.8.8 as DNS-Server (that’s google’s public DNS-Server) in YaST->Network Devices->Network Settings->Hostname/DNS.

Man, awesome is the word for you LoLs… And Brilliant! The last suggestion did the trick, and although the deleted file “resolv.conf” did not auto generate itself on reboot, I did a copy of the same file from the laptop, copied it to the etc folder and now … THE CON is ON :)…

Ok, I think I have bothered you enough for this night… This leaves only the graphics card driver “nouveau” problem to be resolved, but that would better be left for tomorrow… in a new thread :smiley:

In the end (sadly), all I can say is:
One HUGE “Thank you” for your stubborn support for these two days :D…

And good night

Hm, not sure now why this wasn’t re-created, it should have been AFAIK. Maybe you don’t have to set the interface to start on boot or something like that?
You could have tried to create it manually with netconfig.

But copying it from the other system was a good idea as well anyway.

Ok, I think I have bothered you enough for this night… This leaves only the graphics card driver “nouveau” problem to be resolved, but that would better be left for tomorrow… in a new thread :smiley:

Ok, let’s tackle this tomorrow.

And install all updates first, as the network is now working.
Maybe the nouveau driver will even work better then than it does now.

In the end (sadly), all I can say is:
One HUGE “Thank you” for your stubborn support for these two days :D…

You’re welcome.
I’m glad we got it to work! :slight_smile:

And good night

To you as well.