k3b refuses to burn dvd iso image!

I have a problem with burning dvd iso image.
I am running k3b as a root (~> kdesu k3b) and trying to burn the dvd iso image but it fails immediatly after attempt to write, here is the debug:

K3b Version: 1.0.5

Executing ‘builtin_dd if=/dev/fd/0 of=/dev/sr0 obs=32k seek=0’
/dev/sr0: “Current Write Speed” is 2.5x1352KBps.
:- WRITE@LBA=0h failed with SK=5h/WRITE PROTECTED]: Input/output error
:frowning: write failed: Input/output error

What is the reason and how to fix it?

Why run it as root not recommended or needed.
Try again as a normal user.
Also what is the iso are you sure it is ok


The iso is the downloaded SUSE 11.1 installation dvd, I have cheked the md5 summs and everything looks fine.
If I am running k3b as a user, it does not see the cd/dvd drive - it is a separate problem that I think is not related to the burning of dvd.

There was ( is still ?? ) a bug in 11.1 that may or may not have been fixed. That bug is related to permissions on CD/DVD drives. Are you using 11.1 to try burn an 11.1 iso ? [ie burn for someone else or for a backup copy].

If so, then try adding your users to group “cdrom” and group “disk” and then restart your PC and try again.

This can be done by:

YAST >> Security and Users >> User Management >> “select your user” >> Edit >> Details >> Groups >> check “cdrom” and “disk” and then click on “ACCEPT”. Don’t forget after exiting YaST, you need to restart.

If that does not work, there are more suggestions here to work around this temporary problem: Solved : K3b Problem with Normal User on openSUSE 11.1 | Spirit of Change

Drive-by comment:

@oldcpu I suspect that bug has a released fix: I tracked it through the bugzilla and somewhere in there I saw reference to a released fix for it. So in Yast Online Update I tracked down a patch titled “Hal: collective bugfix update” which has a reference to the bug number. It seems to me that s0x80 should run that patch. More in the posts numbered #15 and #16 here: no device cdrom - Page 2 - openSUSE Forums.

But I’m not a multimedia guy, so could you please comment for OP as to whether that is a fix for this problem.

Dear oldcpu,

Thank you for the very clear explanation, I have added “users” to the group “cdrom” and group “disk” - this fixed the problem with access of k3b to the cd/dvd drive so now when I run k3b as a user it can see the empty dvd.
But originally I had asked a little bit another question and I still have this problem: I am trying to burn dvd but it fails to burn whith the next debug:

K3b Version: 1.0.5
SONY DVD±RW DW-D56A PDS3 (/dev/sr0, ) …
Burned media DVD+R
Used versions growisofs: 7.1

Executing ‘builtin_dd if=/dev/fd/0 of=/dev/sr0 obs=32k seek=0’
/dev/sr0: “Current Write Speed” is 2.5x1352KBps.
:- WRITE@LBA=0h failed with SK=5h/WRITE PROTECTED]: Input/output error
:frowning: write failed: Input/output error

How to fix it?

Dear swerdna,
I did not understand what fixes doing those updates and how are they related to the failure of dvd burning? Could you please explain it to me?

According to this article (in russian)
òÁÂÏÔÁ Ó CD/DVD : úÁÐÉÓÁÔØ, ÐÒÏÞÉÔÁÔØ, ÓÔÅÒÅÔØ, ÄÏÐÉÓÁÔØ ÐÏÄ FreeBSD CD, DVD, boot, bootable, GRUB, eltorito : íÉÞÕÒÉÎ áÌÅËÓÅÊ](http://www.michurin.com.ru/dvd.shtml)

and to this error codes of dvd-drive:

I tried to run the burning from command line (changed the speed from 2.4 to 2):
growisofs -dvd-compat -speed=2 -Z /dev/dvd=/home/**/openSUSE-11.1-DVD-i586.iso

the result is the same:
Executing ‘builtin_dd if=/home/yaroslav/soft/openSUSE-11.1-DVD-i586.iso of=/dev/dvd obs=32k seek=0’
/dev/dvd: “Current Write Speed” is 2.5x1352KBps.
:- WRITE@LBA=0h failed with SK=5h/WRITE PROTECTED]: Input/output error
:frowning: write failed: Input/output error

So what does it mean SK=5h/WRITE PROTECTED and how to fix it???

There is a bug in 11.1 that prevents burning by ordinary users. There have been a few workarounds used while the developers have worked on fixing the bug. The developers have finished fixing the bug. Here is how to apply the fix:

GoTo Yast → Software → Online Update. A GUI appears. On the left is a drop-down box titled “Filter”; set that to “Patches”. Underneath that, still on the left side, is another drop-down box titled “Show Patch Category”; Set that to “All Patches”. Now still in the left side, top section, scroll down until you find the patch called “Hal: collective bugfix update”. Use you mouse to highlight it. That will cause to appear on the right hand side the RPM called “Hal daemon for collecting hardware information”. Make sure there is a tick in the left on “Hal: collective bugfix update” and in the right on “Hal daemon for collecting hardware information”. Install the patch.

Try burning now. If it doesn’t work, reboot and try again.

If the burning problem doesn’t go away, then your problem was not the result of the famous bug, but at least you will have eliminated that possibility.


I have updated the system (including the patch you mentioned), but no result.
I also have to say that as I mentioned above the root privileges do not give any effect too, so I am really lost what it can be?

Anyway thanks for the attempt to help.

OK I googled this: builtin_dd if=/dev/fd/0 of=/dev/sr0 obs=32k seek=0

And one response said:
My sugestion to anyone that runs in to the error is to-

  1. Try new media
  2. Clean the lens (w/cleaning CD if possible)

Another said this:
This turned out to be a bad hardware or firmware. I’ve since upgraded to a LG 18x Super Multi DVD Rewriter (GSA-H62N) and limited testing indicates the new drive is functional.

i’m thinking it may be a hardware problem, …

if i burn it normally as i refer above why to go to get a new cable which i dont right now (i’ll have to wait till monday to buy one then)?

All suggest some hardware problem. What do you think about a possible DVD burner hardware problem?

Have you tried Brasero? its a gnome burner i use it with no problems at all and it seems to be a better program to use (my own opinion) I to had some minor issues with k3b but used Brasero and have no issues


Thanks, Brasero works perfect!