k3b - No CD/DVD writer found.

I down loaded openSUSE 11.1, burnt the downloaded file using k3b and then updated my SUSE 11 into SUSE 11.1
when I try k3b using the SUSE 11.1 I got the following message

No CD/DVD writer found.

I then downloaded the k3b again but still getting the same message

Help Advice is requested

It was already in so many threads :slight_smile:

You need to add Yourself to the disk group in YaST2 magament tool. After that logout and login back. You should be able to use your DVD writer again:)


this works
DVD & Audio CD cannot play in all multimedia apps. - openSUSE Forums

Well You didn’t really post something new as solution has already been given :slight_smile: I had the same problem and disk group solved it :slight_smile:

i know :wink: :wink: :wink:

Appreciate your quick answers.
Now here is the problem or question
How could I get to that disk group, I check the yast and do not see any disk group
Could you please be patient and guide me

YAST >> Security and Users >> User Management >> “select your user” >> Edit >> Details >> Groups >> check “cdrom” and “disk” and then click on “ACCEPT”. Don’t forget after exiting YaST, you need to restart.

just follow my link :wink:

Appreciate your patience and advice

STS301 schreef:

> check “cdrom” and “disk”

I just added myself to the cdrom group and haven’t had any problem since.
Can’t say if it’s a bad thing to add yourself to the disk group, but when it
comes to user permissions, less is better.

Chris Maaskant

Thanks…I thought that I had already done this earlier, as I had originally burned an ISO image for OpenSUSE 10.3 after using 10.2 and Mandriva Linux earlier, but I suppose that since the “problem” occured with my system also, right after I ran the 1 security update with the 3 optional recommended updates, that the 1 security update may have changed my User permissions to the CD/DVD-ROM drive, so I’m going to reboot now and see if it has corrected the problem for me.

Thanks again, that was something I hadn’t thought of, and maybe that security update had changed my “group” permission to the Disk and Drive that I ran yesterday after all.

Have a Great Day,

I know this is a little old, the thread that is, but this solution actually didn’t work for me, but what did work for me was to go to the YaST administrator settings and run the “Patch CD Update” under the “Software” heading or category…That worked fine for me, but I did try adding myself to the groups you suggested and had rebooted the computer, but I still had that “Updater” problem until I ran the CD Patch update.

So, I have this really, really dumb question:

Just why in holy heck doesn’t the ``No CD/DVD writer found.’’ error message include the tiniest little hint about how to fix the problem so that hapless neophytes do not have to search the web trying to figure out such a numbskull restriction? >:-( :wink: