K3b Fails to Burn ISO to DVD

I am trying to burn an iso image to DVD using K3b (Leap42.2 with KDE desktop) as I am sure I have in the past. This time I get an error message:-

On-the-fly writing with cdrecord <2.01a13 not supported

Never seen this before and all default settings in place which (I believe) have worked in the past.
On closer examination it seems I do not have cdrecord installed because it conflicts with crdkit-cdrtools-compat-1.1.11-22.28x86_64
I assume this comes from KDE team.
What am I doing wrong please?
Time to change to Gnome?

All default settings means that your drive/k3b has wrong permissions, though I doubt it’s the case here. Go Settings - Programs - Permissions .
Another thing: Is your k3b from Packman ?? And all related codecs?

Hi and thanks for the reply. Yes all from Packman using advice from this site.
Further research has shown that many error messages and dependency advice are misleading, eg stating that something is not installed when it is.
Bottom line however is that I had not put myself in cdrom group. Once I put myself there using yast all was well.

How can I mark this thread [Solved]?
Budge