k10temp + Phenom II (Deneb) OpenSuse 12.2 problem

Hi all,

OpenSuse 12.2(my favorite distro from many years), Phenom II X4 (Deneb), mainboard Gigabyte GA-890XA-UD3 (it87 working well)

cmruk@amonra:/usr> uname -a
Linux amonra 3.4.11-2.16-desktop #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux

my sensor output, i already try load k10temp force=1, not help.

Adapter: PCI adapter
temp1:         +0.0°C  (high = +70.0°C)
                       (crit = +79.0°C, hyst = +77.0°C)

I goggled a bit and find solution for Ubuntu


and same for Arch but it’s not working for me :frowning:

I ill glad to hear if any of You guy’s have working k10temp and how u get it to work :slight_smile:

Regards and Greetings from Poland,

Czeslaw M

Did you happen to try running sensors-detect?

Thx for reply,

Yes, i do ,
now from “/etc/sysconfig/lm_sensors.conf” load automatically “it87” and “k10temp” is autoload, its my full ‘sensors’ output

cmruk@amonra:~> sensors
Adapter: PCI adapter
temp1: +0.0°C (high = +70.0°C)
(crit = +79.0°C, hyst = +77.0°C)

Adapter: ISA adapter
Vcore: +2.16 V (min = +0.78 V, max = +2.0 V)
Vdram: +1.50 V (min = +1.42 V, max = +1.57 V)
+3.3V: +3.36 V (min = +3.14 V, max = +3.47 V)
+5V: +5.13 V (min = +4.76 V, max = +5.24 V)
+12V: +12.24 V (min = +11.41 V, max = +12.62 V)
5VSB: +5.05 V (min = +4.76 V, max = +5.24 V)
Vbat: +3.33 V
CPU Fan: 1603 RPM (min = 300 RPM)
Case Fan: 836 RPM (min = 200 RPM)
SYS Fan: 2789 RPM (min = 300 RPM)
SYSTemp: +34.0°C (low = +0.0°C, high = +60.0°C) sensor = thermistor
CPUCasT: +35.0°C (low = +0.0°C, high = +75.0°C) sensor = thermal diode
NBTemp: +38.0°C (low = +0.0°C, high = +75.0°C) sensor = thermistor
intrusion0: OK

I try already recompile k10temp module with some pathes found in internet but with not good results.

Well, seems k10temp have a bug or i have some broken CPU temperature sensor.

Any way i try keep looking over i-net to find more info about it.


Hi all

According to Devices – lm-sensors

Embedded sensors are known to be unreliable on the DR-BA, DR-B2, DR-B3, RB-C2 and HY-D0 revisions of the family 10h CPU, which will never be supported. Driver contributed by Clemens Ladisch, reviewed by Jean Delvare.

i have bad luck, seems i got CPU with broken thermal sensor :’(,

I wish You more luck with AMD CPU’s.



Hi all,

I discover in “Window” that i haven’t bugged k10 CPU :), below output from CPUz, and hi show to CPU temperature, so looks like module ‘k10temp’ is bugged, i try is it work in Ubuntu or Fdedora,
i will put result here for this of you who looking to make working ‘k10temp’ in 12.2

Processor 1 ID = 0
Number of cores 4 (max 4)
Number of threads 4 (max 4)
Name AMD Phenom II X4 965
Codename Deneb
Specification AMD Phenom™ II X4 965 Processor
Package Socket AM3 (938)
Extended CPUID 10.4
Brand ID 14
Core Stepping RB-C3

Hardware monitor AMD ADL
Voltage 0 1.00 Volts [0x3E8] (VIN0)
Temperature 0 40°C (104°F) [0x28] (TMPIN0)



These are support forums, not developper forums. IMHO you should file a bug report.

Sorry, for bringing this necro-post up. But where would I fill such an bug-report?

Because apparently this problem is still there as of today (2014). :frowning:



I had the similar problem.
I tried disabling CPU unlock in bios and it worked but don’t know how and why.
It may work for you.
So just a suggestion