(K)NetworkManager doesn't work properly

Hi everyone,

About a week ago I installed openSUSE 11.0. Really happy with it. The only thing I’m not happy about is the new NetworkManager version.

I’ve always used NetworkManager version 0.6.5 and KNetworkManager 0.2.
I believe I’m now using version 0.7.0 and 0.7.0.

I’m having problems connecting to wireless networks. It doesn’t see any networks half the time, and when it does, I sometimes have to try and try and try before it connects.

I’ve tried to downgrade to the versions I had, but several combinations gave several problems:
NetworkManager 0.6.5 and KNetworkManager 0.2: KNetworkManager tells me NetworkManager isn’t running, and I can’t get it running.
NetworkManager 0.7.0 and KNetworkManager 0.2: KNetworkManager tells me that there are no network devices.

My questions:

  • Is this a NetworkManager problem or a KNetworkManager problem?
  • Why can’t KNetworkManager 0.2 find any network devices?
  • What can I do!

I have exactly the same problem.
i wonder which is resolution?
disable ipv6 or not?
Change the version of knetworkmanager or not …???

i feel you pain!

see my post as well, its called: networkmanager sucks!

network manager sucks. - openSUSE Forums

i would like to see a new / better / stable / secure / un-buggy piece of software.

as for your problem, go to yast as do it manually. at least its stable this way. also add the packman repository and seatch for “wireless”. you should find a few tools that runs in the tray showing u your signal strenth.

hope this helps (and that the hang who-ever was responsible networkmanager)


do an online update with ipv6 disabled.


I don’t think network-manager is causing your network problems, it is simply a GUI frontend.

I had a similar problem using ndiswrapper under 10.3, sometimes the driver just refused to load on boot. Version 11 fixed that problem for my Broadcom 4312v2 and now I use the “fwcutter” driver instead of ndiswrapper.

My wireless now works perfectly on every boot :).

You would be better off checking your wireless driver especially if you are using ndiswrapper, or even your wireless router as it might be giving a problem.

You don’t have to use it either, you can switch to the traditional “ifup” method through Yast2 network. Or try another one as already suggested.

And suggesting hanging a person for doing unpaid work to give you a free piece of software seems a little unbalanced!

opensuse get about 95% for their effort. best opensuse so far!

but why, for the love of all that holy, put in a buggy networkmanager?

after an update, it gets patched with a more stable version and it fixes the icon size for wireless, but it is still the worst piece of software in there.

i dont like the new networkmanager! it sucks. why do we have to “create a connection”? What a useless time-consuming feature.

we want: right-click and see a list of wireless networks. pick one, type the wlan key and connect.

who-ever were responsible for knetworkmanager should be fired.


please give us a SIMPLE, STABLE and EASY-TO-USE alternative.

As much as i love opensuse, i WONT RECOMMEND it. The connection to the lan / wlan is vital, and now this is the weakest point.

Like having a super-athlete with a weak heart.



i also use ndiswrapper, its not the problem. i use networkmanager on pc with intel (drivers inclueded in opensuse) and have the same problem. problem exists on wlan and rj45. crashed even on server. someone needs to log in before netw-manager would connect.

i run a datacenter in our headoffice, im not new to this issue. issue is networkmanager.

to prove it: set it up in yast, without networkmanager and EVERYTHING works after that.

hope this helps.


Same experience here. Networkmanager and knetworkmanager worked just fine on 10.3, but NetworkManager fails now that I migrated to 11.

If I do “rcnetwork stop” and configure the interface manually, things work just fine, using either ath_pci or ath5k.


I agree, Networkmanager worked better in 10.3. Now it is not working well with wireless networks.