Just switched to Tumbleweed!

A few days ago I decided to finally sit down and install openSUSE 11.4 on my trusty 701 Eee PC. It’s the computer I use at school and when I have to act like a hipster and work at a café. This means I only install productivity software like, Firefox, Thunderbird, LibreOffice-Writer and other handy GNOME tools. A pretty modest install.

I’ve mostly been using Fedora. Before that I used Red Hat. So I’m somewhat comfortable with using RPMs.

The reason for the switch is that I’m sick of the Fedora release cycle. I like having the latest features, and so far Fedora has provided me with that with a very stable distro. Unfortunately I’m done with “playing” with Linux. All I want is an OS that works so I can get some work done.

Upgrading to a new Fedora release is possible, but unfortunately not supported, and the process is somewhat made more complicated than it needs. With openSUSE you only have to change repos and do a ‘zypper dup’, which is supported.

After playing with openSUSE 11.4 for a while I was very pleased with it. Therefore I decided to give Tumbleweed a go.

Changed repos and did a ‘zypper dup’. Rebooted and crossed my finger. Works like a charm!

Still using good old GNOME, as I’ve read Tumbleweed and GNOME 3 isn’t the best of friends, yet. So I’ll wait when 12.1 is out.

I had tried Fedora three times. Never got it working. The badest experience was a refresh attempt for stable fedora-13 from official update repositories which broke completly. The last I tried was Fedora-15 with Gnome3, there where three glitches:

  • used only one cpu out of duo cores (the phoronix wonder patch for developers - cgroup?)
  • Gnome3-Terminal didn’t correctly output my mc-session
  • packagekit didn’t work, and I was unable without graphical gui to switch to kde, yum is pretty unknown for me

Even if you use openSUSE-factory this will be more a production system than a stable fedora release!

Yesterday I tried openSUSE-factory with an additional kde-4.7rc repository and could work without errors. Just because of my common /home/user directory together with Debian-sid and Gentoo~unstable, for now I changed back to openSUSE-tumbleweed using kde-4.6.5 …

I must’ve been very lucky with Fedora lately. Because I switched back to Linux when Fedora 9 was out, and it has worked fine since then. But I have noticed that they use “it’s a bleeding edge distro” as an excuse more and more. Kind of like Google points to their services that are marked as Beta.

What is kind of funny with Fedora 15 is that I started using it when it was Beta RC2, and that has been more stable than the final release.

Some users say that it’s the odd number release curse, but still, what you see “advertised” on Fedora.org is really not what you get in reality. Sometimes it works, but not always.

I think that is the main weakness of Fedora. It’s one of the big distros with a dev repo that is more or less unusable. Both Debian and openSUSE advice not to use their Sid or Factory repo, but still you hear people using it daily without too much trouble.

It seems though that rolling release is the natural way for the linux dekstop to go. People just want to install the OS and get updates, not having to re-install and risk messing it up via a not so safe upgrade. Yet still be able to use the latest software.

My Tumbleweed install is still working fine. Might install it on my main computer too.

Been using Tumbleweed a while and actually you can install it direct if you add the repo in SuSE Studio with(out?) Packman to, you might need to check the versions on anything you select however.

Would say you need decent band width connection for Tumble, also not take fright if you get suggestions like downgrading the kernel, it may be simply the preload-kmp-desktop is missing. The main irritation for me, is the vendor change from the rest of openSUSE repos. In means you have to watch package manager more carefully where Tumble has overtaken the Packman repo. There’s an issue with Kopete that needs sorting for instance, due to unbundling of a library from the linphone package.

The vendor change, means you can’t just “zypper up” and avoid having Packman packages replaced by higher versioned Tumble ones (but presumably without the codec support we want). Means you have as Swerdna said, follow the solver output better than has been necessary in past and understand what’s happening.

However right now, the 12.1 M2 release seems to work for me better than quite a few past “final” GM releases did at first. We’ve got 12.1 M3 in a couple of days, though I’ve not seen much factory threads about new scary packages breaking serious things.

Only deal with rpm directly on rare occasions (apart from packge building), like repairing a busted system into chroot from Live CD or something.

One thing that saves time is knowing how to navigate terminal mode YaST. <TAB> to move forward field, <Shift TAB> back, but when letters are highlighted <ALT-X> jumps you direct to the field. Quite a lot of settings use variables in shell files in /etc/sysconfig, they get picked up by YaST so you have quite a choice in options, GUI, curses or hand hacking, if you work with rather than against system.

I’d recommend turning on kernel multiversions in /etc/zypp/zypp.conf, so you can have more than one, & test out newer releases, like 3.0-rc6 from kernel repo; as well as benefit from greater margin of safety should an unhappy kernel upgrade come your way.

I tend not to find much trouble, though the Perl Bootloader is annoying me at moment, by doiung TOO much :slight_smile:


I just switched my main desktop from 11.4 to Tumbleweed, and it seems to have fixed up some irritating KDE bugs. :slight_smile:
Added Kernel:HEAD to for good measure.

The only “non obvious” thing in the upgrade was due to Packman (for Multimedia codecs), with a screw up on one of the library packages in Packman, I think. You just choose to “keep” clucene-core (best in software manager and get padlock) and use the repo view and do “switch all” to this repo, if you want Packman Multimedia.

fir:~ # uname -a
Linux fir 3.0.0-rc7-1-desktop #1 SMP PREEMPT Wed Jul 13 01:16:09 UTC 2011 (0de37e1) x86_64 x86_64 x86_64 GNU/Linux

clucene-core - CLucene is a C++ port of Lucene

Installed Version - 0.9.21-74.1
clucene-core = 0.9.21-74.1
clucene-core(x86-64) = 0.9.21-74.1

llibclucene-core0_9_23 - CLucene is a C++ port of Lucene

Installed Version - 0.9.23-0.pm.4.1
libclucene-core0_9_23 = 0.9.23-0.pm.4.1
libclucene-core0_9_23(x86-64) = 0.9.23-0.pm.4.1

It was suggesting to downgrade to 32 bit, because in Packman the package providing libclucene-core is called libclucene, but it does not provide “clucene-core” or “.libclucene.so.0”. Not bad for an upgrade to Tumbleweed and have naughty codec support. I could have done it with “zypper -v dup --from packman” taking option 2 may be, but I actually had to install libclucene-core0_9_23 by box check as well, so the GUI Software Manager helped at this stage, fixing things up.

From now on I avoid zypper dup and just generally use zypper up, to avoid unwanted package upgrades & downgrades, setting the priority on Packman helps avoid unwanted changes on “zypper dup”, I’ve acutally configured Packman/Multimedia & Essentials that way.

Anyway, KDE seems better, just means I can’t write pointless bug reports on stuff that’s already fixed. I’ve not seen too many serious Tumbleweed bugs reports and KDE4.6.5 seems like it should be in the update channel, big improvement on 4.6.0. What I ran in 12.1 M2 was probably an improvement on 11.4 anyway, though some breakage there was and perhaps more to come on Thursday with M3.

Hopefully GNOME will be sorted out in the Autumn release in similar fashion, no idea what state is at present. There’s always alternatives like XFCE & LXDE for speed and simplicity of older style environments.