Just reporting a problem of zypper update.

It’s not causing any problem for me. But I thought someone would want to know.

Failed to update zypper: The message is: PackageKit-backend-zypp-1.1.10-lp151.8.3.1.x86_64 requiert libzypp.so.1709()(64bit), mais cette dépendance ne peut pas être fournie (but this dependency can not be provided). The translation was not a part of the message …

Please post:

zypper lr -d

Please use Code-Tags for the output.

FYI =
That version of libzypp exists on my system, and was installed as part of the “libzypp” package.

Recommend running the following to force re-install the necessary package…

zypper in -f libzypp

TSU

#  | Alias                               | Nom                                | Activé | Vérification GPG | Rafraichir | Priorité | Type   | URI                                                                           | Service
---+-------------------------------------+------------------------------------+--------+------------------+------------+----------+--------+-------------------------------------------------------------------------------+--------
 1 | download.nvidia.com-leap            | nVidia Graphics Drivers            | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.1                                |        
 2 | http-download.opensuse.org-289f57b5 | home:Sauerland                     | Non    | ----             | ----       |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.1/ |        
 3 | http-download.opensuse.org-69e0d25f | YaST:Head                          | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/repositories/YaST:/Head/openSUSE_Leap_15.0/      |        
 4 | http-download.opensuse.org-858fc4cf | openSUSE:Leap:15.0:Update          | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                            |        
 5 | http-opensuse-guide.org-f03045a0    | libdvdcss repository               | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                            |        
 6 | openSUSE-Leap-15.1-1                | openSUSE-Leap-15.1-1               | Non    | ----             | ----       |   99     | rpm-md | cd:/?devices=/dev/disk/by-id/ata-HL-DT-ST_BDDVDRW_CH12LS28_K8MC61G2023        |        
 7 | packman.inode.at-suse               | Packman Repository                 | Oui    | (r ) Oui         | Oui        |   95     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.1/                              |        
 8 | repo-debug                          | Debug Repository                   | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/           |        
 9 | repo-debug-non-oss                  | Debug Repository (Non-OSS)         | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/       |        
10 | repo-debug-update                   | Update Repository (Debug)          | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.1/oss/                      |        
11 | repo-debug-update-non-oss           | Update Repository (Debug, Non-OSS) | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.1/non-oss/                  |        
12 | repo-non-oss                        | Dépôt Non-OSS                      | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/             |        
13 | repo-oss                            | Dépôt principal                    | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                 |        
14 | repo-source                         | Source Repository                  | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/          |        
15 | repo-source-non-oss                 | Source Repository (Non-OSS)        | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/      |        
16 | repo-update                         | Dépôt principal de mise à jour     | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss                             |        
17 | repo-update-non-oss                 | Dépôt de mises à jour (Non-OSS)    | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/                        |        
18 | vscode                              | vscode                             | Oui    | ( p) Oui         | Non        |   99     | rpm-md | https://packages.microsoft.com/yumrepos/vscode                                |        
sinatra@linux-h3nl:~> 


Work like a charm. I guess their is a problem with my priority setting somewhere.

You have a Version mismatch of openSUSE Version Repos, installed 15.1 but also Repos for 15.0:

 3 | http-download.opensuse.org-69e0d25f | YaST:Head                          | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/repositories/YaST:/Head/openSUSE_Leap_15.0/      |        
 4 | http-download.opensuse.org-858fc4cf | openSUSE:Leap:15.0:Update          | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/   

You should delete this Repos…

And do not use :Head Repos anymore…

Thank you, I should had spot these ones by myself.>:(