just learned of the new spins, krypton and argon


Whats the difference between tumbleweed and krypton?

Currently running KDE tumbleweed with few to no problems over time.

It’s not very clear at all in the news blog on what differences between the new spins are to tumbleweed and leap at least from what I can read.


I have downloaded, written to a USB and tried both. Oh, and I installed krypton.

Krypton is basically Tumbleweed with 4 additional repos:

KUA: KDE unstable applications
KUE: KDE unstable extras
KUF: KDE unstable frameworks
Qt55: A QT5.5 devel repo.

They bring this software before it is completely tested. And “argon” is similar, except that it has its additional repos based on Leap instead of Tumbleweed.

Booting Krypton from the iso (on a USB), there were lots of screen artifacts. Turning off desktop effects fixes that.

After installing, then updating (with “zypper dup”, the screen artifacts are gone. It’s possible that they were due to some graphics libraries not being on the iso, but added with the update. Krypton also includex xen, which I don’t know much about.

I also booted Argon from the USB. It froze soon after the GUI came up. I then rebooted with


on the kernel command line. It boot and ran fine that way, but complained about running out of disk space.

So I use Yast to reformat the hybrid partition (partition 3 on the USB) from “btrfs” to “ext4” (with no journal). With that change it booted fine and did properly use persistent storage. No screen artifacts. But maybe space wasn’t as tight. I don’t think xen was included, though I could be wrong.

Note that krypton used “ext2” for the hybrid partition, though it was mounted as if “ext4”. Apparently “btrfs” is currently causing problems for the hybrid (persistent storage) partition.

Installing krypton was similar to a typical install from a live KDE iso.

There’s a problem with the repos on the argon iso that I downloaded. The update-nonoss uses “updaet” where it should be “update”. Easy to fix, and that repo is usually empty anyway. And I think it was the KUE repo that showed as no existing. I found what looked to be the correct url to fix it. But I have to boot that USB to find out what I used.

I have not yet had time to try what is there. I do note that konqueror5 appears to be there. But “yakuake” is still the KDE4 version.

That’s a very detailed report Thank you very much.

It sounds like it is also a rolling release (krypton) with different kde repos.

I’ll have to give it a try, sounds like a rockier but maybe better kde spin.

Again thank you for such a detailed report.


I’m expecting occasional breakage. But Icewm is not in the unstable repos, so it should be a stable fallback option if something goes wrong with KDE.

If I think of it, I’ll post the output of “zypper lr -d” tomorrow. I’m guess that it is sufficient to setup the new repos with appropriate priority, and then do “zypper dup”. That should bring an existing tumbleweed up to krypton.

Not only that.
This is unreleased software (not even Beta), “daily” (some call it “nightly”… :wink: ) development snapshots directly taken from KDE’s git repos.

I have not yet had time to try what is there. I do note that konqueror5 appears to be there. But “yakuake” is still the KDE4 version.

yakuake is available as KF5 version, but the package is called yakuake5 and will not automatically replace the KDE4 version at the moment.

Yes, basically.
But those repos are not new at all, KDE:Unstable:Frameworks and KDE:Unstable:Applications exist since two years, and KDE:Unstable:Extra since ever I remember.

See also:

Oh, and I forgot this before, here’s the Argon/Krypton announcement:

By “new”, I only meant that they were additions to what is normally in Tumbleweed.

I still have a standard Tumbleweed install. My “krypton” install is in a separate partition (really, a separate LVM volume). I’m treating it as a way of seeing what is there as work-in-progress.

So maybe I should try yakuake5, in the spirit of such testing.

Ok, and I meant that this is something you already could do before Krypton existed…

The main “new” thing about Krypton (and Argon) is that they are LiveCDs. You don’t have to install them but can just boot from them and try out the latest from KDE.
If you install them, the additional unstable repos get added automatically though (as you wrote), so you will save this step by using Krypton as installation disk.

So maybe I should try yakuake5, in the spirit of such testing.

Well, yakuake5 actually hasn’t changed in months, it should be stable.
Of course it uses the KF5 based konsole (konsole-part) instead of the KDE4 based one (konsole4-part). So in the end you test the unstable konsole devel snapshot mostly by using yakuake5… :wink:

PS: regarding konqueror5, kwebkitpart is still missing, so you are constrained to using KHTML. I do build a package of the KF5 port since about half a year, I suppose I should finally submit it to KDE:Unstable:Applications… I will do that in the next days.

Thanks. I hadn’t noticed that, but I didn’t do much testing.

I did notice that it failed to pickup the old bookmarks from the kde4 version.

Yeah, it probably doesn’t automatically migrate them (yet?).
But you should be able to import the ones from the KDE4 version, or just copy over ~/.kde4/share/apps/konqueror/bookmarks.xml to ~/.local/share/konqueror/ (or copy the whole folder if you want to keep e.g. the history too).

I knew we could add the kde repos , what was new to me was the live usb / install.

I have it installed into a VM now also and it looks good.

I will continue to keep it in a VM to play with and break but for my everyday uses it will be standard kde tumbleweed at this point.

Can we call Tumbleweed standard what a question :slight_smile: but it is more stable than many other distros out there.

I need something somewhat stable and Tumbleweed has been very stable with little breakage and even then it never lasted long.

I installed yakuake5, which required uninstalling the kde4 version. It worked fine. It seemed to pick up the configuration from the kde4 version. Or, at least, it picked up the key strokes that cause it to show. It might have picked up other configuration from konsole5.

And the first problem showed up today. I updated to snapshot 20160223. And now “kwallet” won’t open (complains about a possible dbus library issue).

And here’s the output from “zypper lr -d”:

# | Alias        | Name                     | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                            | Service
1 | KUA          | KUA                      | Yes     | (r ) Yes  | Yes     |   75     | rpm-md | http://download.opensuse.org/repositories/KDE:/Unstable:/Applications/KDE_Unstable_Frameworks_openSUSE_Factory |        
2 | KUE          | KUE                      | Yes     | (r ) Yes  | Yes     |   75     | rpm-md | http://download.opensuse.org/repositories/KDE:/Unstable:/Extra/KDE_Unstable_Frameworks_openSUSE_Factory        |        
3 | KUF          | KUF                      | Yes     | (r ) Yes  | Yes     |   75     | rpm-md | http://download.opensuse.org/repositories/KDE:/Unstable:/Frameworks/openSUSE_Factory                           |        
4 | Qt55         | Qt55                     | Yes     | (r ) Yes  | Yes     |   50     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt55/openSUSE_Factory                                           |        
5 | repo-non-oss | openSUSE-Factory-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/non-oss/                                                             |        
6 | repo-oss     | openSUSE-Factory-Oss     | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/oss/                                                                 |        

Hmm, I hadn’t previously noticed, but there’s no “update” repo there. It’s rarely used, but it was recently used to push a glibc security update.

Interesting names :slight_smile:

Argon - stable but never updates.

Krypton - may explode at any moment.

Krypton: the home of superman.

There are updates.

The KDE packages are the same anyway and change daily.

The standard system is based on Leap 42.1+Updates and gets updates when there are updates for Leap 42.1 obviously.
So mostly security and bugfix updates.

I have a suspicion what the reason for this might be:
I noticed today that KDE:Unstable:Frameworks is now built against KDE:Qt56, i.e. Qt 5.6, and the packages require that. With Qt55 there are conflicts and not all packages will be updated, so you may run into problems caused by incompatible packages.

So try to change the Qt55 repo to Qt56 (replace that in the URL), and do a full upgrade.


I updated this morning, to 20160224. And I added the update repo (for glibc). Between those, that fixed the problem with kwallet.

However, I did run into some conflicts, which I resolved by keeping the old version. So I’ve no changed the URL as you suggested, and I’m running “zypper dup”. That’s updating a lot of stuff (but no conflicts). I’ll see shortly whether kwallet stays fixed or ends up broken again.

Hmm, the attempted update failed on a checksum problem with “libsignon-qt5-1” from KUF repo. Maybe I hit the repo in the middle of a rebuild or something. I’ll try again later.

I gave Krypton.x86_64-5.5.90-Build25.12 and Argon.x86_64-5.5.90-Build18.2 a try on both my HP 17T_J1H37AV Optimus laptop & Asus X-99 Deluxe Viper Desktop. I made the usb’s using “imagewriter”.

Both work very well on my laptop using “nomodeset” and I found that the update persistence work great – very nice.

On my desktop, I found that krypton booted well, but, seemed to be running slow – mouse was leaving trails; after the persistent update on the laptop and a second try on my desktop, that greatly improved (may be because I’m running 4 displays). Krypton is a keeper.

However, I found that argon only booted to the login screen – even after the persistent update on my laptop. I guess there is something in my desktop’s bios that is causing problems. I did not try anything but the default login with various liveCD passwords to no avail. I think I did see the word “panic” flash during the boot process. I will continue to play with it as time permits.

FYI, kwebkitpart is now in the KDE:Unstable:Applications repo (without translations for now though), and konqueror recommends it.
So if you update your system, you should again be viewing web pages using WebKit (this time Qt5WebKit…). :wink:

Will/should probably be pulled in automatically into new rebuilds of the LiveCD images too.

Thanks. I’ll give that a try.