Just installed openSUSE

I think I may have some sort of kernel error? I JUST installed openSUSE 13.1, and when it rebooted it froze completely, then booted into a blackscreen saying all kinds of stuff. The caps lock flashes on and off repeatedly also when this happens. :frowning: Any advice? I took a picture, but my phone isn’t the best for taking pictures.

I can’t find anywhere on the forum to post pictures from my phone, so if you need any more info let me know and I can boot it up again and write down a little stuff the “black screen of death” gives me.

For posting pictures you have to use a image hosting site like http://susepaste.org f.e.

Have you tried to select “Recovery Mode” in the boot menu? (under “Advanced Options”)
Maybe it boots then?

recovery mode seems to work, so how would I get the regular desktop mode to work?

What video card or chip do you have? You will need to install a driver but we don’t know which

Thanks. I’m using AMD Radeon HD 8400. Will installing a driver work in recovery mode?

Yes.
You can find instructions for installing the driver here:
https://en.opensuse.org/SDB:AMD_fglrx

Thank you very much. This will deffinitly fix the delays in things. This will fix the freezing into desktop and capslock blinking thing too?

If it was caused by the graphics driver, then yes.

But it’s hard to say without any error message.

It’s at least worth a try. Most such problems are related to the graphics driver I’d say.

It is worth a shot. I’d say it was probably a driver issue if it let me boot to the recovery mode and not the desktop. It’s installing additional updates with the fglrx driver.

Well, recovery mode also sets some other kernel options to be more compatible with all hardware and prevent problems, not only the graphics driver.

But you can still boot to recovery mode afterwards, even when installing fglrx doesn’t help, so you don’t really lose anything by trying (except for a bit of time maybe :wink: ).

And with your graphics card, fglrx should be the better option than the open source driver that’s shipped with openSUSE 13.1 IMHO anyway.

I’ve always had better performance with the fglrx :slight_smile:

The driver is done installing, but I’m getting other system updates out of the way before rebooting just in case. :slight_smile:

Update: Installing the driver and additional updates worked like a charm! There’s just 2 problems, but one of importance. The other one I can figure out later on my own, not a big deal. The one I have questions for is that when I watch youtube full screen now it only gives me a blue screen on google chrome. Going to test it on firefox.

And it works in windowed mode?

If it’s the flash version, you could try to disable hardware acceleration, right-click on the video and select “Settings” for that.

Or try using the HTML5 version, but in this case you might have to install additional codecs.
See here for a 1-click install f.e.:
http://opensuse-community.org/

To try the youtube HTML5 version, browse to:
http://www.youtube.com/html5